Menu

Excel:Somme de valeurs journalière d'un mois [Résolu/Fermé]

- - Dernière réponse :  Niccow - 13 juil. 2010 à 22:32
Bonjour,

Je n'arrive pas à programmer la chose suivante sur excel simplement:
A chaque jour correpond un chiffre dans mon tableau. Je voudrais pouvoir sommer (ou moyenner) automatiquement toutes les valeurs d'un mois, sachant que tous les mois n'ont pas le même nombres de jours...

Auriez-vous une idée? Et si possible sans macro ni VB...

Merci d'avance!

Nicolas



Afficher la suite 

10 réponses

Meilleure réponse
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
987
1
Merci
re,

Ci-joint une solution :
http://www.cijoint.fr/cj201007/cijdZeAPgO.xls
Si vous n'avez besoin de rien, demandez-moi.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39098 internautes nous ont dit merci ce mois-ci

Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
987
1
Merci
=SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*($C$3:$C$732)) :


SOMMEPROD est une fonction matricielle qui travaille sur des plages. SOMMEPROD (voir l'aide d'excel) fera la somme des produits des matrices présentées.

MOIS(G9)=MOIS($B$3:$B$732) renverra 1 si l'égalité est vraie et ce pour chacune des lignes de la plage.

Donc SOMMEPROD fera la somme de chaque ligne de la plage $C$3:$C$732 multiplié par le test (qui renvoi 1 pour chaque égalité vraie de la plage correspondante dans B. Autrement dit : la somme des valeurs de la plage C si en B l'égalité est vraie.


Pour la moyenne, le principe est exactement le même Somme des valeurs divisées par le nombre de dates qui n'ont pas de valeurs nuls en correspondance. Le tout dans un test pour éviter d'avoir des valeurs #DIV0...)

pour des explications plus claires sur SOMMEPROD.. :

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#sommeprod

Si vous n'avez besoin de rien, demandez-moi.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39098 internautes nous ont dit merci ce mois-ci

Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
987
0
Merci
bonjour,

pour aller vite :

Vous pouvez déposer un fichier exemple (sans infos confidentielles) sur http://www.cijoint.fr/ et coller le lien fourni par le site sur votre prochain message
Messages postés
4401
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
29 décembre 2014
1672
0
Merci
Salut,

tu fais ton tableau en fonction du mois qui a le plus de jours et au bout tu prends une cellule pour faire ta somme et une pour ta moyenne

Maintenant tout dépends comment est fait ton tableau. Si tu pouvais mettre ton fichier sur http://www.cijoint.fr sans donnée personnelles et nous coller le lien ici ce serait plus facile de t'aider :) Et dit nous avec qu'elle version excel tu travailles.

Bonne journée
Messages postés
63
Date d'inscription
jeudi 11 février 2010
Statut
Membre
Dernière intervention
4 décembre 2010
9
0
Merci
Bonjour,

Comment sont réparties tes données?
les mois en colonne et une ligne par jour? Comme pour un calendrier?

Dans ce cas, dans la ligne sous ton tableau (ou autre part...)fait simplement une somme ou une moyenne de tes chiffres au dessus :

=MOYENNE(C1:C100)
=SOMME(C1:C100)

Par contre fait bien attention à ce que les jours inexistants, dans tes mois avec moins de jours, ne correspondent pas à un 0. Sinon le 0 sera pris en compte pour faire ta moyenne et faussera tout.

Bonne chance!

Beeloobop
0
Merci
Bonjour,

Voila le lien: http://www.cijoint.fr/cjlink.php?file=cj201007/cijiltW0Rn.xls

J'espère avoir été clair.

Merci d'avance.
0
Merci
Re-bonjour,

Je travaille sur Excel 2007 mais le classeur doit trouner sous Excel 2003.

ET pour ce qui est des moyennes ou sommes simples, (=MOYENNE(C1:C100) ou
=SOMME(C1:C100) ) je ne veux pas les utiliser car je veux que tout ce fasse automatiquement, c'est à dire que la formule sélection elle même les case correspondant au mois, car chaque mois à un nombre de jours différents et qui pevent différer suivant les années... (février).

Merci.

Je vous retransmet le liens où j'ai mis un exemple:
http://www.cijoint.fr/cjlink.php?file=cj201007/cijiltW0Rn.xls
0
Merci
Merci beaucoup, mais pourrait tu m'espliquer la formule s'il te plait, pour que je puisse la comprendre et la reproduire indéfiniment :)

Je n'ai jamais utilisé cela

=SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*($C$3:$C$732))



=SI(SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*($C$3:$C$732<>0)*1)=0;"";SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*($C$3:$C$732))/SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*($C$3:$C$732<>0)*1))

Merci d'avance!!!!
Messages postés
48871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2019
16142
0
Merci
Bonjour Niccow.

Si les formules compliquées te rebutent, tu peux aussi t'en tirer en ajoutant une colonne (que tu pourras toujours masquer) :

En D3 la formule =MOIS(B3)&"/"&ANNEE(B3)
En H9 la formule =SOMME.SI($D$3:$D$732;D3;$C$3:$C$732)

Ces formules sont à recopier vers le bas.
Raymond PENTIER
Messages postés
48871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2019
16142 -
P.S. => Pourquoi te casser la tête à fusionner B3 et B4, et recommencer dans 729 cellules, alors qu'il te suffisait
soit d'augmenter la hauteur de toutes les lignes de la feuille (ctrl+A puis Hauteur de ligne 30)
soit de sélectionner la colonne A qui est vide et mettre comme taille de police 22 au lieu de 11
Si j'ai fait ca, c'est que mes raisons... :)
Je travaille sur un excel avec des données dessus depuis plusieurs années, donc, ca me prendrait des jours pour tout refaire, et je commétrait des erreurs en recopiant.... voila voila
Merci pour l'astuce!
0
Merci
Ok, merci, mais j'ai un autre soucis, car en fait c'est sur plusieurs années...
J'ai oublié de le préciser, désolé...

Et du coup, ça me somme toutes les valeurs des mêmes mois de chaque année...

Mais j'ai trouvé une solution en concaténant avec le mois et l'année... Ca à l'air de fonctionner. L'aide d'excel n'est pas très utile pour cette fonction, même pas du tout...

Merci beaucoup!
dobo69
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
987 -
alors on rajoute une condition à SOMMEPROD (qui en 'prend' autant qu'on veut...)

=SOMMEPROD((MOIS(G9)=MOIS($B$3:$B$732))*(ANNEE(G9)=ANNEE($B$3:$B$732))*($C$3:$C$732))

le * étant équivalent à ET, si on veut une 'condition' OU : +