Erreur mail en php [Fermé]

Signaler
-
 amal -
Bonjour,


je peux savoir pourqoi quand j utilise la fonction mail pour envoyer un message je trouve cette erreur

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\etudiants\mail.php on line 122

6 réponses

Messages postés
73
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
19 juin 2010
7
Bonjour,

Essayes de spécifier dans ton php.ini l'adresse du serveur SMTP de ton fournisseur d'accès exemple smtp.orange.fr.

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86877 internautes nous ont dit merci ce mois-ci

Messages postés
18375
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
4 141
Il te faut un serveur SMTP.
MERCI POUR LA REPONSE JE PEUX SAVOIR COMMENT AJOUTER UN SERVEUR SMTP ????????
ChrisCompote
Messages postés
73
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
19 juin 2010
7
edites ton php.ini et cherches SMTP
Exemple :
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

remplace localhost par smtp.orange.fr

Si tu n'es pas chez orange, je te laisse chercher l'adresse du serveur SMTP, le plus courant smtp.monfai.fr
Messages postés
18375
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
4 141
Fais comme Chris te l'a dit : utilise le SMTP de ton FAI, c'est ce qu'il y a de plus simple.

Pour le connaître :
http://www.commentcamarche.net/...
merci ChrisCompote j ai bien essayée la solution que tu m as proposé et ca marche pas j ai le meme probleme

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()
ChrisCompote
Messages postés
73
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
19 juin 2010
7
Visiblement, il y a toujours localhost dans le php.ini
Soit tu n'édites pas le bon fichier,
Soit tu n'as pas redémarrer les serveurs (ou services)

Essayes aussi en mettant en haut du script
ini_set('SMTP','smtp.monfai.fr');
Chris j ai appliqué ca


ini_set('SMTP','smtp.monfai.fr');
[mail function]
; For Win32 only.
SMTP = smtp.monfai.fr
smtp_port = 25

mais une donne erreur

Warning: mail() [function.mail]: "sendmail_from" not set in php.ini or custom "From:" header missing in
désolée de vous déranger :)
ChrisCompote
Messages postés
73
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
19 juin 2010
7
Tu ne me déranges pas.

Poursuis la configuration :
Avant l'appel à la fonction mail, déclare dans les headers l'expéditeur, tu met
$headers = 'From: "Mon Nom"<monadressemail@monfai.fr>\r\n'; 
mail($to, $subject, $message, $headers);

Met bien ton adresse mail à la place de monadressemail...
avion-f16
Messages postés
18375
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
4 141
init_set() est une fonction PHP, pas une directive du php.ini
Si tu es sous Vista/7, tu ne peux peut-être pas modifier le fichier : il faut les droits de l'administrateurs.
Copie le fichier sur ton bureau, modifie, enregistre, et recopie le dans le bon dossier : il te demandera si tu veux le remplacer, et encore une autre confirmation pour les droits.
désolée mais quand j ai ajoutée le header de l 'expéditeur j ai tombée dans l erreur que j ai rencontrée la premiere fois

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()

@avion-116 je travaille sous windows XP