Menu

Excel, remplacer un "X" par un "1" [Fermé]

Messages postés
91
Date d'inscription
mercredi 19 mai 2010
Statut
Membre
Dernière intervention
2 juin 2016
- - Dernière réponse : fifou69
Messages postés
91
Date d'inscription
mercredi 19 mai 2010
Statut
Membre
Dernière intervention
2 juin 2016
- 1 juin 2010 à 15:14
Bonjour,

Vous me direz, ton titre rappelle étrangement un paquet de questions intulées "Convertir des lettres en chiffres ou vice versa"

C'est vrai! Mais de mon côté, mon problème reste... un problème!

Voila, d'un côté j'ai 5 colonnes avec le choix de chauffage (électricité, gaz naturel, mazut etc.). D'un autre j'ai 2500 lignes avec des appartements... Or, la personne, qui m'a donné ce fichier excel, a coché ses choix par des "X" et cela me gène pour calculer les totaux de chacun (Combien d'appartments utilisent le gaz naturel par exemple)!

Je n'arrive pas à additionner des X donc j'aimerais bien les remplacer par des 1. Mais faire ça sur 2500 lignes, ça risque de me prendre du courage digne d'Aragorn...

Est-ce que cela est possible? Si oui, quelqu'un peut-il m'aider?

Merci pour votre aide!

Florian

Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
16917
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
2 juillet 2019
3513
3
Merci
Salut,

Il est possible de modifier le X en 1, mais il est possible également de conserver le fichier dans l'état et compter les X

exemple en plage de A1 à A300 avec cette formule

=NB.SI(A1:A300;"x")

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 53045 internautes nous ont dit merci ce mois-ci

Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
657
3
Merci
bonsoir,

1) remplacer des "X" par des 1 :
Edition -> remplacer -> X dans 'rechercher' et 1 dans 'remplacer'....
'remplacer tout'

2) compter des X dan une colonne B (par exemple)
=NB.SI(B:B;"X") ou bien sur : =NB.SI(B2:B2500;"X") ....

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 53045 internautes nous ont dit merci ce mois-ci

Messages postés
3252
Date d'inscription
jeudi 23 août 2007
Statut
Membre
Dernière intervention
18 mai 2013
523
0
Merci
bonsoir,
je crois qu'avec la fonction =NB.SI(plage;"X") tu as ce que tu cherches.

ceci va donner le nombre de "x" ou "X" qui se trouvent dans la plage de cellules indiquée.
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3597
0
Merci
bonjour

Tu peux additionner le nombre de X avec SOMMEPROD.

Tu peux mettre 1 au lieu de X avec la fonction "remplacer" (ctrl + h) après avoir sélectionné ta plage et il te suffit de cocher "totalité de la cellule" et cliquer sur "remplacer tout".
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
657
0
Merci
bonsoir à tous !
et ben fifou tu peux dire merci...:-D
3 réponses en 2 minutes...
Pacorabanix
Messages postés
3252
Date d'inscription
jeudi 23 août 2007
Statut
Membre
Dernière intervention
18 mai 2013
523 -
bah, il est poli, il est clair, et il ne fait pas de faute de français, c'est tellement rare... tout le monde veut se l'arracher ;)
dobo69
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
657 -
oui et super bien expliqué son problème aussi...
fifou69
Messages postés
91
Date d'inscription
mercredi 19 mai 2010
Statut
Membre
Dernière intervention
2 juin 2016
1 -
Merci pour les compliments! Mais l'honneur vous revient car pour trouver ce type de formule... sur internet... comme on dit chez nous "Chaud pélo!"

Pensez-vous qu'il existe un site internet ou guide ou livre sur l'usage des fonctions d'Excel? Je suis peut-être un peu trop optimiste car il faudrait très probablement une bibliothèque pour mettre en avant les possibilités offertes avec Excel mais bon, on ne sait jamais...
dobo69
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
657 -
fifou69
Messages postés
91
Date d'inscription
mercredi 19 mai 2010
Statut
Membre
Dernière intervention
2 juin 2016
1 -
Bientôt une journée de travail achevée pour vous, la mienne ne fait que commencer!

Merci pour les liens, je pense que j'ai de quoi m'occuper avec ça :)
Messages postés
16917
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
2 juillet 2019
3513
0
Merci
Oui mais il ne suit pas sa discussion
Messages postés
91
Date d'inscription
mercredi 19 mai 2010
Statut
Membre
Dernière intervention
2 juin 2016
1
0
Merci
si si!!

Dsl de ce retard, c est juste que je suis au Canada donc je me tape 6 heures de décalage...

Effectivement, je vous remercie grandement pour votre aide! Rapide et efficace!