Debian 5 fr / PuTTy, soucis d'affichage 8^( [Résolu/Fermé]

Signaler
Messages postés
127
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
21 septembre 2012
-
 Hells_Dark -
Bonjour à tous,

J'accède à mon serveur Debian par l'intermédiaire de PuTTy, mais les caractères avec accents sont représentés sous forme bizarre...

un exemple :
Quand lâoption defaults est utilisée, update-rc.d crée des liens 
pour démarrer un service dans les niveaux de fonctionnement  2345 
et  des  liens  pour arrÃ


J'ai tenter de changer le charset sous PuTTy en UTF-8 comme indiquer la sans succès: https://www.commentcamarche.net/forum/affich-2438101-probleme-affichage-en-ssh

Connaitriez-vous un réglage (sur PuTTy ou Debian) qui permette d'avoir les caractères accentués en utilisant Putty ?

5 réponses

Messages postés
43481
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
5 décembre 2019
4 700
Re-

J'ai tenter de changer le charset sous PuTTy en UTF-8 comme indiquer la sans succès: https://www.commentcamarche.net/forum/affich-2438101-probleme-affichage-en-ssh

Je viens de faire l'expérience sur une Ubuntu 10.04 serveur fraichement installée, avec des locales en "fr_FR.UTF-8" et un putty en "iso-8859-1" et donc un affichage qui gère mal les accents.

Par contre en passant putty en UTF-8 c'est nickel, mais il faut bien penser à sauvegarder sa session après avoir modifié l'encodage et avant de lancer putty, sans quoi c'est les paramètres de la session en cours qui sont utilisés...

Donc, en imaginant une session sauvegardée sous le nom de Toto :

- Lire la session Toto (Load)
- Modifier l'encodage (UTF-8)
- Sauvegarder la session Toto (Save)
- Lancer la session Toto (Open)


;-))
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 73922 internautes nous ont dit merci ce mois-ci

Haaa, merci :)
Ca fait un moment que je cherche... j'avais zappé les histoires de sauvegarde ^^'
Messages postés
127
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
21 septembre 2012
39
Ma Debian est en UTF-8

la commande "locale" renvoi ceci :

dom@debian-01:~$ locale 
LANG=fr_FR.UTF-8 
LC_CTYPE="fr_FR.UTF-8" 
LC_NUMERIC="fr_FR.UTF-8" 
LC_TIME="fr_FR.UTF-8" 
LC_COLLATE="fr_FR.UTF-8" 
LC_MONETARY="fr_FR.UTF-8" 
LC_MESSAGES="fr_FR.UTF-8" 
LC_PAPER="fr_FR.UTF-8" 
LC_NAME="fr_FR.UTF-8" 
LC_ADDRESS="fr_FR.UTF-8" 
LC_TELEPHONE="fr_FR.UTF-8" 
LC_MEASUREMENT="fr_FR.UTF-8" 
LC_IDENTIFICATION="fr_FR.UTF-8" 
LC_ALL=
Messages postés
50
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
26 octobre 2010
13
Bonjour,

Tu dois utiliser l'encodage ISO-8859-15. Tu auras les caractères accentués et le signe €.
Messages postés
127
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
21 septembre 2012
39
Merci pour l'info,

Donc j'ai créer une nouvelle Session à la page d'accueil de PuTTy pour être sur que le réglage soit bien pris en compte, après redémarrage de PuTTy le format ISO-8859-15 est bien paramétré.

Mais j'ai toujours les caractères qui s'affiche anormalement, je ne vois pas d'où cela peut venir :/
jipicy
Messages postés
43481
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
5 décembre 2019
4 700
Salut,

Et quel est l'encodage de ta Debian ? (locale)
Messages postés
127
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
21 septembre 2012
39
Merci à tous,

Pour vérifier si sa fonctionne j'utilisai "man update-rc.d" car ce fichier contient beaucoup d'accents ors il se trouve que c'est l'une des rares pages du manuel qui affiche mal les accents chez moi (j'ai mis du temps à m'en rendre compte ...).

Sinon dans l'ensemble les accents s'affiche bien avec PuTTY et ma Debian en UTF-8, sa va être beaucoup plus agréable à lire maintenant ^^

merci encore, bonne journée.