Problème de chiffre dans renvoi aux figures [Fermé]

-
Bonjour,

(Je travail dans Microsoft office word 2003)

Je sais que pour éviter que le renvoi à une figure n'écrive le mot "Figure" il faut ajouter \*arabic dans le code champs. Ça marche généralement mais dans mon cas le numéro de chapitre est inclut. Ce qui fait que lorsque j'ajoute \*arabic dans le code champs de "Figure 2-4", celle-ci devient simplement "6" au lieu de "2-4" comme j'aimerais. Pourquoi word additionne-t-il les deux chiffres et comment puis-je régler ce problème.

Merci beaucoup. Votre aide sera très apprécié et pourrait m'aider à finir ma thèse.
Afficher la suite 

2 réponses

Messages postés
856
Date d'inscription
jeudi 21 janvier 2010
Statut
Membre
Dernière intervention
2 mai 2013
289
0
Merci
Bonjour,

Je ne sais pas si je comprends bien ton problème parce que je ne sais pas comment sont nommées tes figures, mais je me demandais pourquoi, pour faire tes renvois, tu n'utilisais pas la fonction Signet ?
Si jamais :
- tu sélectionnes le nom de ta figure (ou les termes qui nomment ta figure)
- tu vas dans Signet, tu l'ajoutes
- tu te positionnes à l'endroit où tu veux mettre ton renvoi
- tu vas dans Renvoi, tu cliques sur le signet
Messages postés
15431
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
8667
0
Merci
Bonjour,

"Je sais que pour éviter que le renvoi à une figure n'écrive le mot "Figure" il faut ajouter \*arabic dans le code champs. Ça marche généralement "

Je ne sais pas d'où tu tiens ça, mais le commutateur \* arabic n'a jamais eu pour but de supprimer le mot "figure" dans un renvoi à une légende.
Ce commutateur permet simplement d'afficher des numérotations ou des montants en chiffres arabes, comme le commutateur \* ROMAN affiche ces mêmes nombres en chiffres romains.

Donc, dire que ça marche généralement... c'est impossible !
D'autant plus que, par défaut, les légendes étant numérotées avec un chiffre arabe, ce commutateur est mis par défaut.

Une légende automatique est composée d'un champ SEQ et éventuellement précédé d'un champ REFSTYLE suivi du titre courant.
Toutes les légendes sont dotées d'un signet caché, et le renvoi est un champ REF qui fait appel à ce signet masqué. Si l'on fait un renvoi plutôt au numéro de la page, Word insère un champ PAGEREF.

Tout ça pour te dire que le mot Figure ne peut être dissocié, car il fait partie entièrement de ce signet masqué.
Une solution serait, dans le renvoi, de mettre le mot avec un attribut masqué pour la police.

Une autre solution consiste à séparer, dans la légende elle même, le mot Figure et la numérotation par un séparateur de style (Alt+Ctrl+Entrée). C'est peut être plus simple.

Sinon, c'est la solution manuelle que t'as donnée Sylvie.

m@rina

- "Sur le forum bureautique, on pose des questions concernant la bureautique..."
- "Ah bon ???"