Problème publipostage Office 2007 [Résolu/Fermé]

- - Dernière réponse :  jipidi - 20 avril 2010 à 17:56
Bonjour, je fais les bulletins d'une école par publipostage Excel-Word 2007). Pour signaler un élève absent on doit encoder "a" et mon tableau tient compte de ce paramètre mais lorsque j'effectue le publipostage pour l'impression des bulletins, je me retrouve sans raisons apparentes avec des "a" logiquement mais également des "0" qui ont remplacé les "a". Ainsi sur le même bulletin il y a des "a" et des "0" sous Word 2003 je n'avais jamais rencontré ce problème.
Merci de vous intéresser à mon problème pas vital mais gênant ;-)


Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
15404
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
17 septembre 2019
8660
1
Merci
Rebonsoir,

Bon, après avoir testé, le verdict est le suivant : encore des problèmes avec cette cochonnerie d'OLE !
La solution est d'utiliser le protocole DDE. Même s'il peut être moins souple, il ne présente pas ces problèmes de formatage !

Ferme ton fichier Excel puis, dans ton fichier Word, depuis la barre d'outils Publipostage, clique sur le bouton Ouvrir la source de données (2e bouton à gauche). Choisis à nouveau ton fichier Excel et choisis bien DDE (et non pas OLE).

J'ai mis plus de détails ici :
http://faqword.com/...
en particulier pour pouvoir choisir le protocole.

J'ai testé et ça résout le problème.

m@rina

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60169 internautes nous ont dit merci ce mois-ci

je vais tester... MERCIIIIIIIIIIIIIIIIIIII
Messages postés
856
Date d'inscription
jeudi 21 janvier 2010
Statut
Membre
Dernière intervention
2 mai 2013
289
0
Merci
Bonjour,

Fais apparaître tes codes de champs dans ton document principal en cochant la case "code de champs" dans Outils/options/Affichage :

Si tu as quelque chose de cette nature :
{ IF {MERGEFIELD absence } = "a" "a0" "" }

enlève le 0
Messages postés
856
Date d'inscription
jeudi 21 janvier 2010
Statut
Membre
Dernière intervention
2 mai 2013
289
0
Merci
Zut, je n'ai pas vu que ta source venait d'Excel.
Dans ce cas, je pense que c'est lié mais je ne sais pas que faire là. Je suis désolée. J'espère que quelqu'un prendra la main.
Ce qui est étonnant c'est que dans le publipostage, pour un même bulletin il affiche le "a" logiquement mais pour un autre cours il met 0 à la place de a... enfin merci pour la tentative d'aide :-)
Messages postés
15404
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
17 septembre 2019
8660
0
Merci
Bonjour,

Vu qu'il n'y a aucune interférence entre un a et un 0... C'est difficile de te répondre sans voir ni le fichier Word ni le fichier Excel.

m@rina
je veux bien te les envoyer mais je dois enlever une série d'infos qui concernent l'école et les élèves.
Mais il me faut ton adresse mail
m@rina
Messages postés
15404
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
17 septembre 2019
8660 -
Tu retires tout ce qui doit rester confidentiel. Pour le fichier Excel, une extraction de la base suffit avec quelques lignes typiques et tu mets tout ici :
http://cjoint.com et tu n'oublies pas de donner le lien.
m@rina
voilà le lien http://cjoint.com/?estHLEhGw1 . Pour plus de facilité copie les 2 fichiers dans c:\2i et quand tu fais le publipostage regarde l'élève 12 ou 13 (je ne sais plus) les a et les 0 se côtoient. Merci d'avance
deuxième lien http://cjoint.com/?estK4w731t ainsi tu as les 2 fichiers... :-)
0
Merci
résolu mais pas sans problèmes (plus lent, et liste des destinataires ne reste pas en mémoire ...