RechercheV avec feuille variable [Résolu/Fermé]

Messages postés
2040
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
14 décembre 2016
-
Bonjour à tous !
j'ai un soucis avec excel 2003 lors de ma requete recherchev


Quand je fais
=RECHERCHEV(AO4;GD!$C$1:$L$20;4;0)

GD étant une feuille de mon fichier et la cellule AO4 contient la valeur cherchée

Et quand je fais
=RECHERCHEV(AO4;N4&"!$C$1:$L$20";4;0)
j'ai l'erreur #valeur

La cellule N4 contient le nom de la feuille dont je veux faire ma rechercheV


Quelqu'un peut m'éclairer ? Merci

Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
304
Date d'inscription
mercredi 21 mai 2008
Statut
Membre
Dernière intervention
18 février 2016
40
1
Merci
Bonjour,

Pour entrer une plage en prennant des données externe, j'utilise la fonction ADRESSE.

je pense que tu peux y arriver comme ça.

a+

jéjé

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57832 internautes nous ont dit merci ce mois-ci

ratikuss
Messages postés
2040
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
14 décembre 2016
216 -
J'ai fait
=RECHERCHEV(AO4;ADRESSE(3;3;;;N4);4;0)
et toujours la même erreur

la fonction adresse ne peut pas m'aider car elle cible une cellule

Pour résoudre mon problème je voudrais juste une astuce qui renderai ma feuille variable
jejelefou
Messages postés
304
Date d'inscription
mercredi 21 mai 2008
Statut
Membre
Dernière intervention
18 février 2016
40 -
En effet, ce n'est pas la bonne piste,

Essai celle là maintenant :

=RECHERCHEV(AO4;INDIRECT(N4&"!$C$1:$L$20");4;0)
ratikuss
Messages postés
2040
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
14 décembre 2016
216 -
lol je venais justement dire que j'avais trouvé, c'est exactement ce que tu as mis.
Merci beaucoup pour ton soutien jejelefou.
jejelefou
Messages postés
304
Date d'inscription
mercredi 21 mai 2008
Statut
Membre
Dernière intervention
18 février 2016
40 -
avec plaisir, noublie pas de cloturer le post

a+

jéjé