[Excel] Tester le contenu texte d'une cellule [Résolu/Fermé]

Signaler
-
pijaku
Messages postés
12261
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
19 février 2020
-
Bonjour à tous,

Mon pb semble simple, mais impossible de le résoudre de manière optimale d'après mes recherches.

La colonne A contient des phrases (de texte )
Je veux savoir dans la colonne B si la cellule correspondante en A contient le mot "lulu" ( pas forcément au début ou à la fin de la phrase).

En utilisant IF + la fonction SEARCH j'obtiens ce résultat :

IF(SEARCH("lulu",A2)="true",1,2)
- Si A2 contient lulu, renvoie 1
- Si A2 ne contient pas lulu, renvoie #VALUE! . Mais je veux que ca renvoie 2 !!

Merci d'avance pour votre aide.

2 réponses

Messages postés
12261
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
19 février 2020
2 334
Salut,
Prends le problème à l'envers : Si cherche "lulu" renvoie une erreur alors 2 sinon 1.
En excel français :
=SI(ESTERREUR(CHERCHE("lulu";A2));2;1)
En excel anglais : (si je ne m'abuse)
=IF(ISERROR(SEARCH("lulu";A2));2;1)
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 87645 internautes nous ont dit merci ce mois-ci

Hello,

Pas bête du tout, merci bcp ! Simplement en Anglais il faut remplacer " ; " par " , ".

,-)

Merci pr votre aide !
pijaku
Messages postés
12261
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
19 février 2020
2 334
et merci à toi pour la syntaxe anglaise.