Menu

Supprimer des valeurs automatiquement - Excel [Résolu/Fermé]

- - Dernière réponse : Doudou95
Messages postés
1569
Date d'inscription
jeudi 19 juillet 2007
Statut
Membre
Dernière intervention
30 avril 2019
- 12 févr. 2010 à 08:08
Bonjour,
Je cherche à supprimer des adresses mails dans une base Excel de manière automatique.

J’ai un premier onglet avec la liste générale des mails et dans un deuxième onglet la liste des mails que je souhaite supprimer de la liste générale. Aujourd’hui, je suis obligé de passer par l’outil « rechercher » et de sélectionner un à un les mails pour les supprimer dans la liste générale.

Avez-vous une idée pour automatiser cette tâche ?

Je vous remercie d’avance
Afficher la suite 

5 réponses

Messages postés
1569
Date d'inscription
jeudi 19 juillet 2007
Statut
Membre
Dernière intervention
30 avril 2019
317
0
Merci
? t'as que ceux à suppr dans la deuxieme page? comment les mets tu ds la deuxieme page?
Messages postés
1184
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
12 juillet 2012
295
0
Merci
très simplement

tu nommes ta liste qui contient les suppressions.

par exemple liste_mail_a_supprimer

dans la feuille qui contient tous les mails (à garde et à supprimer)

je suppose que tes adresses sont dans la colonne A à toi d'adapter
sur une colonne libre tu écris


=RECHERCHEV(A3;liste_mail_a_supprimer;1;FAUX)
cette fonction te renvoie le nom si elle le trouves sinon #NA
ensuite tu fais un copier coller (valeur uniquement)
tu fais un tri sur toute la base
ensuite tu effaces tout sauf les #NA qui sont toutes les valeurs à garder.
0
Merci
Merci pour votre rapidité.

Effectivement, mon fichier d'origine avec toutes les adresses sont en colonne A dans la feuille "mail". Dans une deuxième feuille "suppr", il y a la liste des mails que je dois enlever de la feuille "mail" (récupérer via un export des désinscriptions).

J'ai fait ta technique Bidouilleu_R mais cette formule me renvoi #NOM? systématiquement. J'ai mis en colonne 2 dans la feuille "mail" :
=RECHERCHEV(A3;suppr;1;FAUX) sur la ligne 3, =RECHERCHEV(A4;suppr;1;FAUX) sur la ligne 4 etc.

Pourquoi me renboit il uniquement #NOM?

Merci d'avance
0
Merci
J’ai trouvé, enfin on m’a aidé…

Il fallait mettre les valeurs de recherche de la feuille suppr :

=RECHERCHEV(A10547;suppr!$A$1:$A$115;1;FAUX)

Dans cette exemple j’avais 115 mail a supprimer. Encore merci pour votre aide, j’espère que ça pourra en dépanner d’autres.
Messages postés
1569
Date d'inscription
jeudi 19 juillet 2007
Statut
Membre
Dernière intervention
30 avril 2019
317
0
Merci
désolé hier j'étais parti du taff à cette heure ci... sinon tu pouvais passer aussi par une macro en VB voilavoila

bix +