Webcams sous ubuntu 8.04 LTS [Résolu/Fermé]

Signaler
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
-
alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
-
Bonjour à tous et bonne année,

je possède depuis longtemps une logitech pro 4000 . sous ubuntu 8.04 j'ai tout essayé : image mais pas de son (micro).!
las de tant d'essais , je me suis procuré une webcam hp deluxe (compatible uvc) : rien ! que dalle !
là aussi j'ai l'image (enfin parfois) mais pas de son !

je ne sais plus quoi faire . pouvez vous m'aider à faire fonctionner au moins une de mes deux webcams sous linux ubuntu 8.04 LTS

j'ai installé maints et maints logiciels et pilotes : rien ; nada ; et en plus amsn fonctionne de moins en moins bien les autre logiciels aussi comme ekiga , kopete , camorama , xawtv(n'a jamais marché) , vlc (impossible à paramétrer) , easycam2

bref, je galère.
vous pouvez m'aider ?
merci d'avance

11 réponses

Et si tu essayais avec Ubuntu 9.10. (essaie avec le live-cd)
La prise en charge des webcams a évolué depuis Hardy...
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
9
justement , si j'ai mis ubuntu 8.04 c'est pour pas avoir à changer se systeme tous les 6 mois et d'une et de deux c'est que mon portable est un vieux dell latitude d610 40GO de disque dur et je parle pas de la ram ...

alors , l'un dans l'autre , je sais pas si je peux le faire et à quels risques ?
Messages postés
377
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
10 août 2010
115
bonjour,

moi aussi, ça me gène un peu de changer tout les 6 mois ... mais bon, dans ce cas il me faut attendre la prochaine version LTS ... j'ai nommé lynx lucide (10.04). En attendant ... on va quand même essayer de voir si il y a quelque chose à faire pour cette webcam.

Ce qui m'étonne, en lisant la doc d'ubuntu a ce sujet :
http://doc.ubuntu-fr.org/webcam

c'est que la webcam logitech pro 4000 semble être très bien supportée. Je vous recommande de lire cette page.

N'hésitez pas a revenir poser des questions si ça ne se passe pas bien

Bonne chance
alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
9
mon problème , si tu veux akkenar , c'est que j'ai bien l'image dans cheese et camorama ;
easycam m'a d'ailleurs grandement aidé pour installer ma webcam mais je n'ai pas de son !
de micro pour etre plus précis . quand à amsn , maintenant il ne veut plus de ma webcam :
il ne la reconnait plus !

j'ai tellement bidouillé que je ne sais plus où j'en suis.
pourrai tu m'aider par la meme occasion à voir clair dans mon systeme
et à désinstaller les pilotes inadéquats ? voire meme quelques programmes ?

d'avance merci.

alain

ps: bonne année à tous et à toi en particulier akkenar .
Akkenar
Messages postés
377
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
10 août 2010
115 > alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015

re, ça toujours été le cirque avec amsn. J'ai configurer une webcam avec micro de chez logithèque dernièrement ... ça passait nickel sous skype ... et pas moyen d'avoir quelque chose de correct avec amsn.

Bon, pour le micro, on va commencer par voir si ce n'est tout simplement pas un problème d'entrée. L'idée est d'aller dans le panneau de configuration du son et de tester les entrées les unes après les autres en amplifiant de signal (il y a un curseur normalement). Pour le test, le mieux est d'utiliser l'enregistreur de son présent par défaut.
alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
9 > Akkenar
Messages postés
377
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
10 août 2010

rien ne marche . ni aux ni mic encore moins mic1 ou mic2
> alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015

Tu n'as pas le choix entre plusieurs périphériques d'entrée ?
Akkenar
Messages postés
377
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
10 août 2010
115 > alainbrest
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015

après recherche, je n'ai rien trouvé de concluant, et je n'ai pas le temps de le faire ces prochains jours, désolé
Moi aussi, j'ai la 8.04 installée sur mon portable. Rien à faire avec la webcam intégrée, elle ne fonctionne que de manière très aléatoire.
J'ai installé la 9.10 (pour tester) sur une partition libre et là j'arrive à faire fonctionner ma webcam .
J'avoue que depuis que j'ai installé la 9.10, je ne me sers plus du tout de la 8.04...

C'est certains que les versions LTS sont plus abouties que les versions intermédiaires.
Messages postés
576
Date d'inscription
jeudi 18 octobre 2007
Statut
Membre
Dernière intervention
18 juillet 2015
9
comme je ne sais plus où j'en suis dans le site http://doc.ubuntu-fr.org/pwc
rubrique compilation.

je vous soumets mes tentatives
p.s.: je suis sous ubuntu 8.04.3LTS

je ne suis pas expert mais il y a beaucoup d'erreurs ... et j'aime pas
ça ; alors je vous soumets le texte de mes démarches en espérant
résoudre mon(mes) problème(s) ...

j'ai déjà installé ma webcam logitech pro 4000 avec easycam qui me
simplifie grandement les choses mais je voudrai installer son pilote pwc
en espérant qu'il fonctionne mieux (image et son (micro!)).
comme je n'en suis pas à ma première tentative , il faudra surement
faire un peu d'ordre là dedans (les pilotes et les modules).
bref, je compte sur vous parceque seul, je m'en sors pas :
linux est si compliqué ! enfin ... là oui !

voilà les commandes de départ :

make
sudo modprobe -r pwc
sudo cp pwc.ko /lib/modules/`uname -r`/kernel/drivers/media/video/pwc/pwc.ko.saillard
cd /lib/modules/`uname -r`/kernel/drivers/media/video/pwc
sudo mv pwc.ko pwc.ko.ubuntu
sudo ln -s pwc.ko.saillard pwc.ko
sudo depmod -a
sudo modprobe pwc

et voilà le résultat :

alain@alain-laptop:~$ cd /home/alain/Bureau/pwc-10.0.12-rc1
alain@alain-laptop:~/Bureau/pwc-10.0.12-rc1$ make
make -C /lib/modules/2.6.24-26-generic/build
SUBDIRS=/home/alain/Bureau/pwc-10.0.12-rc1 modules
make[1]: entrant dans le répertoire
« /usr/src/linux-headers-2.6.24-26-generic »
CC [M] /home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.o
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:166: erreur: variable
«pwc_template» has initializer but incomplete type
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:167: erreur: unknown field
«owner» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:167: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:167: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:168: erreur: unknown field
«name» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:168: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:168: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:169: erreur: unknown field
«type» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:169: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:169: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:170: erreur: unknown field
«hardware» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:170: erreur:
«VID_HARDWARE_PWC» undeclared here (not in a function)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:170: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:170: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:171: erreur: unknown field
«release» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:171: erreur:
«video_device_release» undeclared here (not in a function)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:171: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:171: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:172: erreur: unknown field
«fops» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:172: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:172: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:173: erreur: unknown field
«minor» specified in initializer
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:173: attention : éléments en
excès dans l'initialisation de la structure
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:173: attention : (near
initialization for «pwc_template»)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_isoc_init» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:921: attention : assignment
from incompatible pointer type
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«cd_to_pwc» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1019: erreur: déclaration
implicite de la fonction « «to_video_device» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1019: attention :
initialization makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1020: erreur: déclaration
implicite de la fonction « «video_get_drvdata» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1020: attention : return
makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_create_sysfs_files» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1062: attention :
initialization makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1064: erreur: déclaration
implicite de la fonction « «video_device_create_file» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_remove_sysfs_files» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1070: attention :
initialization makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1072: erreur: déclaration
implicite de la fonction « «video_device_remove_file» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_open» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1112: erreur: déclaration
implicite de la fonction « «video_devdata» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1112: attention :
initialization makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1117: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_close» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1231: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_read» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1292: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_poll» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1359: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_ioctl» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1375: erreur: déclaration
implicite de la fonction « «video_usercopy» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«pwc_video_mmap» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1388: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«usb_pwc_probe» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1722: erreur: déclaration
implicite de la fonction « «video_device_alloc» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1722: attention : assignment
makes pointer from integer without a cast
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1729: erreur: invalid
application of «sizeof» to incomplete type «struct video_device»
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1729: erreur: invalid
application of «sizeof» to incomplete type «struct video_device»
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1729: erreur: invalid
application of «sizeof» to incomplete type «struct video_device»
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1730: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1731: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1732: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1733: erreur: déclaration
implicite de la fonction « «video_set_drvdata» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1756: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1757: erreur: déclaration
implicite de la fonction « «video_register_device» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1757: erreur:
«VFL_TYPE_GRABBER» undeclared (first use in this function)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1757: erreur: (Each
undeclared identifier is reported only once
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1757: erreur: for each
function it appears in.)
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1760: erreur: déclaration
implicite de la fonction « «video_device_release» »
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1765: erreur:
déréférencement d'un pointeur de type incomplet
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c: Dans la fonction
«usb_pwc_disconnect» :
/home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.c:1819: erreur: déclaration
implicite de la fonction « «video_unregister_device» »
make[2]: *** /home/alain/Bureau/pwc-10.0.12-rc1/pwc-if.o Erreur 1
make[1]: *** [_module_/home/alain/Bureau/pwc-10.0.12-rc1] Erreur 2
make[1]: quittant le répertoire
« /usr/src/linux-headers-2.6.24-26-generic »
make: *** [all] Erreur 2
alain@alain-laptop:~/Bureau/pwc-10.0.12-rc1$ sudo modprobe -r pwc
alain@alain-laptop:~/Bureau/pwc-10.0.12-rc1$ sudo cp
pwc.ko /lib/modules/`uname
-r`/kernel/drivers/media/video/pwc/pwc.ko.saillard
cp: ne peut évaluer `pwc.ko': Aucun fichier ou dossier de ce type
alain@alain-laptop:~/Bureau/pwc-10.0.12-rc1$ cd /lib/modules/`uname
-r`/kernel/drivers/media/video/pwc
alain@alain-laptop:/lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc$ sudo mv pwc.ko pwc.ko.ubuntu
alain@alain-laptop:/lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc$ sudo ln -s pwc.ko.saillard pwc.ko
alain@alain-laptop:/lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc$ sudo depmod -a
WARNING: Can't read
module /lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc/pwc.ko: No such file or directory
alain@alain-laptop:/lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc$ sudo modprobe pwc
alain@alain-laptop:/lib/modules/2.6.24-26-generic/kernel/drivers/media/video/pwc$