Object sur IE [Fermé]

Signaler
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010
-
eerbrice
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010
-
Bonjour,
mon object ne s'affiche pas sur IE
que dois-je changer ?
merci
<object
type="audio/x-wav" data="../Media/film-crime-presque-parfait.wav" width="795" height="30" >
<param name="src" value="..Media/film-crime-presque-parfait.wav" />
<param name="autoplay" value="false" />
<param name="autoStart" value="0" />
<param name="controller" value="flase" />
<param name="loop" value="false"/>
</object>

10 réponses

Messages postés
437
Date d'inscription
mercredi 29 juillet 2009
Statut
Membre
Dernière intervention
23 septembre 2010
74
Bonjour,

que dois-je changer ?
Le navigateur XD

N'y aurait-il pas une erreur ici?:
<param name="src" value="../Media/film-crime-presque-parfait.wav" />
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010

non, je ne crois pas,
c'est un chemin absolu... firefox trouve le fichier...
Messages postés
6489
Date d'inscription
jeudi 22 mars 2007
Statut
Contributeur
Dernière intervention
24 mars 2019
1 617
erreur de ma part, oubliez ce message
Messages postés
437
Date d'inscription
mercredi 29 juillet 2009
Statut
Membre
Dernière intervention
23 septembre 2010
74
Heu, je veux dire, Firefox doit se baser sur l'attribut data de la balise object, alors que IE se base sur les paramètre, non? car le lien que tu as mis dans ta balise <param> n'est pas bon.
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010

peux tu préciser ta réponse ?
Messages postés
437
Date d'inscription
mercredi 29 juillet 2009
Statut
Membre
Dernière intervention
23 septembre 2010
74
tout simplement:

<object
type="audio/x-wav" data="../Media/film-crime-presque-parfait.wav" width="795" height="30" >
<param name="src" value="..Media/film-crime-presque-parfait.wav" />

Il y a une différence de lien à cet endroit, le problème bien sans doute de là, il manque un "/" dans le second lien
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010

j'ai corrigé cette erreur
mais IE n'affiche pas le lecteur...
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010

il y a quand même bien une soluce pour afficher la balise object sur IE
ou faut il l'oublier
???
what can I do ?
Messages postés
437
Date d'inscription
mercredi 29 juillet 2009
Statut
Membre
Dernière intervention
23 septembre 2010
74
Je ne suis pas pro dans cette balise, je ne fais pas souvent de site avec des médias qui la nécessitent.

En regardant de plus près, je pense qu'en rajoutant un classid ça pourrait marcher. apparemment IE8 n'arrive pas à lire du wav par défaut...

essaye avec ce code:
<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="795" height="30">
    <param name="src" value="..Media/film-crime-presque-parfait.wav" />
    <param name="autoplay" value="false" />
    <param name="autoStart" value="0" />
    <param name="controller" value="flase" />
    <param name="loop" value="false"/>

    <object type="audio/x-wav" data="../Media/film-crime-presque-parfait.wav" width="795" height="30" >
        <param name="src" value="..Media/film-crime-presque-parfait.wav" />
        <param name="autoplay" value="false" />
        <param name="autoStart" value="0" />
        <param name="controller" value="flase" />
        <param name="loop" value="false"/>
    </object>
</object>


Explication: IE a besoin d'un contrôle activeX pour pas mal de médias. en utilisant un classid, on appelle un programme particulier grâce à activeX. dans ce cas, on fait l'appel à quicktime. Il y a 2 balises object imbriquées, la première pour IE, l'autre pour les autres navigateurs.

Je n'ai pas testé, je ne sais donc pas si ça va marcher.

PS: le wav n'est pas du tout adapté pour le wav, c'est un format de son NON COMPRESSE, qui est bien trop volumineux pour être utilisé sur le web. il vaut mieux utiliser des fichier mp3.
Messages postés
61
Date d'inscription
mardi 5 mai 2009
Statut
Membre
Dernière intervention
27 janvier 2010

merci de ta réponse,
mais j'avais déjà essayé le class id et ça ne fonctionne tjs pas.
en fait je voulais utiliser <object> pour pouvoir paramètrer la taille du lecteur
avec dewplayer par ex ça ne marche pas j'ai beau changer la taille ça reste pareil.. par contre ça fonctionne bien sous IE !
(et pour le wav tu as raison ce n'est pas l'idéal!)


Eric