Menu

[Excel] Formule de calcul [Résolu/Fermé]

- - Dernière réponse : bgob
Messages postés
2
Date d'inscription
samedi 16 avril 2005
Statut
Membre
Dernière intervention
16 avril 2005
- 16 avril 2005 à 18:31
Bonjour,

Voila mon souci :

J'ai un tableau appelé tableau A composé comme suit :

En colonne A, une liste de codes de catégories (602000, 603000, etc...)
En E1, E2, E3, ... j'ai les codes de mes comptes (001, 002, 003, ...)

Sur un tableau B,
En colonne A, j'ai mes codes de catégories
En colonne C, j'ai mes codes de comptes
En colonne E, les montants concernant une catégorie et un compte.

Comment je peux faire pour que dans ma colonne E du tableau A :
si le code catégorie tableauA=code catégorie tableauB ET code compteE1=code compte tableauB colonneC, alors je fais la somme de tous mes montants de la colonne E tableau B.

J'espère avoir été assez clair dans mes explications

Merci de votre aide
Afficher la suite 

3 réponses

0
Merci
Non en fait je vais faire un exemple de tableau A :
A B C D
N° compte |Libellé du compte| 001 Compte Chèque CM |002 PEL
602600 Alimentation X Y
606120 Electricité W Z

Mon tableau B lui est comme ceci :

A B C D E
606110 EAU 1 Compte Chèque CM 95,07
606120 ELECTRICITE 1 Compte Chèque CM 75
606120 ELECTRICITE 2 PEL 75
606120 ELECTRICITE 3 Autres 75
606120 ELECTRICITE 2 Autres 75
606120 ELECTRICITE 1 Compte Chèque CM 222,96

Donc dans mes colonnes C et D du tableau A, je veux qu'il me fasse la somme de la colonne E du tableau B si les numéros des colonnes A des 2 tableaux sont identiques et si le chiffre de C1 du tableau A correspond au chiffre de la colonne C du tableau B.

J'espère que c'est plus clair cette fois ci.
Exemple ici en W, ca me ferait 75+222,96
bgob
Messages postés
2
Date d'inscription
samedi 16 avril 2005
Statut
Membre
Dernière intervention
16 avril 2005
-
bonjour,
j'ai créer une colonne f dans le tab b
dans cette colonne mettre la formule = a6& b6 la ligne 6 étant la
première ligne des données du tab b et copier cette formule sur
chaque ligne du tab b

tab a
a1 (N°compte) b1( Libellé) c1 (001)
606120 Electricité =somme.si(code;A2&C1;val)

code étant le nom donné à la plage contenant les formules ds la colonne F
val étant le nom donné à la plage contenant les sommes
j'espère être arrivée à être assez claire pour que tu comprennes
a+
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3606
0
Merci
bonjour

pour cela il faut travailler avec une formule matricielle.

je considére que ton tableau A est
sur une feuille qui est nommée : "tableau A"

je considére que ton tableau B est
sur une feuille qui est nommée : "tableau B"

et donc ta cellule W a la formule suivante :

=SOMME('tableau B'!E$1:E$8*(A3='tableau B'!A$1:A$8)*('tableau B'!C1:C8='tableau A '!$C$1))

il faut valider cette formule avec CRTL + MAJ + ENTREE
pour fonctionner en matriciel.

pour les autres cellules totaux il suffit de faire un copier / coller
mais ta plage du tableau B doit être rentrée grande
pour fonctionner même en rajoutant des lignes :

=SOMME('tableau B'!E$1:E$65000*(A3='tableau B'!A$1:A$65000)*('tableau B'!C1:C65000='tableau A '!$C$1)) par exemple.


par contre ta cellule C1 doit avoir une valeur strictement égale
aux valeurs de la colonne C du tableau B.
il serait possible de ne prendre que le début de ton libellé
mais c'est plus compliqué et pas vraiment utile car il suffit
de mettre ton titre sur deux lignes : libellé et numéro.

la définition des cellules de A et B doit aussi être identique
car si l'un est un texte et l'autre en nombre il n'y a pas égalité.
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3606
-1
Merci
bonjour

J'espère avoir été assez clair dans mes explications

oui et non car si j'ai bien compris tu veux :
dans ma colonne E du tableau A

avoir à la fois un code compte et une totalisation des montants
et pour cela il vaut mieux avoir 2 colonnes car
tu ne peux avoir une valeur et un résultat de formule en même temps.