Menu

[EXCEL] Remplissage auto de cellules vides [Résolu/Fermé]

- - Dernière réponse :  Etoile - 1 mai 2019 à 19:52
Bonjour à tous,

Dans une feuille Excel, j'ai une colonne qui contient des cellules vides. J'aimerais remplir chacune de ces cellules avec la valeur de la cellule qui la précède (la cellule juste au-dessus).

Suis-je obligé de faire une macro ?

Merci d'avance pour vos réponses.
Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
23895
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 mai 2019
5775
44
Merci
Bonsoir
Difficile, sur une colonne d'intégrer facilement des formules intercalées avec des cellules déjà remplies (il faut les rentrer une par une où presque)

je pense que le plus simple est de reconstruire une nouvelle colonne à coté de la colonne à remplir:
pour l'exemple
colonne "ajourée" en A, à partir de A1
Colonne de renvoi en B
en B1 reporter simplement la valeur de A1
en B2, la formule à tirer vers le bas du tableau:
=SI(ESTVIDE(A2);B1;A2)
la valeur de la cellule au dessus des vides se répétera autant de fois qu'il y a de cellules vides qui se suivent
il ne reste plus qu'à faire un copier collage spécial / Valeurs de la colonne B si besoin pour supprimer les formules
Crdlmnt

Dire « Merci » 44

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40122 internautes nous ont dit merci ce mois-ci

c'est pile poil ce que je cherchais aussi, merci bcp
génial! Kaiser !!
ça sert encore merci!!
Au top comme toujours
Messages postés
33
Date d'inscription
lundi 28 mai 2012
Statut
Membre
Dernière intervention
14 août 2018
20
1
Merci
J'ai trouvé la solution.
Pour ceux qui auraient le meme problème que moi, il faut que toutes les cellules concernées soient au format date.
Messages postés
1578
Date d'inscription
mardi 2 octobre 2007
Statut
Membre
Dernière intervention
14 décembre 2017
964
0
Merci
tu copie les valeur de la colonne ( j'espére que chaque cellule a une cellule en desous vide )
puis tu filtre sur les cellule vide : menu donné > filtre > filtre automatique
puis tu selectionne la premiere cellule et tu colle
0
Merci
Merci beaucoup, Vaucluse. C'est exactement ce que je voulais.
Messages postés
33
Date d'inscription
lundi 28 mai 2012
Statut
Membre
Dernière intervention
14 août 2018
20
0
Merci
Bonjour à tous,

La formule de Vaucluse fonctionne parfaitement bien, sauf pour les dates qui me posent problème. En effet, lorsque j'applique cette formule à des dates (au format JJ/MM/AAAA par exemple), Excel me retourne des valeurs numériques comme par exemple 41057 pour le 28/05/2012.

Je vous remercie d'avance de la réponse que vous pourrez m'apporter.
Pour ca c'est normal ,car les dates avec excel commence le 1900-01-01 ,donc =1.
ton cas 41057=28/05/2012.
il suffit de changer le format de la date après.