Apache : reconnais pas index.php [Résolu/Fermé]

Signaler
Messages postés
4984
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
31 octobre 2019
-
le hollandais volant
Messages postés
4984
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
31 octobre 2019
-
Bonjour à tous.
Je viens juste d'installer Ubuntu 9.04 sur un ordinateur et j'ai installé aussi les composants d'apache.

Le nom du PC est "timo" et le dossier du site est dans "/var/www/blog/"

Le problème, c'est que si dans Firefox je tapes "http://timo/" il m'affiche bien "It works" mais si je tapes "http://timo/blog/" il me demande d'enregistrer un fichier, que je reconnais comme mon "index.php". Le fichier enregistré à un nom aléatoire et son contenu est du PHP (je veux dire que le PHP n'a pas été interprété en HTML.)

Là où je ne suis plus, c'est que si je tapes "http://timo/blog/index.php" la page s'affiche comme il faut. Firefox reconnais néanmoins les fichiers "index.html" sans avoir à les taper.

C'est juste le index.php…

Étrange aussi car c'est la première fois que j'ai ce problème…

Pour installer Apache, j'ai fait :
sudo aptitude install apache2 php5 libapache2-mod-php5


donc pas de MySQL comme indiqué dans le tuto pour installer LAMP facilement sous Ubuntu. Les fois d'avant, j'avais installé tout comme dans le tuto, puis viré les composants mysql-server php5-mysql


Une idée?

2 réponses

Messages postés
6764
Date d'inscription
mardi 14 mai 2002
Statut
Contributeur
Dernière intervention
11 janvier 2016
879
salut,

à priori, #sudo a2enmod php5 puis relancer le serveur.

plus d'infos :
http://doc.ubuntu-fr.org/lamp#verification_du_bon_fonctionnement_d_apache
Messages postés
4984
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
31 octobre 2019
965
Effectivement, ça marche.

Par contre, le module était déjà chargé (la commande renvoie : "Module php5 already enabled"

Ensuite, j'ai effectivement rechargé Apache, puis vidé le cache de Firefox. Tout baigne ;-)

Merci^^