Problemes avec des .deb dans kubuntu [Résolu/Fermé]

Signaler
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
-
emsaiz
Messages postés
51
Date d'inscription
mardi 2 novembre 2010
Statut
Membre
Dernière intervention
12 mars 2012
-
Bonjour,
Je voudrais installer des paquets deb, mais quand je les installe, sa dit:Désolé, une erreur est survenue

si je l'installe avec Gdebi:Impossible d'ouvrir « install_flash_player_10_linux.deb »
Ce paquet est peut-être corrompu, ou vous n'avez pas les droits pour y accéder. Vérifiez les droits d'accès fichier.


ca fait ca avec tout les paquets deb..

merci de votre aide!!

7 réponses

Messages postés
2049
Date d'inscription
dimanche 22 août 2004
Statut
Contributeur
Dernière intervention
13 novembre 2016
132
Salut Jérémie,

Comment as-tu installé limewire? vu le message d'erreur, tu l'a fait a la mains aussi, et qqch ne c'est pas bien passé. Idéalement enlève le COMPLÈTEMENT, puis ré-installe le en suivant les tuto de Mamiemando.

Bonne chance

Renisaac
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 75331 internautes nous ont dit merci ce mois-ci

j-e-r-e-m-i-e
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
7
bien jai (essayé) d'installer limewire avec le deb, mais ca ma mit 3 messages d'erreur disant que java na pas pu être installé. j'ai essayer un sudo apt-get remove limewire-basic, mais sa ma dit :
E: Impossible de localiser un fichier du paquet limewire-basic. Cela signifie que vous devrez corriger ce paquet vous-même (absence d'architecture).
(je ne suis pas chez moi pour le moment je vais te donner + de détailles demain.)

et je crois que c'est depuis ce temps que je ne peut plus en installer.


de plus, quand je fait un apt-get (par exemple ''sudo apt-get install amsn''), ca dit ''E: Erreur interne : impossible de créer la liste des paquets à télécharger ''
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 809
Essaye avec dpkg :
sudo dpkg --purge limewire

Oublie apt-get et utilises systématiquement aptitude à la place, et pour purger un paquet dpkg. Ensuite pour tout remettre à plat :
sudo aptitude clean
sudo aptitude update
sudo aptitude safe-upgrade

Bonne chance
j-e-r-e-m-i-e
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
7
hu,mmm,

on dirait qu'il ne veut vraiment pas le désinstaller...

jeremie@jeremie-laptop:~$ sudo dpkg --purge limewire-basic
dpkg : erreur de traitement de limewire-basic (--purge) :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d'essayer de le supprimer.
Des erreurs ont été rencontrées pendant l'exécution :
limewire-basic
jeremie@jeremie-laptop:~$
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
7
ah oui vous savez je vous ai dit que quant j'allais dans KpackageKit et je fesait une recherche pour un paquet, il y avait un message d'erreur

voici le message AVEC les détails (sa pourrait etre util):


Un problème inattendu s'est produit.
Veuillez signaler ce bogue ainsi que la description de l'erreur.

Traceback (most recent call last): File "/usr/lib/python2.6/dist-packages/packagekit/daemonBackend.py", line 109, in run threading.Thread.run(self) File "/usr/lib/python2.6/threading.py", line 477, in run self.__target(*self.__args, **self.__kwargs) File "/usr/lib/packagekit/aptDBUSBackend.py", line 588, in doSearchName self._check_init(progress=False) File "/usr/lib/packagekit/aptDBUSBackend.py", line 1755, in _check_init self._cache.clear() File "/usr/lib/packagekit/aptDBUSBackend.py", line 246, in clear self._depcache.Init() SystemError: E:The package limewire-basic needs to be reinstalled, but I can't find an archive for it.
Messages postés
231
Date d'inscription
mardi 23 juin 2009
Statut
Membre
Dernière intervention
2 juillet 2009
38
Bonjour,

essaye la commande sudo dpkg --force-all --purge nom_du_paquet
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
7
merci Mister_AmX! limewire a été désinstallé et je peut installer des deb!

mais je ne peut toujours pas installer limewire, quand j'essai, Gdebi ou Kpackagekit plante.... :/

vooici l'instalation de limewire avec KpackageKit:


jeremie@jeremie-laptop:~/Bureau$ kpackagekit LimeWireLinux.deb
isFIle
jeremie@jeremie-laptop:~/Bureau$ New transaction with tid "/67_cecebddb_data"
KPackageKit(6695) KpkIcons::actionIcon: action unrecognised: 9
enumFromString ( State ) : converted "" to "" , enum value -1
enumFromString ( ErrorType ) : converted "unknown" to "Unknown" , enum value -1
KPackageKit(6695) KpkTransaction::errorCode: errorCode: -1 "/var/cache/apt/archives/sun-java6-jre_6-13-1_all.deb
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
(Reading database ... 102577 files and directories currently installed.)
Unpacking sun-java6-jre (from .../sun-java6-jre_6-13-1_all.deb) ...

sun-dlj-v1-1 license could not be presented
try 'dpkg-reconfigure debconf' to select a frontend other than noninteractive

"
KPackageKit(6695) KpkTransaction::finished: Failed.
KPackageKit(6695) KpkTransaction::finished: Yep, we failed.
KPackageKit(6695) KpkInstallFiles::installFilesFinished: Finished.
removing transaction from pool : "/67_cecebddb_data"
Messages postés
51
Date d'inscription
mardi 2 novembre 2010
Statut
Membre
Dernière intervention
12 mars 2012

Si tu veux installer des logiciel ou il demande les droit superutilisateur tu tapes:
sudo -i

sa devrait de donner les droits =)
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 809
Si le but c'est d'installer un paquet, tu n'as (sauf quà exceptionnel) jamais à télécharger le .deb à la main. Tout est fait implicitement par ton gestionnaire de paquet (par exemple synaptic, aptitude, adept...).
http://doc.ubuntu-fr.org/synaptic
http://doc.ubuntu-fr.org/aptitude

Pour installer flash : http://doc.ubuntu-fr.org/flashplayer

Personnellement et contrairement à ce qui est indiqué dans la doc, j'installerais plutôt le paquet prévu pour. Par exemple sous debian :
(mando@aldur) (~) $ apt-cache search flash | grep mozilla
mozilla-noscript - Javascript/plugins permissions manager for Iceweasel and Iceape
swfdec-mozilla - Mozilla plugin for SWF files (Macromedia Flash)
flashplayer-mozilla - Macromedia Flash Player

Ce qui reviendrait à faire :
sudo aptitude update
sudo aptitude safe-upgrade
sudo aptitude install flashplayer-mozilla

Sinon il existe d'autres plugins flash, libres qui plus est, comme gnash : http://doc.ubuntu-fr.org/gnash
mozilla-plugin-gnash - free SWF movie player - Plugin for Mozilla and derivatives

Bonne chance
j-e-r-e-m-i-e
Messages postés
219
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
4 janvier 2010
7
salut!

voici le résultat de la commande:

jeremie@jeremie-laptop:~$ sudo aptitude update
[sudo] password for jeremie:
Écriture de l'information d'état étendu... Fait
Atteint https://usn.ubuntu.com/ jaunty-security Release.gpg
Ign https://usn.ubuntu.com/ jaunty-security/main Translation-fr
Atteint http://ca.archive.ubuntu.com jaunty Release.gpg
Atteint http://ca.archive.ubuntu.com jaunty/main Translation-fr
Ign https://usn.ubuntu.com/ jaunty-security/restricted Translation-fr
Ign https://usn.ubuntu.com/ jaunty-security/universe Translation-fr
Ign https://usn.ubuntu.com/ jaunty-security/multiverse Translation-fr
Atteint https://usn.ubuntu.com/ jaunty-security Release
Atteint http://ca.archive.ubuntu.com jaunty/restricted Translation-fr
Atteint http://ca.archive.ubuntu.com jaunty/universe Translation-fr
Atteint http://ca.archive.ubuntu.com jaunty/multiverse Translation-fr
Atteint http://ca.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://ca.archive.ubuntu.com jaunty-updates/main Translation-fr
Ign http://ca.archive.ubuntu.com jaunty-updates/restricted Translation-fr
Ign http://ca.archive.ubuntu.com jaunty-updates/universe Translation-fr
Ign http://ca.archive.ubuntu.com jaunty-updates/multiverse Translation-fr
Atteint http://ca.archive.ubuntu.com jaunty Release
Atteint http://ca.archive.ubuntu.com jaunty-updates Release
Atteint https://usn.ubuntu.com/ jaunty-security/main Packages
Atteint http://ca.archive.ubuntu.com jaunty/main Packages
Atteint http://ca.archive.ubuntu.com jaunty/restricted Packages
Atteint http://ca.archive.ubuntu.com jaunty/main Sources
Atteint http://ca.archive.ubuntu.com jaunty/restricted Sources
Atteint https://usn.ubuntu.com/ jaunty-security/restricted Packages
Atteint https://usn.ubuntu.com/ jaunty-security/main Sources
Atteint https://usn.ubuntu.com/ jaunty-security/restricted Sources
Atteint https://usn.ubuntu.com/ jaunty-security/universe Packages
Atteint http://ca.archive.ubuntu.com jaunty/universe Packages
Atteint http://ca.archive.ubuntu.com jaunty/universe Sources
Atteint http://ca.archive.ubuntu.com jaunty/multiverse Packages
Atteint http://ca.archive.ubuntu.com jaunty/multiverse Sources
Atteint http://ca.archive.ubuntu.com jaunty-updates/main Packages
Atteint http://ca.archive.ubuntu.com jaunty-updates/restricted Packages
Atteint http://ca.archive.ubuntu.com jaunty-updates/main Sources
Atteint http://ca.archive.ubuntu.com jaunty-updates/restricted Sources
Atteint http://ca.archive.ubuntu.com jaunty-updates/universe Packages
Atteint http://ca.archive.ubuntu.com jaunty-updates/universe Sources
Atteint https://usn.ubuntu.com/ jaunty-security/universe Sources
Atteint https://usn.ubuntu.com/ jaunty-security/multiverse Packages
Atteint https://usn.ubuntu.com/ jaunty-security/multiverse Sources
Atteint http://ca.archive.ubuntu.com jaunty-updates/multiverse Packages
Atteint http://ca.archive.ubuntu.com jaunty-updates/multiverse Sources
Lecture des listes de paquets... Fait

jeremie@jeremie-laptop:~$ sudo aptitude safe-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Résolution des dépendances...
Résolution des dépendances...
Les NOUVEAUX paquets suivants vont être installés :
linux-headers-2.6.28-13{a} linux-headers-2.6.28-13-generic{a}
linux-image-2.6.28-13-generic{a}
linux-restricted-modules-2.6.28-13-generic{a}
Les paquets suivants seront ENLEVÉS :
linux-headers-2.6.28-11{u} linux-headers-2.6.28-11-generic{u}
Les paquets suivants seront mis à jour :
linux-generic linux-headers-generic linux-image-generic
linux-restricted-modules-generic
4 paquets mis à jour, 4 nouvellement installés, 2 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 98,1Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
E: Impossible de localiser un fichier du paquet limewire-basic. Cela signifie que vous devrez corriger ce paquet vous-même (absence d'architecture).
Écriture de l'information d'état étendu... Fait
E: Impossible de localiser un fichier du paquet limewire-basic. Cela signifie que vous devrez corriger ce paquet vous-même (absence d'architecture).
E: Erreur interne : impossible de créer la liste des paquets à télécharger
jeremie@jeremie-laptop:~$ sudo aptitude install flashplayer-mozilla
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Pas de version candidate trouvée pour flashplayer-mozilla
Pas de version candidate trouvée pour flashplayer-mozilla
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
E: Impossible de localiser un fichier du paquet limewire-basic. Cela signifie que vous devrez corriger ce paquet vous-même (absence d'architecture).
Écriture de l'information d'état étendu... Fait
E: Impossible de localiser un fichier du paquet limewire-basic. Cela signifie que vous devrez corriger ce paquet vous-même (absence d'architecture).
E: Erreur interne : impossible de créer la liste des paquets à télécharger
jeremie@jeremie-laptop:~$

(flash nest pas plus installé :/)


je vien juste de me rendre conte que, quand je vais dans KPackageKit et je fait une recherche, sa dit: Un problème inattendu s'est produit.
Veuillez signaler ce bogue ainsi que la description de l'erreur.