Recherche de cellules non-vides dans colonnes [Fermé]

Signaler
Messages postés
134
Date d'inscription
mardi 17 février 2009
Statut
Membre
Dernière intervention
2 octobre 2013
-
Raymond PENTIER
Messages postés
50554
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
-
Bonjour à tous,

dans une colonne excel, je retrouve des cases vides et non vides réparties aléatoirement.

J'aimerais pouvoir retranscrire dans une autre colonne excel l'ensemble des valeurs contenues dans les cases non-vides les unes à la suite des autres.

Pourriez-vous m'aider?

D'avance merci

4 réponses

Messages postés
50554
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
11463
Bonjour.
Faire un tri. Récupérer les cellules non-vides : elles sont maintenant contigües.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62831 internautes nous ont dit merci ce mois-ci

Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3717
Salut,

Tu peux faire simple avec une mise en forme conditionnelle

Mets ta colonne en surbrillance et Format/Mise en forme conditionnelle, sélectionnes la valeur de la cellule est, sélectionnes égale à et saisis =""
Format et sélectionnes une couleur et OK

les cellules vide de ta plage se mettront en couleurs automatiquement.

Il est également possible d'écrire une formule dans une autre colonne

exemple
=SI(A1<>"";"";"vide")
inconvéniant si les cellules contiennent une formule, elles ne sont pas considéré comme vide;

Ou en VBA

A+