Ecran noir avec nouveaux pilotes Nvidia [Résolu/Fermé]

Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
- - Dernière réponse :  olislan - 9 juin 2009 à 11:23
Bonjour,

Alors voilà mon problème, j'ai acheté une carte graphique PNY GeForce 9800 GT 512Mb, et je ne peux pas mettre mes pilotes à jour, je m'explique:

Les pilotes fournis sur le CD fonctionnent, ceux jusqu'à la version 177.79 aussi. Mais si j'essaie d'installer des pilotes plus récents, soit l'installation plante et je suis obligé de reboot manuellement, soit ils s'installent et l'écran reste noir après le démarrage de Windows (XP SP3). Quand il plante au démarrage, mon disque dur ne tourne même pas et je suis obligé de désinstaller les pilotes en mode sans échec et de réinstaller les autres plus anciens.

J'ai déjà parcouru beaucoup de forums pour ce problème que je ne suis pas le seul a avoir, et aucun n'a été résolu.

Mon écran est branché via un adaptateur VGA/DVI, j'ai pas l'occasion de tester avec un autre écran DVI mais je pense que sa ne résoudra rien vu que windows ne boot même pas ...

Le BIOS de ma carte-mère est à jour ainsi que celui de ma carte graphique, j'ai aussi essayé de changer le disque dur de bus SATA, etc ...

Donc je sais plus trop quoi faire, si vous aviez une idée ... je suis preneur :D
Afficher la suite 

15 réponses

Meilleure réponse
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103
1
Merci
A vérifier avant la manip - IMPORTANT !!

Il est conseillé de désactiver toute optimisation et overclocking du setup du bios de votre carte mère.
Notamment de mettre le « Video Memory Cache Mode » sur UC (paramètre par défaut) au lieu de USWC si l�option est présente.
En USWC, cela provoque un plantage systématique lors du flash de la carte Radeon avec certaines cartes mères (chipset I815 par exemple).
La conséquence est une perte du bios graphique.

Se munir d'une disquette de démarrage Win98, la procédure ne marche QUE sous Dos.

==================> N-Vidia <====================

Flash du bios, cartes NVidia (méthodes valables pour les cartes Geforce jusqu'au Geforce 4 AGP 4x (NV28 et NV3x pas encore supportées par le logiciel):
Téléchargez les utilitaires suivants :
- NVFlash ici
- VGAbios ici
- et bien sur un bios adéquat pour votre carte, perso j'en ai trouvé un sur le net, mais vous pouvez récupérer le bios d'une carte identique à la votre.

NVFlash va nous servir à flasher le bios, VGABios va nous servir à tester si le bios est adapté à notre carte graphique en le chargeant en mémoire et en utilisant le bios en mémoire à la place du bios de la carte graphique.
On extrait le tout dans un dossier facilement accessible (personnellement je les ai mis à la racine)
Ou bien mettez tous ces utilitaires sur une disquette.
Ensuite, sous DOS (démarrez à partir d'une disquette de démarrage Windows 98), tapez :

// Vérification du bios téléchargé
VGABIOS -fbios.rom (votre fichier doit absolument s'appeler bios.rom, ca marchait pas autrement chez moi)
tapez VGABIOS -? pour voir toutes les options (y en a pas beaucoup)


// Sauvegarde de votre bios dans le fichier save.rom pour une récupération éventuelle en cas de mauvais fonctionnement après flashage
nvflash -b save.rom


// Eventuellement, vous pouvez comparer votre bios actuel avec le bios que vous vous appretez à mettre dans votre carte
nvflash -k bios.rom (en supposant que le bios que vous allez mettre s'appelle bios.rom)


// Flashage du bios (l'opération délicate ! On prie pour qu'il n'y ait pas de coupure de courant) laugh_pci.gif
nvflash -f bios.rom


// reboot du PC



Il y a pleins d'autres options pour NVflash, tapez nvflash -? pour les voir toutes...
Attention ! NVflash ne supporte pas tous les types d'EEPROM (mémoire où est stocké le bios).
Pour vérifier si votre EEPROM est supportée, faire nvflash -c

Si vous avez plusieurs cartes graphiques, il faudra faire nvflash -a pour voir quel est le numéro de votre carte, puis au lieu de taper nvflash -f bios.rom, tapez nvflash --index=i bios.rom. (avec i le numéro de votre carte à flasher)


Voilà c'est pas mal expliqué :p
(sources: PCInpact)

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 71364 internautes nous ont dit merci ce mois-ci

Messages postés
7631
Date d'inscription
vendredi 28 novembre 2008
Statut
Contributeur
Dernière intervention
23 octobre 2013
920
0
Merci
est ce que quand vous mettez les pilotes Nvidia à jour vous désinstallez les précédents ???
Schiz0b0y
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103 -
Oui oui, je passe même un coup de Driver Cleaner pour être sur ... Mais toujours pareil à chaque fois. :)
Messages postés
7631
Date d'inscription
vendredi 28 novembre 2008
Statut
Contributeur
Dernière intervention
23 octobre 2013
920
0
Merci
c'est bizarre.
si je comprends bien pour ne pas dire de bétise après :
- vous désinstallez les anciens drivers.
- vous redémarrez.
- vous installez les nouveaux.
- vous redémarrez.
c'est bien ça ??,

Messages postés
369
Date d'inscription
lundi 1 septembre 2008
Statut
Membre
Dernière intervention
18 mars 2013
9
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103
0
Merci
@yoanf26 : Oui c'est sa.
@goliate23: j'ai déjà testé tous les drivers depuis 177.79 jusqu'au Bêta 185.65, et aucun ne marche.
Messages postés
7631
Date d'inscription
vendredi 28 novembre 2008
Statut
Contributeur
Dernière intervention
23 octobre 2013
920
0
Merci
c'est bizarre car la PNY GeForce 6200 de mon fils fonctionne nikel avec les drivers à jour et de même avec la Nvidia GeForce 9600GT de ma femme.
je n'arrive pas a cerner le problème.
j'y réfléchi peut etre que la nuit me portera conseil pour ton cas.
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103
0
Merci
Ok je vais aller au dodo aussi :p

J'ai déjà tester pas mal de trucs (divers réglages dans le BIOS, réinstallation des drivers de ma carte mères, ... etc)

Bonne nuit aux intervenants ;)
Messages postés
7631
Date d'inscription
vendredi 28 novembre 2008
Statut
Contributeur
Dernière intervention
23 octobre 2013
920
0
Merci
bon j'ai réfléchi mais a part un conflit materiel produit a cause de cette mise à jour c'est tout ce que je vois a l'heure actuelle.
désolé mais je cherche toujours une possibilité d'une résolution du problème.
0
Merci
j'avais sensiblement le meme probleme en lancant call of duty 4. ecran noir apres maxi 5 minutes de jeu. et perte de controle du pc. je pouvais reprendre la main que en reinitialisant.

le premier plantage que j'avais qui m'empéchait de lancer etait du a mon parefeu. en le desactivant j'ai pu lancer le jeu.

Mais rien de changé sur l'utilisation du jeu. toutes les mises a jour sont faites carte mere carte graphique...
et j'en suis toujours au meme point pas de solution
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103
0
Merci
@mmaneewan : Je pense que ton problème est différent dans la mesure où tu peux quand même naviguer sur ton bureau, moi windows ne boot même plus :(

@yoanf26 : C'est ce que je pense aussi, je vais essayer de réinstaller et d'enlever tout mes périphériques (G15, Souris USB, webcam ) et je vous tiens au courant ;)
0
Merci
c'est vrai tu as raison aucun soucis pour la naviqation sur le bureau ou le net.

mais les symptomes sont les memes c'est ca qui m'interpelle.

il doit y avoir un lien.

A force d'essayer tout ce que je peux avoir comme piste je finis par sauter sur la moindre idée....j'en ai marre je sature.

Je pense a faire appel à un chamman ou bruler un cierge
Messages postés
130
Date d'inscription
jeudi 9 avril 2009
Statut
Membre
Dernière intervention
4 janvier 2016
103
0
Merci
@yoanf26 : Les mêmes problèmes en enlevant tout les périphériques USB et rien de bnaché sur les ports PCI :(

@mmaneewan : Tu as essayé de mettre le BIOS de ta carte graphique à jour ? J'ai lu sur des forums que sa résolvait pas mal de problèmes d'écran noir dans les jeux, peut-être que ...

P.S.: je doute que le chamanisme marche pour nous malheureusement :p
0
Merci
Bonjour à toutes et tous,

j'ai quasiment le même problème....j'installe vista ultimate64, tout va pour le mieux puis j'installe les pilotes concernés (peu importe si ce sont les derniers à jours ou pas) puis quand l'odi reboot, j'arrive jusqu'au bureau puis , (chose que je n'ai encore lu nulle part, j'ai d'accord, un écran noir mais mon écran lcd me certifie qu'il n'y a plus de connection DV-I en cours et s'éteint complètement)...

On peut dire que j'ai essayé pas mal de choses (changement de cable vidéo, X (dés)installation de pilotes en tous genres (tous ce qui a été dit, je l'ai tenté....Ce qui est plutôt évident, c'est que j'ai installé sur un deuxième DD windows7 qui roule sans problème...

Déjà que j'ai du racheter une 9800gt alors que j'avais déjà la 6800gt car ma carte mère GigaByte n'était pas compatible (bon en terme de pertformences, je ne vais pas me plaindre)

Quelqu'un pourrait-il nous sortir de là ? D'avance, merci

Matos
-------
Carte mère Gigabyte S-series-GA-MA790GP-DS4H
Geforce 9800 GT Sweex
4Go Ram
LCD sony SDM73HX
Messages postés
9
Date d'inscription
mardi 15 novembre 2005
Statut
Membre
Dernière intervention
3 octobre 2010
0
Merci
Re,

désolé pour le double post,

Schiz0b0y, pourrais-tu m'expliquer comment opérer une mise à jour bios pour la carte graphique, je commence maintenant une recherche active à ce sujet, mais te le demande en cas ou je ferais choux blanc, merci à toi.
0
Merci
Merci