Probleme d'affichage de mon site internet [Résolu/Fermé]

Signaler
-
 dp3d -
Bonjour,

voila j'ai plusieurs Problème sur mon site www.dp3d.fr

1er mon site s'affiche mal avec internet explorer mais s'affiche bien avec firefox
probleme css ? (voir code source des pages)

2ème pourquoi mes pages s'ouvre dans de nouveaux onglets ou page internet ?

merci de m'éclairer car j'ai beau relire mes scripts je trouve rien

4 réponses

Messages postés
1064
Date d'inscription
jeudi 25 octobre 2007
Statut
Membre
Dernière intervention
30 juin 2013
133
logique
au lieu d'avoir une page "index.html" comme tout le monde où tu pourrais avoir tes liens de pages "normaux" etc... tout est en php...
de plus tu as aucun metatags... si un jour tu veux être référencé...
La création d'un site commence par la réflexion de son devenir...
Messages postés
387
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
14 août 2014
1
Bonsoir,
Pour le deuxième point, enlève ceci (se trouve dans les balises <a>) : target="mainFrame"
merci Adenora

mon 2ème problème est résolu (l'ouverture de page est maintenant normal) je n'avais pas prêté attention à ça.

par contre pour l'affichage entre firefox et internet explorer !

pour les metatags je suis dessus, mais j'ai mis en stand by le temps de trouver une réponse à ce problème d'affichage
j'ai trouver

j'ai rajouté un découpage supplémentaire pour internet explorer dans mon css
#entete {
width: 99%;
height : 110px;

}
et <div id="entete"> pour mon entete

merci pour vos infos
il me reste 2,3 bug à regler mais je m'en sortirai ! ;-)
Messages postés
2590
Date d'inscription
dimanche 9 septembre 2007
Statut
Membre
Dernière intervention
7 mai 2016
332
ça s'affiche mal avec quel version d'ie sous ie7 je ne vois pas de différence par contre ie 6 ne sais pas lire les png avec de la transparence le pb peut être corrigé par javascript https://www.alsacreations.com/astuce/lire/81-obtenir-la-transparence-png-avec-internet-explorer-6.html sinon ton css est parfait il passe au css validator
normal, que tu ne vois plus la différence car j'ai mis a jour le site (avec la correction ;-) ).
merci pour l'info de la transparence car moi j'ai pas le problème sur mon poste.