Menu

Relay access denied [Résolu/Fermé]

- - Dernière réponse :  anonymous - 1 mars 2010 à 14:09
Bonjour à tous,
Que ce soit sous linux ou sous xp, lorsque j'essaye d'envoyer un courriel avec mozilla-mail, à un correspondant disposant d'une adresse autre que celle attribuée par mon fai, à savoir wanadoo, je me retrouve avec le message d'erreur suivant "Il y a une erreur lors de l'envoi du courrier. Le serveur de courrier a répondu : xxxxxx@hotmail.com ou encore xxxxxx@dgi.finances.gouv.fr : Relay access denied. Vérifier que votre adresse mail dans les paramètres de Comptes courrier et forums est correcte et essayer à nouveau."
Si l'un d'entre vous a connu cette situation ou ce problème qu'il ait la gentillesse de me faire part de sa solution.

Merci
Catiopee
Afficher la suite 

20/40 réponses

Meilleure réponse
5
Merci
J'ai été confronté au même problème (pas moi directement en fait mais un de nos utilisateurs ; je fais de la hotline) et j'ai une réponse à ce problème.
Utilise-tu bien les serveurs DNS de Wanadoo (c'est à dire ceux qui te sont affectés à la connexion ou rentrés manuellement ; 193.252.19.3 par exemple) ?
En effet, si tu n'utilises pas les DNS de Wanadoo, la réponse à smtp.wanadoo.fr est différente (ça ne renvoie pas les mêmes adresses IP) et tu contactes alors en fait les serveurs "publics" qui reçoivent les mails à destination de @wanadoo.fr => si l'adresse destination dans ton mail n'est pas du Wanadoo, c'est considéré comme une tentative de relaying => refusé.
Il ne faut pas que ton poste client (Windows ou Linux, même combat) utilise une résolution DNS "locale" mais il le faut le relayer sur les DNS de Wanadoo.
Pour confirmer cela, si tu fais "telnet smtp.wanadoo.fr 25", tu dois avoir actuellement une bannière du style (faire "quit" pour sortir) :
220 mwinf1112.wanadoo.fr ESMTP **************************

Avec les DNS de Wanadoo configurés, tu obtiens qqc du genre :
220 mwinf0402.wanadoo.fr ESMTP ABO **************************

Remarque le ABO dans la bannière... On ne contacte pas le même serveur SMTP.

Une résolution DNS sans utiliser directement les DNS "abonnés" de Wanadoo donne aujourd'hui la série d'adresses IP :
smtp.wanadoo.fr. 600 IN A 193.252.22.78
smtp.wanadoo.fr. 600 IN A 193.252.22.79
smtp.wanadoo.fr. 600 IN A 193.252.22.80
smtp.wanadoo.fr. 600 IN A 193.252.22.81
smtp.wanadoo.fr. 600 IN A 193.252.22.82
smtp.wanadoo.fr. 600 IN A 193.252.22.83
smtp.wanadoo.fr. 600 IN A 193.252.22.89
smtp.wanadoo.fr. 600 IN A 193.252.22.92
smtp.wanadoo.fr. 600 IN A 193.252.22.110
smtp.wanadoo.fr. 600 IN A 193.252.22.116
smtp.wanadoo.fr. 600 IN A 193.252.22.123
smtp.wanadoo.fr. 600 IN A 193.252.22.65

Avec les DNS abonnés, on obtient :
smtp.wanadoo.fr. 567 IN A 193.252.22.77
smtp.wanadoo.fr. 567 IN A 193.252.22.88
smtp.wanadoo.fr. 567 IN A 193.252.22.91
smtp.wanadoo.fr. 567 IN A 193.252.22.109
smtp.wanadoo.fr. 567 IN A 193.252.22.115
smtp.wanadoo.fr. 567 IN A 193.252.22.122
smtp.wanadoo.fr. 567 IN A 193.252.22.64
smtp.wanadoo.fr. 567 IN A 193.252.22.72
smtp.wanadoo.fr. 567 IN A 193.252.22.73
smtp.wanadoo.fr. 567 IN A 193.252.22.74
smtp.wanadoo.fr. 567 IN A 193.252.22.75
smtp.wanadoo.fr. 567 IN A 193.252.22.76
==> ce ne sont pas les mêms réponses...

Quant à savoir pourquoi ça fonctionne comme ça chez Wanadoo, seuls eux peuvent le dire...
Désolé pour la longueur du post...

Dire « Merci » 5

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39378 internautes nous ont dit merci ce mois-ci

MERCI de ton explication !!!!

La solution de Golliet Joel marche nickel.

Bonne continuation,

bnj.
J'ai exactement le même problème mais je n'ai pas compris où et quand on rentre ces fameux DNS ?
Quand je fais "telnet smtp.wanadoo.fr 25" j'ai effectivement la bannière sans ABO.
Si quelqu'un pouvait m'expliquer comment "relayer [mon poste client] sur les DNS de Wanadoo", merci !
1
Merci
meme pb avec eudora

solution:
en faisant "ipconfig /all" dans commande MS-DOS,
j'ai vu que mes 2 cartes reseau
(modem ADSL USB et Ethernet reseau local)
n'avaient pas les memes DNS.
j'ai remis 2 fois les 2 DNS wanadoo
de mon secteur (Nancy) fournis par France Telecom
(he oui, le 10 14 est parfois bien plus rapide
et efficace que wanadoo que je n'ai jamais contacté) :

193.252.19.3 et 193.252.19.4
dans la config TCP/IP de mes 2 connections reseau.

avant, avec les mauvais DNS, quand l'envoi de méls à d'autre adresses que les abonnés wanadoo (type xxxx@wanadoo.fr),

"telnet smtp.wanadoo.fr 25" dans commande MS-DOS me répondait
220 mwinf1112.wanadoo.fr ESMTP **************************

maintenant, avec les bons DNS de Wanadoo,
"telnet smtp.wanadoo.fr 25" dans commande MS-DOS me répond
220 mwinf0402.wanadoo.fr ESMTP ABO **************************

c'est "ABO" qui fait toute la difference.

j'avais cherché des Torjans avec Ad-Aware, SpyBot sans resultat.
j'en deduis que ce n'est pas un pb de Torjan.
HijackThis et a²free ne m'ont pas servi pour resoudre ce pb.

Grand merci à mermoz59 Golliet Joel (www.commentcamarche.net/forum) et Bonemine (www.informatruc.com/forum) !!!

http://www.informatruc.com/forum/sutra39335.php
http://www.informatruc.com/forum/ftopic8015-0-asc-0.php
Messages postés
2
Date d'inscription
vendredi 21 janvier 2005
Statut
Membre
Dernière intervention
14 février 2006
1
1
Merci
Bonjour, je vais vous donner une autre solution.
Dans mon cas, je ne suis plus chez wanadoo mais chez 9 telecom.
Ce que j'ai fait c'est que au lieu de mettre smtp.wanadoo.fr, j'ai mis : smtpauth.wanadoo.fr

Allez savoir pourquoi mais cela fonctionne tres bien.
Re,

En continuant mes recherches, je viens de trouver une solution sur http://www.teladsl-7.com/index.php?showtopic=6452.

Mettre directement l'adresse IP du serveur SMTP de Cegetel : 84.96.92.4 (qui serait en fait une adresse de chez Neuf, mais ça reste dans la famille...).

Et ça marche. Combien de temps ?

FG
> Heffgé -
Ca marche en effet !
Merci beaucoup Heffgé !
> Emmanuel -
Y'a pas de quoi.

FG
LE HOUX
Messages postés
1
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
8 juillet 2006
> Emmanuel -
Un très grand merci à Heffgé qui m' a permis de résoudre mon problème de "relay access denied" : abonné CEGETEL, je me voyais refuser l' accès pour mes mails envoyés à partir d' outlokk ou de incredi mail, ou bien ceux ci étaient refoulés comme SPAM. Plusieurs recours à la hot mail n' ont été bénéfiques que pour le compte en banque de CEGETEL. La saisie de l' adresse IP du FAI Neif telecom a tout résolu.
Jusqu' à quand les FAI se moqueront ils aussi ouvertement de leurs client ? car je rappelle que ces refoulements de messages étaient uniquement dus à des modifications opérées par le FAI sur son réseau !!!!!!! Il est temps qu' une organisation structurée d' utilisateurs Internet fasse contrepoids à ces opérateurs qui bâtissent des fortunes en toute irresponsabilité sur le dos des consommateurs
> Heffgé -
Formidable !
en effet, remplacer le SMTP de Cegetel par une IP marche...
Effarant et impossible à deviner mais... merci !
0
Merci
Tu as mis le bon serveur SMTP de Wanadoo dans ta config de mozilla ? Si tu ne passe par le bon relay de Wanadoo (le serveur SMTP) il est possible que tu sois rejete comme spammeur.
Si tu ne connais pas le serveur SMTP tu devrais le trouver dans la doc de Wanadoo ou sur leur site web.
Merci, kmf de ta réponse.
J'ai tout bien mis le bon serveur smtp qui est 25 smtp .wanadoo.fr
Y a t-il autre chose à mettre ?
Si tel est le cas peut-on me renseigner

Merci
Profane
0
Merci
Normalement ca devrait marcher (le caractere "blanc" dans
smtp .wanadoo.fr

ne figure pas dans la config de mozilla ? Seulement pour verifier.). Peut-etre Wanadoo exige un mot de pass pour utiliser leur serveur smtp ?
Il faut regarder leur doc.
Sinon il y a l'hypothese que ton numero IP (s'il est fix) est blackliste (mis sur liste noire) ? Ca peut en theorie arriver quand un pc Windows est controle par de pirates, des vers/virus et sert comme relay pour des spams. Ca s'appelle des zombies et les spameur "achetent" l'utilisations des zombies (par unites de millier) aupres des pirates. Ce n'est pas une blague, c'est malheureusement serieux. Si on est victime de ca ce n'est pas evident de s'en sortir.

Tu peux deja verifier tes antivirus en Windows et aussi ton firewall.
Bizarrement, tout fonctionne sous windows, je ne recontre ce problème que sous linux. Je n'ai pas d'anti virus, mais j'ai iptables et tous mes ports sont fermés (j'ai vérifié avec pcflank).
merci
Catiopee
0
Merci
Que ce soit sous linux ou sous xp, lorsque j'essaye d'envoyer un courriel avec mozilla-mail, à un correspondant disposant d'une adresse autre que celle attribuée par mon fai, à savoir wanadoo, je me retrouve avec le message d'erreur suivant "Il y a une erreur lors de l'envoi du courrier.
C'est dans ton premier message que tu as le meme probleme en Windows et Linux. C'est en contradiction avec:
tout fonctionne sous windows, je ne recontre ce problème que sous linux.
Ca change en principe completement la donnee! Si on a pas les vraies infos on ne peut pas vraiement aider.

Pour firewall il faut surtout verifier quand Windows tourne. En linux il n'y a que peu de danger. C'est ton installation Windows qui est en cause. Si tu n'as pas d'antivirus cherches un et verifies ton systeme (en Windows).
Bonjour,
Désolée pour cette contradiction. En effet le problème est identique sous xp et Mandrakelinux 10.1
Merci
0
Merci
Salut

Je viens de découvrir ton problème : je n'ai pas de solution car j'ai le même type d'ennuis avec wanadoo :

Ma config est un serveur 2003 standard avec 4 postes sur xp pro et 1 poste win 98 se . un systeme d'antivirus client serveur sur tous les postes, un routeur DLINK.

Le problème est global car le poste win98SE fait la même chose.



Si tu as une solution ou quelqu'un d'autre

Merci d'avance

Pascal
Messages postés
4
Date d'inscription
vendredi 28 janvier 2005
Statut
Membre
Dernière intervention
19 mars 2005
1
0
Merci
Bonjour, si c'est le même problème que j'ai eu (cad envoi vers messagerie ....@wanadoo.fr ok et les autres non), j'ai la solution pour toi.
Moi j'ai eu ce problème et mon serveur de courier sortant était smtp.wanadoo.fr.
Aparament wanadoo (serait, à vérifier, en faillite cachée)
Essaye de changer ton smtp.wanadoo.fr en smtp.oleane.net
(Il paraitrait que wanadoo serait en faillite et que ca soi aoléane qui ai repris le flambeau mai c pa du sur)
En tou cas moi ca a fonctionner impec avec ca.
essay et tu verra
0
Merci
Comment est connecté ton poste chez Wanadoo ?
Par une LiveBox, un modem ADSL, un routeur ADSL, ???
Quel est ton système d'exploitation ?
Si tu es sous Windows, connecté à Internet, que donne la commande "ipconfig /all" dans une commande MS-DOS (pour atteindre ces commandes MS-DOS, tape "command" (Win95/98) ou "cmd" (Win2000/XP) dans Démarrer/Exécuter. Le paramètre DNS doit apparaître. C'est un paramètre qu'on trouve dans les paramètres TCP/IP du poste.
Un peu plus de précisions : je suis sous Mandrake 10.1, mon modem est un ADSL de type Sagem fast 800 E3, et mon logiciel de messagerie est Thunderbird (mais KMail donne le même résultat).
0
Merci
La config DNS est donc dans le fichier /etc/resolv.conf sur ton poste Linux.
Qu'est-ce que tu as dedans (une fois connecté à Wanadoo) ?
Tu as configuré la connexion par l'utilitaire Mandrake (drakconnect) ?
Normallement, y'a un moment où tu peux spécifier le DNS à utiliser. Je ne sais pas ce qu'est le choix par défaut.
Une fois connecté, essaie à la limite d'éditer le fichier /etc/resolv.conf (sous "root", par l'éditeur de texte de ton choix) et de mettre ou remplacer la ligne commançant par "nameserver" en mettant l'adresse IP d'un serveur de Wanadoo (ex : 193.252.19.3) => ton fichier devrait ressembler à :
nameserver 193.252.19.3
search wanadoo.fr

Refait ton telnet smtp.wanadoo.fr 25 et vois si ça a changé quelque chose au niveau de la bannière. Si c'est OK, faut vraiment trouver comment changer la config DNS de ta connexion Wanadoo sur ta Mandrake.
Joel,
Tout d'abord merci pour toutes ces explications, ca fait maintenant 3 mois que j'ai ce soucis avec Outlook sous Windows XP et tu m'as donné une lueur d'espoir. Je suis en connextion livebox habituellement mais etant donné que je me déplace pas mal ces derniers temps (actuellement à londres) je suis souvent connecté via d'autre FAI. J'ai effectivement l'absence de ABO quand je tappe "telnet smtp.wanadoo.fr 25" [exactement: 220 mwinf1223.wanadoo.fr ESMTP *********].
Cela dit je ne comprend pas ou plutôt je ne sais pas comment modifier manuellement le DNS. Peux-tu m'aider s'il te plait.
> Claudy -
Je crois que ça a déjà été dit dans ce fil de discussion (si ce n'est pas le cas, ce le sera maintenant), en règle générale, le serveur SMTP que tu dois utiliser où que tu soies dans le monde est celui du FAI qui gère ta connexion à Internet.
Si tu es chez Wanadoo, tu utilises ceux de Wanadoo (et en général tu as alors les DNS de Wanadoo de configuré -> tu n'as pas le problème mentionné dans ce forum) ; si tu es chez Free, tu utilises le SMTP de Free (smtp.free.fr), si tu es sur un réseau local d'Université, tu te rencardes auprès du CRI correspondant pour savoir ce que tu dois utiliser, ...
Sinon, une possibilité est d'installer sur ton propre poste un serveur SMTP (tu configures alors ton outil de messagerie pour utiliser 127.0.0.1 comme SMTP) qui balancera alors ses mails "en direct" sur le net. Inconvénient : avec la montée en puissance des spams, quelques gros serveurs de messagerie dans le monde refusent les connexions qui peuvent leur arriver en direct d'adresses IP d'abonnés ADSL. Ils t'obligent alors à utiliser des serveurs SMTP "connus" (celui des grands FAI notamment) et tu dois donc partir du principe que le SMTP à utiliser est celui du FAI que tu utilises.
> Golliet Joel -
Merci pour ta réponse rapide, c'est vraiment sympa. Il s'avère que je suis vraiment débutant donc désolé par avance pour mes eventuelles gaffes...

Si je comprends bien les adresses DNS presentes sur: http://www.wanadoo.fr/bin/frame2.cgi?u=http%3A//assistance.wanadoo.fr/reponse791.asp ne sont valables que pour une configuration réseau!?
Je ne peux vraiment pas rentrer ces adresses manuellement!?

Ce qui est bizarre c'est qu'une fois connecté à ma Livebox (donc à mon FAI: wanadoo) le problème persiste (ça a été le cas ce week end).

Si tu peux me renseigner une fois de plus sur ce coup je te remercie d'avance.
0
Merci
Effectivement, ça a marché en changeant le fichier "/etc/resolv.conf". La commande telnet donne la bannière avec ABO, et j'ai aussi réussi à envoyer un mail. Merci.
- pour info, j'ai cherché dans le Centre de Contrôle Mandrakelinux, onglet Réseau & Internet, icône Accès à Internet : là aussi on peut voir l'IP du Serveur DNS (et la changer)
- mais il me reste une dernière question : d'où sors-tu cette adresse IP d'un serveur de Wanadoo ? Est-ce qu'ils les rendent publiques ?

Et merci pour tout !
0
Merci
Ces paramètres sont présents sur les documents techniques du support de Wanadoo. A un certain moment, ils étaient systématiquement fournis en parallèle des codes de connexion pour ceux qui voulaient configurer leur connexion "à la main". Depuis, ça a disparu.

L'adresse IP donnée dans la réponse était récupérée je ne sais où. j'avais ça dans un coin.

On trouve par contre dans la section Assistance de Wanadoo d'autres adresses IP.
http://www.wanadoo.fr/bin/frame2.cgi?u=http%3A//assistance.wanadoo.fr/reponse791.asp
Je ne sais pas si ça change quelque chose...

Normallement, tu dois aussi pouvoir configurer ton Linux pour que les DNS du FAI soient récupérés à la connexion (comme ton adresse IP). J'ai pas + d'infos mais ça doit se faire.
Bonjour,

J'ai un compte et donc une adresse wanadoo mais je viens de partir aux US et impossible comme pour tout le monde d'envoyer des message a des destinataires autres que machin@wanadoo.fr avec ma nouvelle connexion et outlook. J'ai bien réussi a voir que ca ne marchait pas avec "telnet smtp.wanadoo.fr 25" mais je ne comprend pas comment ni où aller changer le dns. Je ne suis pas super douée alors est-ce que quelqu'un pourrait me donner des explications détaillées (je suis sous windows xp)?

Merci beaucoup!
kmf31
Messages postés
1569
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
27 février 2007
471 > Eve -
Si tu as une connexion internet autre que chez Wanadoo, par exemple aux US, il ne faut pas et on ne peut pas utiliser le smtp de Wanadoo. Le smtp de Wanadoo va simpler rejeter ca!

Il faut utiliser un serveur smtp de l'autre fournisseurs d'acces internet (celui ou on est connecte) et ca peu importe si son a toujours une adresse mail chez Wanadoo. Pour acceder a et recevoir ses messages destines a son mail avec adresse Wanadoo ca passe toujours par le serveur pop ou imap de Wanadoo. Ca marche depuis partout avec toute connexion internet.

Mais ca n'a rien avoir avec le smtp qu'on utilise pour envoyer de mails:
Bref si tu as une autre connexion internet que Wanadoo => tu dois utiliser le smtp pour l'autre connexion, s'il y en a. S'il n'y a pas de smtp avec cette autre connexion il ne reste que les webmails pour envoyer les mails.
0
Merci
Salut à tous,

Après des recherches sur le net, il s'avère que wanadoo à brider son port smtp mais connaissant comment fonctionne FT il ne nous dira jamais qu'il a fait ce type de manip il mettra la faute sur les autres serveurs comme hotmail ou yahoo par exemple.

Cdt.
0
Merci
J'ai constaté le même problème sur wanadoo et arachno. Je pense simplement qu'ils brident leurs serveurs pour ne pas avoir à gérer des messages de personnes qui ne sont pas leurs clients : si tu n'es pas abonné chez eux, tu dombe sur un réseau DNS qui interdit la fonction relay.
0
Merci
Ouais, mais ce n'est pas comme ça qu'on configure l'anti-relayage sur des serveurs de messagerie habituellement...
Là, clairement, c'est pour bien limiter le champ d'action de leurs utilisateurs (je ne dis pas que c'est mal ; mais l'anti-relayage que tous les FAI mettent en place n'est pas la cause ici de cette config).
Ils pourraient par contre mettre ça + en évidence dans leurs docs techniques parce qu'on ne trouve l'info que sur des forums de ce genre...
0
Merci
J'avais le meme probleme qu'au début, et en fait y'a juste à changer dans le compte de outlook le smtp, en mettant directement l'IP mais celle fournit pas Golliet Joel car le DNS de wanadoo me donné une mauvaise IP.
Merci
meme pb...
Mais quelle adresse IP faut-il positionner pour le smtp de wanadoo.fr ?
> toine -
Regarde le message 10 de ce thread (http://www.commentcamarche.net/forum/affich-1180899#10) => y'a une liste des IP qui correspondent aux serveurs SMTP abonnés de Wanadoo (la 2eme).

Mais la solution d'utiliser les @IP des serveurs SMTP de Wanadoo est "risquée" (suffit qu'ils changent du jour au lendemain leur plan d'adressage et t'es grillé...).

Dans la logique (de Wanadoo en tout cas), vaut mieux utiliser leurs serveurs DNS.
0
Merci
Mon problème est identique aux autres en utilisant outlook express sous XP.
Lorsque je rentre les adresse DNS dans les propriétés de ma connexion internet, je n'ai plus accés à internet (193.25.19.3 et 193.252.19.4). Est ce lié au fait que j'ai une adresse messagerie wanadoo et une connexion chez free?
Redge
0
Merci
Un grand merci à Golliet Joel; ça fait quelque temps que Outlook est bloqué chez moi !

Pour info, j'ai wanadoo + livebox et j'ai mis les DNS de Wanadoo dispo ici :

http://www.wanadoo.fr/bin/frame2.cgi?u=http%3A//assistance.wanadoo.fr/reponse791.asp

En configurant les DNS je n'avais plus accès à Internet; j'ai donc mis une IP fixe et tout fonctionne ;-)
Messages postés
2
Date d'inscription
jeudi 15 décembre 2005
Statut
Membre
Dernière intervention
6 avril 2006
0
Merci
Merci à Golliet Joel, effectivement l'enregistrement manuel des DNS à réglé le problème d'envoi de mail.
Voici ce que dit wanadoo

Quelles sont les adresses DNS de Wanadoo


Il ne faut désormais plus spécifier d'adresses DNS pour se connecter à Wanadoo. Celles-ci sont récupérées de manière automatique à la connexion. Il arrive cependant, avec certains routeurs ou firewall que la connexion ne passe pas. Ceux-ci nécessitent de saisir manuellement les adresses DNS pour fonctionner. Voici donc les adresses à spécifier :

DNS primaire 80.10.246.2
DNS secondaire 80.10.246.129

Mon logiciel de messagerie est thunderbird pour ceux qui se posent la question de la compatibilité avec wanadoo
0
Merci
Bonjour

Je viens d'avoir le même problème sur un site équipé d'une petite dizaine de postes avec des adresses wanadoo derrière un routeur NetGear ; du jour au lendemain, sans prévenir, il est devenu impossble d'envoyer des msg ; réponse : problème serveur smtp, relay access denied .

Un technicien wanadoo a préconisé de remplacer l'adresse dns secondaire (final 129 remplacé par 132), sans résultat ; du coup, il a fait remplacer, sur chaque poste, dans le compte courrier, le serveur "smtp.wanadoo.fr" par une adresse IP en dur, et tout est rentré dans l'ordre.

Dans un autre contexte et tout à fait par hasard, aujourd'hui, j'ai voulu envoyer une réponse à un spammeur, et j'ai aussi eu en retour un "relay access denied".

Merci à tous pour toutes les infos sur ce forum
Passez de bonnes fêtes
JFT