Excel test logique avec date comme valeur [Résolu/Fermé]

Signaler
-
 Percileslestratege -
Bonjour,

mon objectif lorsque ma cellule contient une date celle ci doit être comptabilisée = 1, aucune date alors =0
je ne sais pas comment valider mon test logique puis que pour la nième fois il est faux

voici ma dernière tentative
SI(F24="DATEVAL(jj-mmm)";1;0)

merci
A voir également:

3 réponses

Messages postés
191
Date d'inscription
lundi 1 décembre 2008
Statut
Membre
Dernière intervention
13 août 2015
91
Bonjour,

Je ne connais pas de formule pour tester si c'est une date.
tu peux essayer ceci =
=SI(ESTERREUR(DATEVAL(TEXTE(A1;"jj/mm/aa")));0;1)

Je transforme la cellule en texte avec un format date et ce texte je le transforme en date ==> si le résultat est une erreur, ce n'était pas une date donc 0 sinon 1

Si quelqu'un connaît une formule plus propre, je suis preneur.

A +
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 78440 internautes nous ont dit merci ce mois-ci

merci pour ton aide, grâce à ta réponse et en prenant les choses à l'envers, je ne tiens plus compte de la date j'opte pour

=SI(F24="";0;1)
Super efficace, merci beaucoup !
Messages postés
1
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
4 mars 2012
3
Bonjour à tous,

Un fonction à mettre dans un module :

Function EstDate(Cel As Range) As Byte 'BH² sur XLD
If IsDate(Cel) Then EstDate = 1
End Function


Les valeurs en A1 et suivantes :
Mettre =EstDate(A1) en B1

A+ à tous

Bonjour,

on est 4 ans plus tard mais c'était juste pour dire que votre macro fonctionne parfaitement bien quelque soit le format de date,

Merci
Messages postés
1756
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
22 mai 2017
221
 



… la fonction si() ne sait pas reconnaître une date qui, à défaut d'être formatée, est un nombre comme un autre. Tu peux éventuellement vérifier si ta cellule est vide

=si(<cell>="";"vide";"plein") …