Excel : résultat négatif égale à zéro [Résolu/Fermé]

Signaler
-
 Flo -
Bonjour,
Mon problème est relativement simple,
je voudrais que quand le résultat d'une soustraction est négatif (par exemple 0-2=-2), il apparaisse égale à zéro ?
Merci de votre aide.
jelumic
A voir également:

4 réponses

Messages postés
17086
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Salut,

Regardes cette formule qui prend référence sur les cellules A1 =0 et B1 =2

=SI(A1-B1<0;0;A1-B1)

A+
42
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 71580 internautes nous ont dit merci ce mois-ci

OK, ça marche,
Merci.
Merci, j'avais oublié cette formule qui est bien utile.
ok cette formule fonctionne sauf que j'ai un probleme, j'aimerais que la valeur '0' soit RÉELLEMENT '0'

Je m'explique, si la somme de mon calcule est de -4,ce code affiche 0 et c est parfait, sauf que j'aimerais qu'apres le premier calcule, si j'ajoute +1 a mon calcule, que la somme soit 1 et non encore 0 (Puisque pour excel,meme si il affiche 0,pour lui la somme est encore à -4.

J'aimerais qu'excel oublie que c est -4 et meme si c est -124, qu'il croit que c est 0 et donc, si j ajoute 1 a cette somme, qu il m affiche 1 et non encore 0.

Merci :)
Messages postés
17086
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Salut,

Pas si simple, si en A1 tu as exemple 1 et en B1 5
le résultat est -4
si tu rajoutes 1 en A1 donc A1 est 2 moins B1 5 résultat négatif -3 donc toujours 0 et même en VBA le résultat sera toujours négatif ou alors tu ajoutes une cellule de calcul exemple C1

=SI(A1-B1<0;0;A1-B1)+C1

et la on pourra jouer avec des conditionnelles supplémentaires si besoin est
ok merci mike.