Menu

[excel] insertion automatique de valeur [Résolu/Fermé]

- - Dernière réponse :  joniyyy - 9 janv. 2009 à 19:02
Bonjour,

Je vais essayer de vous expliquer avant toutes chose ce que je suis train de faire avant de poser ma question:
J'ai un tableau avec deux colonnes; dans l'une des diamètres de tuyaux, dans l'autre les temps nécessaire à leur soudure unitaire.

J'ai ensuite un autre tableau avec quatres colonnes; une avec le diamètre du tuyau, une avec le nombre de soudure, une avec le temps de la soudure unitaire, et la dernière le prix temps des soudures.

Voila ma question: comment faire pour que lorsque je rentre ma taille de tuyau dans le second tableau j'ai automatiquement le temps de la soudure unitaire qui s'affiche en fonction des temps que j'ai rentré dans le premier tableau?

Merci.
Afficher la suite 

5 réponses

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
216
0
Merci
bonjour à tous

A2:B14 est la table concernée par le RECHERCHEV, mais la recherche ne se fait que sur la 1ere colonne

2, revoie la valeur de ma 2eme colonne (dans ce cas la valeur de la colonne B) Si la recherche est Ok

Faux : Impose la recherche de la valeur EXACTE et renvoie une erreur si la valeur n'est pas trouvée, si on avait mis Vrai, la recherche s'arreterait automatiquement à la valeur supèrieure et renverrait la valeur immédiatement inférieure, ce qui impose le Tri de la base.
0
Merci
ok merci.

Dernière question: comment je fait pour remplacer le #N/A par "DN non répertorié" lorsque je rentre un diamètre qui n'est pas dans mon tableau de recherche?
Messages postés
1270
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
495
0
Merci
Bonjour,

Tu modifies la formule ainsi:

=SI(ESTERREUR(RECHERCHEV(E2;$A$2:$B$14;2;FAUX));"DN non répertorié";RECHERCHEV(E2;$A$2:$B$14;2;FAUX))

Bonne journée.
0
Merci
Merci de votre aide.

Vous pouvez passer en résolu.
Bonne soirée.
Messages postés
1270
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
495
-1
Merci
Bonjour,

Une solution sur http://cjoint.com/?biopBjtLjJ

Bonne journée.
Merci

Je ne comprend pas trop la fin de la formule que tu m'as donnée:
RECHERCHEV(E2;$A$2:$B$14;2;FAUX)
E2 est la valeur à partir de laquelle on fait la recherche
$A$2:$B$14 est le tableau dans lequel je fait ma recherche
mais en suite, 2;FAUX ca sert à quoi?

Merci.