Excel: aff. N° de semaine et année [Résolu/Fermé]

- - Dernière réponse :  MOUSSE - 7 janv. 2009 à 19:03
Bonjour,

sous excel 200x

Je souhaite afficher le numero de la semaine ( 1 a 52) ainsi que l'année a partir d'une cellule contenant la date:

A1: 07/01/2009
et je souhaiterai recuperer 02/09 en cellule A2

la fonction NO.SEMAINE ne m'affiche que 2...

Avez vous une solution Merci
Afficher la suite 

2 réponses

Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
123
0
Merci
Bonjour,

Assayez cette formule: Si vous voulez le résultat en A2.

=NO.SEMAINE(A1;2)&"/"&DROITE(ANNEE(A1);2)

A+
Messages postés
15953
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 novembre 2019
2820
0
Merci
Bonjour,

Nosemaine te donne le numérotage des semaines aux normes US; En europe, il faut utiliser la norme ISO le numéro de la semaine est donnée par la formule
(ENT(MOD(ENT((A1-2)/7)+0,6;52+5/28))+1)
source: Laurent Longre
http://xcell05.free.fr/

la formule proposée au format 02/09 est:
=SI(A1=0;"";TEXTE((ENT(MOD(ENT((A1-2)/7)+0,6;52+5/28))+1);"00")&"/"&TEXTE(DROITE(ANNEE(A1);2);"00"))
Merci

c'est ce qu'il me fallait!