Posez votre question Signaler

Convertir un fichier Excel en csv [Résolu]

isaaa - Dernière réponse le 20 nov. 2008 à 09:14
Bonjour,
je dois convertir des donnees Excel en donnees csv, separées par des virgules (windows) et ca ne marche pas en faisant la demarche classique (enregistrer sous). en fait, quand je le fait, le contenu de la page reste identique ou du moins, pas comme ca devrait etre...
en fait mon but est de creer une base de données sur Sales force et je dois importer mes données via outlook, obligatoirement en csv.
merci par avance pour votre aide !
Lire la suite 
Réponse
+0
moins plus
bonjour

D'après ce que tu dis, la structure de ton fichier excel ne doit pas être conforme à la structure attendue.

Les colonnes ou champs doivent être conforme aux champs attendus par outlook ou Salesforce et je pense que tes colonnes n'ont pas la bonne structure, il en manque ou elles ne sont pas dans le bon ordre.

Je pense que tu devrait chercher de ce côté du problème et tu peux mettre des colonnes non documentées dans excel si nécessaire.
isaaa- 19 nov. 2008 à 09:27
Bonjour,
j'ai deja essayé de nommer les colonnes en fonction des champs disponibles sur outlook mais ca n'a rien changé...

j'ai eu l'occasion de nommer des plages...(ca, je sais faire ! )

d'autre part, qu'est ce que la structure des colonnes et comment la modifier? et qu'est ce que des colonnes non documentées?
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+0
moins plus
Bonsoir,

Sur un enregistrement csv excel ne met pas toujours le nombre de séparateurs nécessaire sur les dernières lignes si les derniers champs sont vides (par exemple 32 champs donc 31 séparateurs, sauf sur les dernières lignes où il en manque...).
Teste un import sur 4-5 lignes correctes pour voir si ça peut être ton pb
eric
isaaa- 19 nov. 2008 à 09:30
Bonjour,

d'abord, qu'est ce que des separateurs?

ensuite, j'ai deja fait le test avec un petit nombre de lignes... mais qu'est ce que tu entends par lignes correctes?

et oui, desolé, je n'y connais pas grand chose ! :-)

merci pour ton aide
Répondre
isaaa- 19 nov. 2008 à 10:17
re bonjour...

je viens de me rendre compte de quelque chose...

j'ai un autre doc en csv qui ne contien qu'un contact... j'ai essayé de l'introduire dans salesforce et miracle, ca marche !

alors la je n'y comprend plus rien...

je vais essayer de comparer les deux documents, voir ce qui ne va pas et essayer d'arranger ...
Répondre
isaaa- 19 nov. 2008 à 11:56
re bonjour !

alors, j'ai trouvé d'ou semble venir le probleme :

j'ai affiché mes deux documents csv (celui que j'avais avant et celui que j'ai créé) avec un editeur de texte. j'ai vu qu'il y avait des virgules au lieu de points virgules. je les ai remplacé facilement (rechercher / remplacer) .

par contre il n'y avait pas les guillemets non plus. j'ai fait le test sur un echantillon de 5 contacts en modifiant a chaque fois et ca semble fonctionner...

Ma question est simple : comment faire pour introduire les guillemets a chaque fois de maniere automatique pour le contenu de toutes les cellules, sachant que j'ai mis 30 minutes pour faire 5 contacts et que j'en ai plus de 400 a faire !

merci beaucoup par avance
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+0
moins plus
bonjour

j'ai vu qu'il y avait des virgules au lieu de points virgules

Si tu choisis "enregistrer sous" CSV (séparateur : point virgule) pas besoin de corriger après.

Pour les guillemets, si dans ton fichier excel tu formates tes cellules avec le format personnalisé : \"@\"

tes champs seront entre guillemets mais du coup excel en met 3 de suite, je ne sais pas si cela va te gêner.

Si c'est le cas il faudra avec l'éditeur remplacer les 3 par 1 à moins que je trouve autre chose.

Comme l'a dit Éric, il faut que ta dernière colonne soit renseignée pour que excel mette bien tous les champs :
donc renseigner le dernier champ systématiquement.
isaaa- 20 nov. 2008 à 09:14
Bonjour,

j'ai enfin reussi a resoudre mon probleme :

Salesforce est configuré en Americain avec des virgules alors que excel est configuré point virgule.

j'ai donc fait rechercher / remplacer et ca marche !

merci a tous !
Répondre
Ajouter un commentaire
Réponse
-1
moins plus
bonjour

le contenu de la page reste identique

Cela me semble normal mais si tu ouvres ton fichier csv avec un éditeur (notepad par exemple) il sera bien au bon format.
isaaa- 18 nov. 2008 à 09:16
Bonjour,
j'ai verifié sur un editeur de texte et tu as raison...

par contre ca ne regle pas la question principale, mais merci quand meme !
Répondre
Ajouter un commentaire
Réponse
-1
moins plus
bonjour

je dois importer mes données via outlook, obligatoirement en csv.

Je suppose que c'est cela ta question principale et que l'import ne fonctionne pas ?

Si mon interprétation est correcte, essaie de remplacer avec un éditeur, les virgules par des points virgules.
isaaa- 18 nov. 2008 à 12:44
bonjour,

en fait, l'import fonctionne mais pas correctement...

quand je veux mettre les contacts dans outlook, j'ai l'etape "mappage des champs personnalisés"
j'ai deux colonnes :
de mon doc a outlook

dans la colonne de gauche, on me propose des valeurs, en l'occurence des noms de colonnes separés par des points virgules et en dessous "field 2"

a droite on me propose des champs.

je comprends qu'idealement je devrait faire correspondre le titre d'une colonne de gauche a droite, mais je ne peux pas le faire...

est ce que ca t'aide un peu plus?
Répondre
isaaa- 18 nov. 2008 à 13:44
bonjour,

juste une petite precision : je ne suis pas obligée d'importer mes données dans outlook, je peux le faire directement entre csv et Salesforce, mais ca ne regle pas mon probleme...
Répondre
Ajouter un commentaire
Ce document intitulé «  convertir un fichier Excel en csv  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.