Posez votre question Signaler

Clavier QWERTY AZERTY [Résolu]

barcelofb 5Messages postés samedi 30 août 2008Date d'inscription 31 août 2008 Dernière intervention - Dernière réponse le 23 juin 2013 à 10:11
Bonjour, je viens de recevoir un acer aspire one ZG5 avec linpus linus lite. J'ai besoin du clavier QWERTY canadien français. J'ai un clavier physique QWERTY, mais j'ai choisi la langue française au démarrage et mon clavier me donne du AZERTY. Je suis nul en Linux (toujours sur Mac jusquà aujourd'hui). Quelqu'un peut m'aider?
Merci.
Lire la suite 
Réponse
+10
moins plus
C'est plus ou moins expliqué dans <6> si tu changes la map de clavier depuis KDE. Une autre solution consiste à corriger /etc/X11/xorg.conf. En root ou avec sudo
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
nano /etc/X11/xorg.conf

(nano est un éditeur texte mais tu peux en utiliser un autre si tu préfères). Ensuite va dans la section du clavier et choisis une map française. Pour cela déplace toi avec les flèches et corrige la ligne 'XkbLayout'. Exemple chez moi :
...
Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "latin9"
EndSection
...

Sauve (ctrl x), quitte et relance ta session graphique avec la commande suivante (en root ou avec sudo) :
/etc/init.d/kdm restart

Bonne chance
Ajouter un commentaire
Réponse
+6
moins plus
Oui mais là il est sous linux. En mode texte (ctrl alt f1) :
loadkeys fr

En mode graphique (ctrl alt f7), ça se configura ailleurs. Va dans le panneau de configuration et règle les paramètres linguistiques et régionaux, qui permettent notamment de régler la map de clavier. Par exemple sous KDE c'est dans :

K > centre de configuration KDE > Régionalisation et accessibilité > Disposition du clavier

Bonne chance
barcelofb 5Messages postés samedi 30 août 2008Date d'inscription 31 août 2008 Dernière intervention - 30 août 2008 à 20:13
Bonjour,
Merci de la réponse. Mais je suis vraiment trop nul pour comprendre.

Oui mais là il est sous linux. En mode texte (ctrl alt f1) :

Je fais ctrl alt f1, et il ne se passe rien. Je dois faire cette combinaison de touches quand et où?

loadkeys fr

Le fr conviendra-t-il si je cherche le clavier canadien-français (qui pourrait être cf)?

En mode graphique (ctrl alt f7), ça se configura ailleurs. Va dans le panneau de configuration et règle les paramètres linguistiques et régionaux, qui permettent notamment de régler la map de clavier. Par exemple sous KDE c'est dans :

K > centre de configuration KDE > Régionalisation et accessibilité > Disposition du clavier

Là non plus, je n'arrive à rien avec cette combinaison. Dans les paramètres, j'ai réglé à Français (Canada) mais ça n'a rien changé.
Y aurait-il un panneau de configuration dont j'ignorerais l'existence?
Merci de venir en aide à un vieil écrivain tout à fait nul hors de l'environnement macintosh.

Configuration: Linpus Linux Lite
Camino
Répondre
Asphalt- 30 août 2008 à 23:37
Dans les paramètres, j'ai réglé à Français (Canada) mais ça n'a rien changé.

je comprends pas... un clavier qwerty est un clavier anglais ou us, pas français (azerty )... donc au même endroit, tu dois pouvoir choisir non pas le clavier canadien mais le clavier anglais ou us.
Répondre
barcelofb 5Messages postés samedi 30 août 2008Date d'inscription 31 août 2008 Dernière intervention - 31 août 2008 à 00:19
Désolé de vous recevoir, mais il y a des dizaines de claiviers qwerty (anglais US, anglais uk, etc) et plusieurs claviers qwerty, dont le canadien français (comme il existe un clavier azerty belge).
Mon problème a été réglé parce que j'ai trouvé dans je ne sais trop quel site un commentaire qui conseillait de faire une mise à jour du système. Et ça a fonctionné: j'ai maintenant dans mes icônes de paramètres un utilitaire Claviers qui m'a permis d'avoir accès à mon cher et indispensable clavier c.f.
Merci à tous pour leurs conseils et leur soutien.
Répondre
Ajouter un commentaire
Réponse
+4
moins plus
Bonjour,
la réponse à votre question est :

>loadkeys fr pour passer à un clavier fr-latin1 (azerty) ou
>loadkeys us clavier us (qwerty)

cette commande permet de charger le clavier fr ou us en ligne de commande. Le lien dans KDE concerne uniquement l'interface graphique X (xterm, ...) par contre la commande loadkeys est faite pour le mode console.

Le seul problème que tu pourras avoir : si le fichier du clavier voulu n'est pas installé sur ton système, la commande te dit tout simplement impossible de charger le clavier us (les fichiers de mapping de clavier se trouvent dans le répertoire /usr/share/keyboards/ si je me souviens bien, à toi de vérifier si ça t'intéresse).
Bonne soirée
Issiaka Koné
adaptator- 16 janv. 2009 à 13:30
je possède un aspire one avec linux linpus et je voudrais savoir comment on obtient la console pour mettre le clavier en azerty merci d'avance
Répondre
Specht- 8 janv. 2010 à 12:25
Le sujet est sans doute réglé, mais au cas où, pour accéder à la console sous Linux Linpus Lite on presse les touches Ctrl + F2, puis "xterm" dans la fenêtre qui vient de s'ouvrir, et voilà la console qui s'ouvre.

Salutations.
Répondre
Specht- 8 janv. 2010 à 12:33
Oups, je voulais écrire Alt + F2, sorry !
Répondre
Ajouter un commentaire
Réponse
+2
moins plus
Les distributions linux (debian, ubuntu, linpus,...) proposent un environnement graphique (ou bureau ou encore window manager) comme par exemple KDE, gnome, XFCE, fvwm, icewm etc....

Cet environnement utilise son propre panneau de configuration et donc sa propre map de clavier, c'est donc à toi de trouver dans tes menus ou c'est caché (je t'ai donné l'exemple pour KDE car c'est ce que j'utilise).

Dans ton cas je ne pense pas que tu aies besoin de configurer le mode texte donc laisse tomber ce que j'ai dit. En fait linux lance généralement 6 environnements en mode texte (accessibles de ctrl alt f1 à ctrl alt f6) et un en mode graphique (ctrl alt f7). Dans ton cas tu n'utilises a priori que celui en mode graphique, les autres servant uniquement si le mode graphique est cassé ou non installé (ce qui n'est pas ton cas).

Maintenant pour qu'on puisse t'aider il faut que tu nous dises quel environnement graphique tu utilises (KDE ? gnome ? ...) ?

Bonne chance
barcelofb 5Messages postés samedi 30 août 2008Date d'inscription 31 août 2008 Dernière intervention - 31 août 2008 à 13:59
BONJOUR.
Et désolé de vous avoir fait perdre votre temps. Je ne connais pas la réponse à votre question, mais mon problème a été réglé parce que j'ai trouvé dans je ne sais trop quel site un commentaire qui conseillait de faire une mise à jour du système. Et ça a fonctionné: j'ai maintenant dans mes icônes de paramètres un utilitaire Claviers qui m'a permis d'avoir accès à mon cher et indispensable clavier c.f.
Il faut maintenant que je trouve le moyen d'annuler ma question.
Merci mille fois.
Répondre
Ajouter un commentaire
Réponse
+2
moins plus
chakahot vient de l'écrire. En root ou avec un sudo :
loadkeys fr

Ceci ne corrige le clavier qu'en mode texte. Pour le mode graphique il faut intervenir dans /etc/X11/xorg.conf ou directement dans le panneau de configuration de ton bureau (par exemple sous KDE, dans le centre de configuration KDE).

Bonne chance
Ajouter un commentaire
Réponse
+2
moins plus
C'est bon, j'ai réussi !
Il m'a suffit d'éditer le fichier /etc/X11/xorg.conf avec l'éditeur de texte nano (en console)
Puis, je me suis amusé à recopier :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

j'ai enregistré (CTRL+O) et quitté (CTRL+X)
puis j'ai écris startx, j'ai essayé dans le terminal les lettres 'a' , 'z' et 'm' elles s'affichent correctement !
Ajouter un commentaire
Réponse
+2
moins plus
Bonjour,

si tu as un fichier /etc/X11/xorg.conf


quand à la commande suivante :
/etc/init.d/kdm restart

elle ne fait que redémarrer le serveur X (kdm pour KDE, je pense) sinon fermer sa session et la réouvrir cela devrait le faire aussi.
Ajouter un commentaire
Réponse
+1
moins plus
Bonjour, j'ai installé l'environnement JWM avec debian,
or, je ne trouve pas de centre de configuration (le menu est vide à part "EXIT")
et le fichier /etc/X11/xorg.conf est totalement vide !

comment mettre mon clavier en azerty ?
Ajouter un commentaire
Réponse
+1
moins plus
Euh, vous savez si la commande est valide sous opensolaris svp ? Moi c'est l'inverse : j'ai du faire un clic trop rapide à l'installation, et je me retrouve avec un clavier qwerty. Et comme je ne connais pas du tout solaris (je le teste en machine virtuelle) je n'ai pas trouvé de menu qui permettait de configurer ça...même dans le menu clavier !
Ajouter un commentaire
Réponse
+1
moins plus
Salut,
Solution pour UBUNTU :
pour moi, l'utilisation du terminal ou des combinaisons de touches du clavier ne fonctionnaient pas, alors j'ai fait ceci !

cliquez sur rouage en haut à droite de l'écran > Paramètres système > clavier > Paramètres d'agencement (en dessous du tableau de gauche appuyez sur le + en bas et ajouter Français puis supprimer Anglais US avec le "-")

On peux aussi trouver le clavier dans "Aller à>Système de fichiers>usr>share>application"
Ajouter un commentaire
Réponse
+0
moins plus
Non non laisse la question et reporte plutôt la réponse à laquelle tu fais allusion, comme ça les personnes qui seront confrontées à ton problème pourront également trouver la réponse ici.

Bonne continuation
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour
Je suis sous knoppix j'aimerai savoir quel commande il faut taper pour passer du clavier americain au clavier azerty Je precise que j'utilise la console je pense être sous kde
Ajouter un commentaire
Réponse
+0
moins plus
Moi j'ai fait "flèche sous la majuscule" et majuscule et ça marche.
sous linux.
Ajouter un commentaire
Réponse
-1
moins plus
j'avais aussi la commande
install-keymap fr
en console comme réponse
Ajouter un commentaire
Ce document intitulé «  clavier QWERTY AZERTY  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.