CommentCaMarche
Recherche
Posez votre question Signaler

Synchronisation Exchange <=> iPhone [Résolu]

dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - Dernière réponse le 14 mars 2012 à 12:01
Bonjour,
J'essaie depuis plusieurs jours maintenant de configurer un iPhone 3G pour une synchronisation avec un serveur Exchange.
Après configuration du compte sur l'iphone, en essayant la synchro il me demande d'accepter le certificat, OK, et ensuite plus rien, aucun message synchronisé, aucun évènement du calendrier...
Le compte exchange concerné est bien autorisé pour la synchronisation d'un appareil mobile. ActiveSync sur exchange est bien en place et semble fonctionner (erreur 501 not implemented quand j'y vais avec Firefox, donc c'est bon).
La seule chose qui est récupérée par l'iPhone est l'id de session exchange. C'est tout.
Quelqu'un a-t-il déjà réussi à synchroniser un iPhone avec un serveur Exchange ? Quelqu'un a une idée, une piste, une solution ?
Pour info, c'est moi l'administrateur réseau, le parefeu est bien configuré pour rediriger les requêtes sur le port 443 vers le serveur exchange.
Merci d'avance.
Lire la suite 
Réponse
+11
moins plus
Voici la solution pour résoudre le probléme de certificat qui empeche l'accés à votre BAL Exchange 2007
Vous pouvez aussi trouver la solution ici

http://sites.google.com/...

--SOLUCE--
Avec Exchange 2007, si vous rencontrer un problème de certificat lors de la connexion à OWA et lorsque vous configurez un compte Exchange 2007 / Pushmail / ActiveSync avec vos appareils IPhone (2.2.1) et Windows Mobile, voici la procédure que j’ai utilisé pour résoudre ce problème.

Le message d’avertissement OWA n’est pas bloquant car vous pouvez continuer et accéder à votre OWA, cependant le problème de certificat gène la connexion du IPhone à Exchange 2007 / ActiveSync. Résoudre le problème OWA résout le problème avec l’IPhone, ou vice versa.


• Avec Exchange 2K7 et OWA, lorsque vous vous connectez à votre messagerie par OWA et que votre navigateur internet vous informe qu’il y un problème de certificat avec le message suivant :

Le certificat de sécurité de ce site Web présente un problème.
Le certificat de sécurité présenté par ce site Web a été émis pour une autre adresse de site Web.

• Avec votre IPhone ou Windows Mobile, lorsque vous configurez votre compte Exchange, après la vérification d’accès, votre IPhone vous dit que le :

Certificat pour le domaine XXXX n’est pas valide

L’erreur vient du fait que vous n’avez pas installé de certificat contenant précisément le nom de domaine auquel vous tentez d’accéder.

Si votre URL d’accès à OWA est par exemple : https://mail.toto.fr/owa (définie au niveau OWA du CAS pour l’URL d’accès), alors vous devez générer a partir de votre Exchange 2007 un certificat contenant précisément ce nom de domaine.

RESUMER DES MANIPULATIONS

Pour résumer les manipulations à faire pour générer un certificat correct vous permettant d’accéder directement à OWA et configurer l’IPhone ou Windows Mobile avec un compte Exchange 2007 :

1. Générer dans le PowerShell de votre Exchange 2007 CAS un nouveau certificat avec l’option
–DomaineName mail.toto.fr
2. Activer le certificat sous powershell avec pour le service IIS
3. Copier le certificat personnel dans le trusted root certification Authorities de votre Exchange 2007 afin de le valider complètement
4. Exportez-le à partir du trusted root certification Authorities
5. Installez-le sur votre PC pour accéder directement à OWA sans message d’avertissement
6. Installez-le sur votre IPhone ou Windows Mobile pour configurer l’accès à Exchange

DETAILS DES MANIPULATIONS

Evidemment les ThumbPrint générés et indiqués dans les exemples ci-dessous sont propres à chaque nouveau certificat.

1. A partir du PowerShell de votre Exchange 2007 CAS
2. C’est à ce niveau qu’il faut générer le certificat correct, Tapez :

new-exchangecertificate -DomainName mail.toto.fr

a. Si le PowerShell vous propose de remplacer le certificat actuel, répondez non

Confirm
Overwrite existing default SMTP certificate, '3423EFEE23C8984FFD9AD4E0FC2A0D9BE1F1213B' (expires 05/01/2010 15:22:58), with certificate 'ECEF5481D4D72083EFAB466D6A82682DB74B5DEF' (expires 03/04/201013:55:55)?
[Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): n

b. Le PowerShell vous affiche maintenant le certificat résultant, contenant le ThumbPrint et le nom de domaine.

Thumbprint Services Subject
---------- -------- -------
ECEF5481D4D72083EFAB466D6A82682DB74B5DEF ..... CN=mail.toto.fr

c. Afin de vérifier la création du nouveau certificat taper : get-exchangecertificates, on s’aperçoit que le certificat est valide avec l’option S qui correspond au service SMTP, il faut donc le changer pour le service IIS

Thumbprint Services Subject
---------- -------- -------
ECEF5481D4D72083EFAB466D6A82682DB74B5DEF ....S CN=mail.neoelectra.fr

d. Afin de modifier le type de service autorisé par le certificat, tapez :

enable-exchangecertificate -thumbprint ECEF5481D4D72083EFAB466D6A82682DB74B5DEF -services "IIS"

e. Vérifier la modification avec la commande get-ExchangeCertificat, elle apparait avec l’option W en plus de S

Thumbprint Services Subject
---------- -------- -------
ECEF5481D4D72083EFAB466D6A82682DB74B5DEF ...WS CN=mail.toto.fr

f. A partir des MMC Windows de votre Exchange, chargez le composant Certificats pour l’ordinateur local

g. Dans les certificats personnels, vous devez apercevoir votre certificat généré sous la la forme mail.toto.fr



h. Effectuez un clique droit sur le certificat, puis copiez-le

i. Collez-le dans le répertoire Certificates, de Trusted Root Certification Authorities. il apparaît maintenant dans la liste des certificats autorisés



j. Effectuez un clique droit, et exportez le simplement


k. Une fois exporter, à partir de votre PC, double cliquer sur le fichier afin de l’installer

l. Vous devriez maintenant accéder à votre OWA, sans message concernant le certificat.

Concernant le IPHONE

m. Il faut maintenant transférer le certificat généré sur le IPhone, le plus simple pour moi à été de créer un compte Gmail, de le paramétrer sur le Iphone et d’envoyer en pièce jointe le certificat

n. Une fois envoyer, touchez la pièce jointe afin de l’installer sur le IPhone

o. Le certificat apparaît maintenant dans les profils (Paramètres) de votre IPhone, si il a apparaît comme non signé ou non vérifié, ce n’est pas grave.

p. Re-paramétrer le compte Exchange de l’IPhone en suivant la procédure

http://www.businessmobile.fr/actualites/services/0,3800003789,39382450,00.htm
http://www.apple.com/fr/support/iphone/enterprise/

q. Info : Si votre URL est composé comme ceci https://mail.toto.fr/owa (ou plus compliqué) indiquez simplement dans le paramétrage IPhone : mail.toto.fr
r. Si le message concernant la validité du certificat apparaît une nouvelle fois, appuyez sur accepter, le message ne devrait plus réapparaitre


Voici ma configuration Exchange 2007 / Iphone

Exchange 2007 IPhone
ActiveSync et OWA activés pour l’utilisateur IPhone

URL OWA extérieur : HTTPS://mail.toto.fr/owa
URL OWA Intérieur : sans importance

URL interne ActiveSync par défaut
URL Externe ActiveSync par défaut. Le champ est vide

Authentification OWA :
• Use forms-based authentication
• Users name only : Domain toto.fr

Authentification IIS :

• Require secure channel activé
• Require 128 bits encryption active
• Client certificats ingnorés

SSL Activé
rico06- 28 sept. 2009 à 12:15
Bonjour
Je m'appercois que tu es tres bon dans la configuration de exchange et je viens te soumettre un probleme que j'ai malencontreusment créé dans IIS.
En voulant regler un petit soucis mineur j'ai modifié tout le site web par defaut au niveau de la securité du repertoire dans authentification et controle d'accés ! il m'a demandé si je voulais l'appliquer aussi a tous les fichier en dessous et comme un cretin j'ai dis oui.

Du coup maintenant plus de https via RPC sauf si je suis au bureau avec le DNS du serveur
Plus de synchronisation des mobiles
pour le OWA c'est bon

Donc j'ai suivi quand meme ta manip pour mettre un certificat, c'etait deja un probleme avant j'etais pas en ssl, donc je me suis dit qu'en corrigant step by step.
Mais la vraiment je seche, peux tu m'aider en me donnant des pistes ?
Répondre
Mast416- 20 mai 2011 à 21:24
Bonjour, je possède un iPad 2 en 4.3.3 et je souhaiterais y configurer exchange dessus .
Après la vérification effectuée et en me rendant dans "Mails" j'ai un message d'erreur me disant :
"le connexion au serveur a échouée !
Après plusieurs tentative de reconfiguration le problème perssiste .
Que faire ???

Merci d'avance
Répondre
Ajouter un commentaire
Réponse
+2
moins plus
Up !
Ajouter un commentaire
Réponse
+1
moins plus
Trouvé, ça marche en désactivant l'obligation d'un certificat ssl sur le répertoire virtuel /exchange (owa).

@+
Ajouter un commentaire
Réponse
+1
moins plus
Bon, après intervention d'un technicien France Télécom sur notre serveur, c'est reparti pour moi.

Il a désactivé l'authentification par formulaire qui a du être activée suite à un patch de sécurité ou autre mise à jour Windows.

Pour l'iPhone, Jeff_81, il ne faut pas rendre le SSL obligatoire pour se connecter au serveur Exchange depuis l'extérieur et configurer l'iPhone sans SSL. C'est uniquement dans ces conditions que la synchro fonctionne pour nous.

@+
Titoubc- 24 nov. 2008 à 10:44
Bonjour,

Si vous êtes toujours intéréssés...
J'ai eu le même souci sur un Exchange 2003 et sur un Exhcange 2003 SBS voilà comment je m'en suis sorti pour que celà fonctionne de l'extérieur et on peux laisser le SSL sur l'Iphone.

- il faut le SP2 de Exchange2003 minimum

- il faut que OWA marche en SSL avec un certificat (valide préférence sinon il faudra accepter le certificat deux fois sur l'Iphone...)

- pas besoin d'activer IMAP

- il faut désactiver l'authentification par formulaire dans la console Exchange (Serveur => protocole => HTTP => propriétés sur serveur virtuel")

- il faut activer les "services mobiles" dans cette même console (paramétres globaux => services mobiles)

- décocher "Requérir un canal sécurisé SSL sur le répertoire OMA dans la console IIS

Déjà là si vous désactivez le SSL sur votre Iphone votre compte doit être fonctionnel (sauf si vous avez un serveur SBS)



Si vous voulez activez le SSL sur l'iphone ben faut encore un peu de courage....

J'ai testé cette procédure sur un Exchange2003 et sur un SBS celà a fonctionné les deux fois...


---REMARQUE---
Si votre serveur est Microsoft Windows Small Business Server 2003 (SBS), le nom du répertoire virtuel Exchange OMA cité dans l'article ci-dessous doit être exchange-oma. Il faut donc le supprimer de la console avant d'appliquer la procédure ci-dessous ou donner un autre nom que "exchange-oma".



ISSU D'UNE KB MICROSOFT
http://support.microsoft.com/kb/817379

Remarques Ces étapes affectent les connexions Outlook Mobile Access comme les connexions Exchange ActiveSync. Une fois ces étapes effectuées, les connexions Outlook Mobile Access et Exchange ActiveSync utilisent le nouveau répertoire virtuel que vous aurez créé.
Démarrez le Gestionnaire des services Internet.
Localisez le répertoire virtuel Exchange. L'emplacement par défaut est le suivant :
Web Sites\Default Web Site\Exchange
Cliquez avec le bouton droit sur le répertoire virtuel Exchange, cliquez sur Toutes les tâches, puis sur Sauvegarder la configuration dans un fichier.
Dans la zone Nom de fichier, tapez un nom. Par exemple, tapez RépExchange. Cliquez ensuite sur OK.
Cliquez avec le bouton droit sur la racine de ce site Web. En général, il s'agit de Site Web par défaut. Cliquez sur Nouveau, puis sur Répertoire virtuel (à partir du fichier).
Dans la boîte de dialogue Importer une configuration, cliquez sur Parcourir, recherchez le fichier créé à l'étape 4, cliquez sur Ouvrir, puis sur Fichier de lecture.
Sous Sélectionnez une configuration à importer, cliquez sur Exchange, puis sur OK.

Une boîte de dialogue indiquant que le « répertoire virtuel existe déjà » s'affiche.
Dans la zone Alias, tapez un nom pour le nouveau répertoire virtuel à utiliser par Exchange ActiveSync et Outlook Mobile Access. Par exemple, tapez exchange-oma. Cliquez ensuite sur OK.
Cliquez avec le bouton droit sur le nouveau répertoire virtuel. Dans cet exemple, cliquez sur exchange-oma. Cliquez sur Propriétés.
Cliquez sur l'onglet Sécurité de répertoire.
Sous Authentification et contrôle d'accès, cliquez sur Modifier.
Assurez-vous que seules les méthodes d'authentification suivantes sont activées, puis cliquez sur OK :
Authentification Windows intégrée
Authentification de base
Sous Restrictions par adresse IP et nom de domaine, cliquez sur Modifier.
Cliquez sur refusé, sur Ajouter, sur Ordinateur unique, tapez l'adresse IP du serveur que vous configurez, puis cliquez sur OK.
Sous Sécurisation des communications, cliquez sur Modifier. Assurez-vous que l'option Requérir un canal sécurisé (SSL) n'est pas sélectionnée, puis cliquez sur OK.
Cliquez sur OK, puis fermez le Gestionnaire IIS.
Cliquez sur Démarrer, puis sur Exécuter. Tapez regedit, puis cliquez sur OK.
Recherchez la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
Cliquez avec le bouton droit sur Paramètres, pointez sur Nouveau, puis cliquez sur Valeur chaîne.
Tapez ExchangeVDir, puis appuyez sur ENTRÉE. Cliquez avec le bouton droit sur ExchangeVDir, puis cliquez sur Modifier.

RemarqueExchangeVDir respecte la casse. Si vous ne tapez pas ExchangeVDir exactement comme il apparaît dans cet article, ActiveSync ne trouve pas la clé lorsqu'il recherche le dossier exchange-oma.
Dans la zone Données de la valeur, tapez le nom du nouveau répertoire virtuel que vous avez créé à l'étape 8. Par exemple, tapez exchange-oma. Cliquez ensuite sur OK.
Quittez l'Éditeur du Registre.
Redémarrez le service d'administration IIS. Pour cela, procédez comme suit :
Cliquez sur Démarrer, sur Exécuter, tapez services.msc, puis cliquez sur OK.
Dans la liste de services, cliquez avec le bouton droit sur Service d'administration IIS, puis cliquez sur Redémarrer.

Voilà c'est déjà fini lol pushmail tout par le 443 :)
Bon courage à vous...
Répondre
Mic- 22 janv. 2009 à 17:23
quelle adresse serveur faut-il inscrire dans l'iphone.
actuellement, pour accéder à OWA, je tape https://adresse_ip_fixe/exchange
Répondre
stephane654- 4 févr. 2009 à 19:53
Bonsoir.

perso cela fonctionne avec : nomduserveur.domaine uniquement. exemple mail.apple.com. Si tu ajoute :exchange cela n'a pas fonctionné pour moi...

@

Stéphane
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
J'ai le même souci que toi, j'ai 2 sites, ca fonctionne uniquement sur un de mes sites et je ne sais pas pourquoi, les ports sont ouverts, normal nous utilisons la fonction WebAccess (Webmail) déja.
En ce qui concerne les certificats, j'ai noté que l'iPhone me demandais par 2 fois la validation au niveau du site ou ca fonctionne.
Sur le site ou ca ne fonctionne pas il me le demande 1 seule fois et donc les mails ne se synchronisent pas, je vois juste boite de reception et c'est tout.
Le problèmes vient selon moi des certificats, mais lesquels ???
Voila c'est tout ce que je peux pour t'aider.
Bon courage.
Ajouter un commentaire
Réponse
+0
moins plus
Salut,
Le probleme peut venir du certificat. Selon la provenance, il faut parfois installer un certificat intermediaire sur le serveur. Vous pouvez faire un verification du certificat entre autre a l'Adresse suivante:
http://www.digicert.com/help/

Bonne chance
Ajouter un commentaire
Réponse
+0
moins plus
Moi cela marche en wifi quand je suis dans la société, mais pas en wi-fi de chez moi, ni en 3G, pourquoi, je ne comprends pas...
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 21 août 2008 à 16:24
Vérifie bien l'adresse du serveur...
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Salut,
Comment as tu fait pour configurer le pare feu de maniere a ce qu il redirige tout sur le port443???
Parce que ce que je fais ne semble pas fonctionner. Mais je pense que c est a partir du certificat que ca bloque.

Merci d avance
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 3 sept. 2008 à 09:15
Ben je veux bien te le dire, mais si on n'a pas le même système de parefeu...

J'ai fait pour que les requêtes sur le port 443 de l'interface extérieure du parefeu soient redirigées sur le port 443 du serveur Exchange (routage et redirection NAT).

J'utilise un parefeu NETASQ d'entreprise (parefeu matériel et non logiciel).

@+
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
C est ok pour ca je me suis debrouillé ca devrait fonctionner. merci!
C'est apres quand je cree le ceertificat serveur, je veux me connecter a monserveur/certsrv , et la rien ne fonctionne.
je ne sais meme pas ce que ca devrait faire normalement, donc je sais pas ou chercher
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 3 sept. 2008 à 20:01
C'est pour quoi au juste ? Une synchronisation avec un iPhone ? Ou ça n'a pas de rapport direct avec ma question initiale ?

Parce que pour ce qui est de la synchronisation avec un iPhone, il faut désactiver l'obligation de ssl sur le répertoire virtuel /Exchange de IIS sur le serveur Exchange.

@+
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

Moi aussi j'ai le même probleme (synchonisation impossible avec l'Iphone). J'ai desactive le SSL sur la partie Exchange dans IIS amis cela ne change rien. Apparament, le probleme viendrait du certificat ssl.

Si quelqu'un pouvait m'aider sur le sujet.

Merci beaucoup.

David
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 10 sept. 2008 à 11:40
Si tu as désactivé le certificat SSL, c'est pas un problème de certificat SSL...
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Appliquez le Service Pack 2 d' Exchange 2003 et tous vos problèmes de synchro avec iPhone seront résolu ;)

Ça se passe par la :
http://www.microsoft.com/...
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 16 oct. 2008 à 16:38
Suite à des mises à jour Windows Server, la synchronisation ne fonctionne de nouveau plus du tout, et pas que sur les iPhone cette fois-ci, mais également sur nos Palm et HTC sous Windows Mobile 6.

Pour info, je suis sous SP2 d'Exchange depuis sa sortie.

@+
Répondre
drooopy- 18 oct. 2008 à 12:09
Une solution hormis l'attente de la mise à jour, gratuite ou peut être pas?
Répondre
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 10 nov. 2008 à 15:56
Malheureusement toujours aucune...

Quelqu'un ?
Répondre
Jeff_81- 18 nov. 2008 à 16:49
j'ai le même souci, un serveur Exchange sous SP2, certificat SSL valide, Iphone désilmloké sous SFR avec forfait pro (pas illimithys, impossible a insérer dans une flotte de portable pro...)

impossible de toucher le serveur exchange...

???

Help
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

avez vous eu une réponse à vos questions ?
j'ai le même problème mais moi avec le mail de mon entreprise, je pense qu'il faut que je trouve l'administrateur de mon serveur exchange.

Merci,

Lili
dcanl 3026Messages postés mercredi 7 septembre 2005Date d'inscription ContributeurStatut 1 décembre 2013Dernière intervention - 4 déc. 2008 à 15:51
Les réponses aux questions (techniques) sont ci-dessus. Si tu en as d'autres, merci de la préciser explciitement.

Quoiqu'il en soit, il faut être administrateur Exchange pour régler tout problème lié à Exchange. Encore heureux d'ailleurs !

@+
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
je precise que j'ai exchange 2007 et outlook 2007
JChristophe- 9 oct. 2009 à 16:06
Salut Rico,

Désolé de ne pas avoir répondu plus rapidemment, un petit BB vient de naitre, j'étais bien loin de mon PC, je ne viens de voir ton mail que maintenant. as tu résolus ton pb depuis ?
Répondre
rico06- 13 oct. 2009 à 20:30
Pas vraiment completement
j'ai un crtificat ssl pour la synchro du push, owa fonctionne
mais RET via HTTP hors du LAN non

et maintenant en plus regulierement il faut relancer ISS car il me demande mon mot de passe sinon et quand je le met il ne le reconnais pas.

je pense que c'est un peu le bordel dans mon serveur entre le DNS, le certificat etc
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
C un bug os 4 iphone f les mise à jour
Ajouter un commentaire
Réponse
+0
moins plus
bonjour

j'ai un probleme de synchronisation de la messagerie sur un MACbook air avec exchange 2007 ,j'ai tester avec exchange 2010 ca marche
merci d'avance pour votre aide
Ajouter un commentaire
Réponse
+0
moins plus
Mon iPhone et mon iPad ne synchronisé plus avec Exchange depuis la mise a jour
OS 5.1

Rien n'a changé sur le serveur
Rien n'a changé sur mon iPhone a part le firmware

Lors de la config du compte email : vérification OK
Mais lors. La synchro : conexion au serveur impossible

Une idée

Merci
Ajouter un commentaire
Réponse
+0
moins plus
Essai de réinstaller le certificat Exchange
Ajouter un commentaire
Réponse
+0
moins plus
Réinstaller OU ? serveur ?

je n'ai pas accès au serveur c'est un serveur entreprise
Ajouter un commentaire
Ce document intitulé «  Synchronisation Exchange <=> iPhone  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.