CommentCaMarche
Recherche
Posez votre question Signaler

WAMP 2 -- droits d'accès à phpmyadmin [Résolu/Fermé]

lerogertroutman 9Messages postés lundi 2 juin 2008Date d'inscription 27 janvier 2015Dernière intervention - Dernière réponse le 5 juil. 2014 à 09:49
Bonjour,
J'ai recemment installé WAMP 2, et je ne peux pas accéder à http://localhost/phpmyadmin/
J'obtiens l'erreur 403 :
Firefox : "You don't have permission to access /phpmyadmin/ on this server"
IE : "Le site Web a refusé d’afficher cette page Web"
Apparemment je n'ai pas les droits... Comment les avoir ?
Merci par avance.
LeRogerTroutman
Lire la suite 
Réponse
+110
moins plus
Même si j'arrive en retard, pour que mysql, localhost (le serveur) etc fonctionnent,
n'allez pas à l'adresse http://localhost/ MAIS PLUTOT SUR http://127.0.0.1/ .

Maintenant, tout devrait fonctionner et vous avez touts les droits sur vos fichiers ;)

cyril- 28 févr. 2014 à 18:05
Bonsoir, j ai le même soucis tu le dépose ou le code merci
jeanpie- 5 mars 2014 à 12:49
tu le depose dans barre d'addresse
siecool- 18 mars 2014 à 18:16
mille merci
Cancer04- 28 avril 2014 à 18:04
Moi j'ai EasyPhp qui est configurer pour le navigateur Firefox et j'ai installé WampServer pour Chrome.
Mais wamp me donne le message ci-dessus lorsque je lance phpmyadmin.
kikilove1988- 5 juin 2014 à 18:40
Merci ca m'a ete d'une grande aide
Réponse
+15
moins plus
J'avais le même problème et j'ai lu se poste de joel68 http://www.siteduzero.com/forum-83-283793-wampserver-phpmyadmin.html sur le site du zero. maintenant sa marche ni quel.

LePtitTraficeur- 19 juin 2011 à 14:04
mdr
Stéphane- 22 févr. 2012 à 16:40
En ce qui me concerne j'ai super galéré pendant 48H00 avec ce message d'erreur 403 : résultat, j'ai cessé de vouloir installer la dernière version WAMP et j'ai téléchargé celle-ci :
http://www.commentcamarche.net/download/telecharger-34055064-wampserver
et je n'ai plus aucun souci avec l'accès à la page phpMyAdmin
Réponse
+14
moins plus
Après avoir essayé toutes les solutions ci-dessus, et étant donné qu'aucune, ni la réinstallation ni les petits changements dans les .conf , n'ont arrangé mon problème j'ai donc fait un peu a la barbare, a ma sauce quoi en mettant ça en alias:
Order Allow,Deny
Allow from all
Allow from 127.0.0.1
Allow from localhost

et ça a marché o.O Voilà je poste ça au cas ou d'autres auraient été dans le même problème et que les solutions précédents n'aient pas suffit!!
(Je l'ai réinstallé 5fois aussi)

hr08- 17 nov. 2012 à 05:22
Seul le
Allow from all
suffit à résoudre votre problème.... les autres entrées sont facultatives à 100%
(Dans ce cas de figure)
et avec cette solution vous vous exposez à de gros dangers de sécurité
n'importe qui tape http:/--URL--DE--VOTRE--SITE/phpmyadmin , et BOOM! faites le test et je vous laisse imaginer la suite :)

Alors dans ce cas penser quand même à modifier vos lignes comme cela:
     $cfg['Servers'][$i]['auth_type']     = 'http';
     $cfg['Servers'][$i]['user']          = '';
     $cfg['Servers'][$i]['password']      = '';


Comme le dit vlmath
penser bien à rajouter:
	Allow from localhost


*Seulement si votre hôte se nomme localhost et que vous souhaitez autoriser l accès a phpmyadmin depuis ce poste!

regarder votre fichier hosts aussi (formatage et syntax)

vous devriez avoir cette ligne
127.0.0.1	localhost

*Attention ici l'espace est une [TABULATION]


Besoin d'aide ?: joigniez moi sur mon skype: onyxrhardcore99
Politesse et écriture soignée sont requises
Je veux bien faire l'effort d accepter les lacunes de certain mais il ne faut pas pousser :)
Merci.
scorpionN1 4Messages postés dimanche 13 juin 2010Date d'inscription 6 janvier 2013Dernière intervention - 6 janv. 2013 à 21:49
Merci Malik
de passage- 5 juil. 2014 à 09:49
"vous devriez avoir cette ligne
127.0.0.1 localhost
*Attention ici l'espace est une [TABULATION] "

J'ai remplacé les espaces entre 127.0.0.1 et localhost par une tabulation.
Et c'est exactement ce qui m'empêchait d'aller sur localhost.
Maintenant ça marche. Merci beaucoup hr08!!!
Réponse
+11
moins plus
Salut,

A mon avis, c'est une erreur dans la configuration de l'alias (ou du .htaccess).

Va sur l'icone de WAMP, clique -> Apache -> Répertoire Alias -> phpMyAdmin -> Edit alias

Et contrôle bien que c'est autorisé pour "localhost" et pour "127.0.0.1" comme ici :
Alias /phpmyadmin "C:/Program Files/wamp/apps/phpmyadmin2.11.5/" 

<Directory "C:/Program Files/wamp/apps/phpmyadmin2.11.5/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order Deny,Allow
	Deny from all
	Allow from 127.0.0.1
	Allow from localhost
</Directory>


@Bientôt

babouki- 15 juin 2012 à 01:08
j'ai un autre probleme c'est que l'apache ne demare pas
artatum- 9 févr. 2013 à 15:22
Terrible les alias. Merci.:)
Taya- 1 mai 2013 à 00:19
Un grand merci pour m'avoir évité une soirée de galère !
Eleetrix- 8 avril 2014 à 21:44
Après avoir cherché pendant des heures ce problème est résolu, merci bien ;)
Réponse
+5
moins plus
J'avais exactement ce problème: accès à Localhost mais pas à Phpmyadmin par Wamp. La modification de l'emplacement ne donnait rien, et je ne voulais pas mettre Allow from All.
Avec Allow from localhost ::1 127.0.0.1 ça marche nickel ! Et je suis sous Windows 8 ^^
Merci beaucoup =)

JC- 13 janv. 2013 à 16:00
j ai une machine qui tourne encore avec Vista et cet ajout m'a solutionné le problème ! (après avoir testé toutes les solutions au dessus - sauf celles ouvrant l accès à tout le réseau bien sur !)
Un grand merci !
bivv 1Messages postés jeudi 31 janvier 2013Date d'inscription 31 janvier 2013Dernière intervention - 31 janv. 2013 à 00:06
loveyouman :D
Réponse
+4
moins plus
J'ai eu le même problème et voici ce que j'ai fait pour que ça marche:

1) Aller au repertoire: C:\Windows\System32\drivers\etc

2) Copier le fichier hosts sur bureau
3) L'ouvrir avec un éditeur et supprimer tout ce qu'il y'a à l'intérieur. Ensuite, tapper uniquement cette ligne:
127.0.0.1 localhost

4)Sauvegarder le fichier hosts et le coller dans le repertoire etc


5)Cliquer gauche sur wampserver, appache, alias directories, http://localhost/phpmyadmin, edit alias

6) dans le fichier qui s'affiche, ajouter la commande:
Allow from localhost

vous devriez avoir ceci:

<Directory "c:/wamp/apps/phpmyadmin3.5.1/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
Allow from locahost

</Directory>

7)sauvegarder le fichier phpmyadmin.conf

8)redemarrer tous les services de wamp

et ça devrait marcher!

-------
Rukia

hr08- 17 nov. 2012 à 05:47
Supprimer toutes les lignes du fichier hosts ? êtes-vous sérieux Rukia ? le fichier hosts, et s'il contient d autres entrées autres que 127.0.0.1 localhost est un fichier utilisé par certain logiciels "antimalware" (que je ne citerai pas ici) afin de sécurisé l'ordinateur de "sites nuisibles"

Donner cette solution lamentable en public est un très mauvais choix à mon goût. Prenez du recul penser que votre méthode à certainement plus ouvert de portes sur des dangers potentiels, que résolus les soucis d'accès a phpmyadmin mentionnés ici.

Bien que je vous accorde qu'un éventuel problème peut tout à fait lui être directement lié.

N'EFFACER PAS CES LIGNES! (en tout cas pas sans savoir ce que vous faites)

Veillez seulement à ce que que celle-ci soit correcte:
127.0.0.1	localhost

Cordialement.
ok- 2 janv. 2013 à 19:28
Merci ca mache :)
bon solution.
Toxmana- 30 mars 2013 à 04:11
Merci rukia !!!!!
Réponse
+3
moins plus
Bonjour!

J'ai essayé toutes les techiniques citées ci dessus... mais aucunes ne fonctionnent... aurriez--vous une solution?

Fanzie- 10 févr. 2010 à 23:48
Attention les distraits comme moi il y a 2 modifs à faire :

1. Alias /phpmyadmin "C:/wamp/apps/phpmyadmin3.1.3.1/"
et 2. <Directory "C:/wamp/apps/phpmyadmin3.1.3.1/">
Réponse
+1
moins plus
bonjour à tous,

Je viens d'installer wamp server 2.0g, et j'ai rencontré le même problème, la cause est la suivante :

allez sur l'icone de WAMP, clique -> Apache -> Répertoire Alias -> phpMyAdmin -> Edit alias

il faut bien verifier le chemin parce que à l'origine il manque le "1" à la fin (phpadmin3.1.3)

<Directory "c:/wamp/apps/phpmyadmin3.1.3.1/">

bonne journée à tous

jfk1948- 17 avril 2009 à 23:22
C'était bien \phpmyadmin3.1.3.1 qui était mal libellé dans phpmyadmin.conf, après réinstallation de Wampserver.
Merci à toi skyblazer972
jfk1948
GeekTitif- 10 nov. 2013 à 20:47
Moi jai la version 4.0.4 et quand jouvre phpmyadmin il me demande un identifiant et un mot de passe
Réponse
+1
moins plus
Réponse
+0
moins plus
c'est bisard ...

Normalement, il ne bloque que si on lui a demandé ... Regarde la ligne "Order" et contrôle si elle est dans le même sens (en premier deny, puis allow).

Pour l'installation, tu n'as pas choisis d'option en plus ? ou une "mauvaise" option ?

Réponse
+0
moins plus
Essaye ça

lerogertroutman 9Messages postés lundi 2 juin 2008Date d'inscription 27 janvier 2015Dernière intervention - 2 juin 2008 à 21:38
Rebonsoir vlmath,

Merci pour ton aide.
L'ordre est bien "deny,allow"
J'ai fait l'installation la plus simple possible.
Quant à la solution que tu me proposes, regarde bien : c'est moi qui pose la question ^^

Malheureusement, cette solution ne fonctionne pas.


Je ne comprends vraiment pas.
SAMEH- 20 févr. 2012 à 12:25
L'erreur que vous obtenez est typique d'un paramètre manquant dans le fichier de configuration d'Apache. Plus précisément ...

1) Rechercher "httpd.conf" et le modifier avec le bloc-notes.

2) Cherchez un article qui définit les répertoires, quelque chose comme ça ...

<Directory "c:/phpmyadmin">
AllowOverride All
Commandez allow, deny
Allow from all
</ Directory>

Bien sûr, le chemin d'accès réel pour PhpMyAdmin varie en fonction de votre installation. Ou il peut même ne pas être encore là, dans ce cas, vous devez l'ajouter.
hr08- 17 nov. 2012 à 06:07
Arff vous n'avez qu' 2 ans de retard... en plus:

Commandez allow, deny

LOL -- Vive le traducteur!
Réponse
+0
moins plus
Alors là .... je crois que je ne sais pas ..... désolé

Essaye quand même de lire une fois tous les fichiers de configuration, et si tu vois un truc louche, dis le nous ...

Pour le lien, désolé, je n'avais pas regardé qui avait posé la question .... :D

lerogertroutman 9Messages postés lundi 2 juin 2008Date d'inscription 27 janvier 2015Dernière intervention - 3 juin 2008 à 13:46
Oui, je vais tenter de me plonger dans ces fichiers de configuration. Le pire que je risque, c'est d'y comprendre quelque chose ;)

Aucun problème pour le lien, c'était simplement amusant : j'a commencé à lire le post en me disant que c'était EXACTEMENT mon problème (du style "tiens, en plus il a exactement le même nom que moi" ^^' )

Merci encore pour ton aide, je te tiens au courant.

LeRogerTroutman
goya- 13 juin 2008 à 11:55
J'ai eu le meme souci et je me suis rendu compte que j'avais oublié de cliquer sur "put online". après avoir lancer les services.
lerogertroutman- 14 juin 2008 à 10:28
Salut Goya,

Merci pour ta proposition, mais ça ne semble pas venir de là non plus.

Je pense que c'est Vista qui pose problème, avec des droits d'admin distribués n'importe comment.
Mais toujours pas de solution.
Réponse
+0
moins plus
Bonjour,

J'ai exactement le même problème, j'ai essayé également la solution donnée ci-dessus, mais malheureusement celà ne fonctionne toujours pas...

J'ai windows XP, donc le soucis ne vient pas de Vista.

Si l'un de vous a une solution, n'hésitez pas, car c'est vraiment embêtant ce problème...

Merci.

Réponse
+0
moins plus
Génial elite_section !! Ca fonctionne !

Un IMMENSE merci à toi d'avoir pris le temps de me donner ce lien !


Au final, il faut simplement installer wampserver ailleurs que dans le dossier C:\wamp
J'ai accès à toutes les pages, tout fonctionne niquel, bref... c'est reparti pour un peu de PHP :)

Bonne journée et merci encore !

Dorlomion- 15 nov. 2008 à 11:20
génial, il n'y a plus qu'a répandre la solution, j'ai du me balader pas mal sur le net pour la trouver. Merci beaucoup
B elhassen Tunisia- 11 juin 2010 à 12:33
Bon pour la version de phpmyadmin 3.3.3 , on ne copie plus phpmyadmin dans /var/www/ , mainant il est sous /etc/phpmyadmin.

Pour avoir l'acceés à phpmyadmin via le web :Editer le fichier apache.conf sous /etc/phpmyadmin

vim /etc/phpmyadmin/apache.conf et ajouter ces lignes .

<Directory /usr/share/phpmyadmin>
AllowOverride None
# Empêche que des .htacces modifient la règle suivante
Order deny,allow
# Dans l'ordre : on refuse l'accès à... et on permet à...
Deny from all
# Donc, on refuse à tout le monde
Allow from votre adresse ip
# Sauf à cette adresse interne
</Directory>
UNTAC 19Messages postés mardi 10 avril 2007Date d'inscription 26 décembre 2011Dernière intervention - 26 déc. 2011 à 16:01
merci mon ami vraiment une top solution 1000 merci
Réponse
+0
moins plus
Moi sa ouvre firefox et sa met :

Erreur

MySQL a répondu:?
#1130 - Host 'localhost' is not allowed to connect to this MySQL server
phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de "host", "username" et "password" dans votre configuration et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.

Help !!

Merci d'avance

Réponse
+0
moins plus
Bonjour,

Moi aussi j'avais le même Problème et je les résolu, voici la solution :

cliquez sur l'icon wampserver en bas à droite puis apache puis alias directories puis http://localhost/phpmyadmin et ouvrez le fichier texte Edit alias puis changer le 127.0.0.1 par all.

comme ça:

<Directory "c:/wamp/apps/phpmyadmin3.4.10.1/">

Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
Deny from all
Allow from all au lieu de allow from 127.0.0.1

</Directory>

La Solution il fonctionner avec tous le monde si dieu le veux.

jack- 19 janv. 2013 à 01:52
Bonjour,

Moi ça a fonctionné (sous Vista) après avoir ajouté :
Allow from localhost ::1 127.0.0.1

Merci.
spifiane1992- 6 févr. 2013 à 10:52
voila le Soultion : http://www.youtube.com/watch?v=7fo4h-n5TN0
spifiane1992- 6 févr. 2013 à 11:02
click sur le directory C:\wamp\alias apres modifier le fichier phpmyadmin.conf
<Directory "c:/wamp/apps/phpmyadmin3.5.1/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
allow from all
Allow from all
</Directory>
et le fichier sqlbuddy.conf par :
<Directory "c:/wamp/apps/sqlbuddy1.3.3/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
allow from all
Allow from all
</Directory>
et enfin le fichier webgrind par:
<Directory "c:/wamp/apps/webgrind1.0/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
allow from all
Allow from all
</Directory>

conclusion : en modifier et deny ->allow et 127.0.0.1 ->all
DEBUTANT- 25 mars 2013 à 14:46
Pensez à redémarrer les services; à part ça vos modifications ne sont pas prises en compte!
Lili- 4 juin 2014 à 22:59
Oui , cette solutions marche très bien ! merci beaucoup.
Réponse
+0
moins plus
bonjour tlm,

voici la meilleur solution que j'ai trouver et aussi la plus propre :

Par défaut, le serveur web personnel Wampserver affiche une erreur 403 à l'appel de http://localhost, mais fonctionne normalement sur http://127.0.0.1.

Solution (source)

Dans le fichier \bin\apache\apache2.2.22\conf\httpd.conf, remplacer:

Listen 80
par Listen 127.0.0.1:80
PS: En cas de problème de connexion (Access denied) à phpMyAdmin / changement ou ajout de mot de passe utilisateur, se référer à cet article et à celui-là.

voici le lien de la page ou je l'ai trouvée :
http://www.ygi.ch/blog-notes/2012/08/15/wampserver-403-forbidden-sur-localhost-mais-pas-sur-127001/

a bientot

Ce document intitulé «  WAMP 2 -- droits d'accès à phpmyadmin  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.