Signaler

Serveur Linux Debian haute-disponibilité. [Résolu/Fermé]

Posez votre question linuxfr - Dernière réponse le 29 févr. 2012 à 11:25 par Azhar
Bonjour,

Voilà je dois tenter de mettre en place une solution de Haute-Disponibilité, pour le moment, via des machines virtuels étant sous Debian etch et grâce au logiciel VMware. J'ai trouvé bon nombre de tutoriaux et j'ai décidé de me baser sur celui-çi : http://www.morot.info/spip.php?article34 .
Donc j'ai crée deux machines virtuels Debian grâce à VMware et j'ai fais les updates.
J'ai donc suivi le tutorial, tout se passe bien jusqu'a la commande "modprobe drbd".

En effet, je lance cette commande dans la console, mais rien ne se passe, pourtant j'ai fais les manipulations pour installer le module drbd, çela semble fonctionner d'après les résultats mais il n'apparait pas dans la liste des modules (commande modprobe -l). Je cherche depuis quelques heures, en vain... Je tiens à dire que j'étais totalement inconnu à ce type de configuration (HA, clustering etc.) il y à quelques jours, je viens seulement de décourvrir, excusez donc si mes phrases paraissent peu claires.


Merci d'avance.
Utile
+2
plus moins
Bon, nouveau problème, lorsque je lançe la commande "/etc/init.d/drbd start", j'obtiens ce message d'erreur :

Starting DRBD resources: [ d0 ioctl(,SET_DISK_CONFIG,) failed: Invalid argument
Lower device is already mounted.

cmd /sbin/drbdsetup /dev/drbd0 disk /dev/sda5 internal -1 --on-io-error=detach failed!

J'ai cru lire que çela aurait un rapport avec la taille du disque.
Etrange...
Cette réponse vous a-t-elle aidé ?  
linuxfr- 23 mai 2008 à 17:37
Je viens de trouver, j'avais simplement mal partitionner lors de l'installation de Debian, j'ai crée un autre partition ext3, je l'ai utilisé et ça a fonctionner :).
Utile
+1
plus moins
Salut,

Lorsque tu fais un lsmod | grep drbd, il n'y a rien qui apparait donc ?

En ce moment je suis sur le même sujet que toi et pareil : impossible de charger drbd. Finalement, j'ai fait :

mkdir ~/drbd
wget http://oss.linbit.com/drbd/8.0/drbd-8.0.5.tar.gz
tar xzvf drbd-8.0.5.tar.gz
cd drbd-8.0.5
make
sudo make install

et là, le module drbd était chargé. J'espère que ça t'aidera.
linuxfr- 22 mai 2008 à 17:20
Merci pour la réponse rapide, alors oui maintenant j'ai bien le module qui s'affiche avec la commande lsmod, mais étrangement lorsque je lance modprobe drbd(comme indiqué dans le tuto.), je n'ai rien qui s'affiche, est-ce normal ? Pourtant, le drbd est bien chargé...
krn- 22 mai 2008 à 17:24
oui c'est normal que rien de s'affiche.
linuxfr- 22 mai 2008 à 17:27
Bon ok, merci beaucoup en tout cas !
Utile
+0
plus moins
bonjour chers collègue je suis mois aussi fortement intéressé par l'implémentation de la haute disponibilité je ne sais pas s'il y'aurai un cours que vous pourriez me donnez car l'accès à toutes les pages dont vous avez fait référence dans votre discussion ne se télécharge pas(ne s'ouvre plus) dans l'attente d'une prompte réponse je vous souhaite pleins de bonnes choses.
Yann
Utile
+0
plus moins
Bonjour a tous,

Est ce que tu peux nous passer une copie de la page que tu as sauvegarder
car le site http://www.morot.info/spip.php?article34 ne fonctionne pas.
Merci

Azhar

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !