Posez votre question Signaler

Ubuntu et casque audio [Résolu]

le hollandais volant 4978Messages postés samedi 8 mars 2008Date d'inscription 25 mai 2014Dernière intervention - Dernière réponse le 25 déc. 2010 à 19:08
bounjour a tous et merci pour votre travail magnifique,
voilà, j'ai instalé Ubuntu 7.04 hier, ca marche génial, mais y'a quand même un problème (en ce qui me concerne, de taille) :
la carte son emet les bon son, pas de probleme, mais dés que je met le casque (que j'ai d'habitude toujours) il n'y a plus aucun son...
c'est une carte REALTEK HD AUDIO, pour moi c'est plutot embetant,
mon ordi est un portable ASUS A6 (HDD 60Gib, Processeur intel M740 1,733GHz, 1,5Gb, Carte graphique Nvidia GeForce Go 7300 256Mb)
Je m'y connait bien en informatique et maitrise windows, mais suis un tout nouveau pour Linux...
Si quelqu'un a une idée, merci bien...
Lire la suite 
Réponse
+0
moins plus
C'est peut-être la 8.04 (héron hardy)
Même version, même pc,même problème

On se tient au courant
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+0
moins plus
J'ai enfin réussi à le faire marcher la semaine dernière :
Ajoutez la ligne
Code:

options snd-hda-intel model=z71v position_fix=1

A LA FIN du fichier /etc/modprobe.d/alsa-base et redémarrez. Vérifiez aussi que le volume n'est pas muté dans les controles du volume...

Il faut aussi trafiquer un peu
>double clic sur le petit haut parleur et vérifier que le volume casque n'est pas à zéro.
>reboot

Ca fait 3 jours que je bataille, et enfin chez moi, ça marche
le hollandais volant- 13 mai 2008 à 17:44
j'ai trouvé le fichier, mais je ne peut pas l'enregistrer, (il faut que je me logue en ROOT), et ca, je n'y arrive pas (j'ai éssayé ROOT, ADMIN, ... avec tous les mots de passes imaginables...


Au risque de me faire passer pour un noob, je vous demande de l'aide...
Répondre
domirock- 14 mai 2008 à 08:46
Pour se logger en root

Je ne sais pas si ma méthode est la plus rapide, mais au moins je me comprends.

J'ouvre un terminal
(APPLICATIONS >ACCESSOIRES>TERMINAL)

je tape ma commande PRECEDEE DE sudo
Ex sudo gedit /etc/modprobe.d/alsa-base

ubuntu demande alors le mot de passe. C'est celui qui te sers normalement au démarrage. Quand tu le saisis, rien ne s'affiche, mais il est pris en compte

la commande se lance avec les privilèges de super utilisateur.

Et là, tu pourras sauver les modif.

Bon courage
Répondre
sebuntu- 25 déc. 2010 à 19:08
merci beaucoup, ta solution ma sauvé ;)
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+0
moins plus
bonjour,

voilà, j'ai instalé Ubuntu 7.04 hier, ca marche génial,
(il faut que je me logue en ROOT), et ca, je n'y arrive pas (j'ai éssayé ROOT, ADMIN, ... avec tous les mots de passes imaginables...

en installant ubuntu aurais-tu manquer l'étape de la création du super-utilisateur root ???
Ajouter un commentaire
Réponse
+0
moins plus
sous ubuntu on ne se connecte jamais en SuperUser, on utilises sudo
Ajouter un commentaire
Réponse
+0
moins plus
j'ai pas Ubuntu ! .......................... tout s'explique !

:-))
Ajouter un commentaire
Réponse
+0
moins plus
rebonjour a tous, désolé, de ne revenir que maintenant, mais j'avais pas mon pc au lycée, je viens d'éssayer votre astuce, avec sudo, et... J'entends tous les sons avec le casque!!!

Je suis content! Merci, a tous et vive le logiciel libre!!

je vais mettre "sujet résolu" en haut.

Encore merci et continuez bien pour aidez ceux qui en ont besoins...
domirock- 16 mai 2008 à 20:09
Tu dis:

"Encore merci et continuez bien pour aidez ceux qui en ont besoins..."

Quand ça marche chez les autres, je suis presque aussi content que quand ça marche chez moi.

Bonne continuation
Répondre
cool17- 17 janv. 2010 à 06:14
Merci beaucoup pour la résolution de ce probleme qui est apparement recurent !!

je débute tout juste sur linux, je suis aussi sur un asus et j ai bien tourné en rond 2 jours pour résoudre ce probléme ... donc merci encore pour les explications et la pédagogie .

bonne continuation
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Salut, et bienvenu sous GNU/Linux !

Ce topic en a surement aidé plus d'un ! D'où l'intérêt énorme de garder tout les méssages accéssible :-)

Bonne continuation à toi aussi !
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour a tous.

Je débute sur Mandriva 2010 et je rencontre le mm probleme.

j'ai essayer la manip citer plus haut mais malheureusement je ne parviens pas a trouver le fichier "alsa-base"

je suis sur un pc portable Asus G50.

J'espere que quelqu un pourras m aider a récupéré le son sur ma sortie casque.

Merci d'avance
Ajouter un commentaire
Réponse
+0
moins plus
Salut !

Depuis les dernières versions d'Ubuntu, le fichier se nomme "alsa-base.conf".

Je suppose que Mandriva a adopté le même changement ?


Si tu veux le retrouver, essaies en lançant une commande "locate alsa-base" dans un terminal. Il renverra tous les fichiers qui portent ce nom.
Mat- 9 mars 2010 à 19:15
Salut !

Tout d'abor merci pour cette réponse rapide :)

Malheuresement dans le Dossier " modprobe.d " , je ne trouve aucun fichier du nom de " alsa-base.conf"

les fichiers présents sont les suivants : " blacklist-compat " , " blacklist-mdv" , " ipw-no-associate.conf" ,

" snd-oss " , " snd-usb-audio" , " visor" .

Et quand je lance uen recherche via le Terminal , j'obtiens le message suivant : " bash: locate alsa-base : commande introuvable "

est ce que par hasard " alsa-base.conf " = " ipw-no-associate.conf " ????
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
étrange... La commande Locate n'est pas installée ? Elle est pourtant bien utile...

Essayes en créant le fichier alsa-base.conf et en mettant :

options snd-hda-intel model=g71v probe_mask=1

ou :
options snd-hda-intel model=asus-mode3

Ensuite, redémarres l'ordinateur.
En tout cas, c'est ce qu'ils conseillent ici pour ton model d'ordinateur.


Le fichier, pour le créer, tu dois être logué en Root.
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour, apres plusieurs soirées de recherche , je n'arrive tjs pas a modifier le dossier " modprobe.d "

L'acces m en est refusé mm en loguant en mode root.

Par conséquent, je pense désinstaller Mandriva 2010 sans pour autant abandonner l idée de passer sous Linux.

En effet , je pense essayer Fedora 12 ou encore Ubuntu.

Si vous avez une autre distribution a me conseiller , je suis preneur.

Dans ts les cas , merci infiniment pour avoir essayer de m aider, et bonne continuation a tous !!

Cordialement
Ajouter un commentaire
Réponse
+0
moins plus
Même en Root ? C'est pas normal. Root a tous les droits.

Pour te mettre en Root, dans un terminal, essaies :
su root


Ensuite, essaies ce qui suit (cela devrait logiquement dire que le fichier n'existe pas) :
cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.save


Puis, pour mettre un fichier avec le bon contenu :
echo "options snd-hda-intel model=g71v probe_mask=1" > /etc/modprobe.d/alsa-base.conf



Personnellement, j'utilise Ubuntu, je suis donc habitué a tout ce qui spécifique à lui et au système de Débian ("apt" plutôt que "yum", etc…).
J'ai pas pris le temps de vraiment tester de distributions basés sur autre chose que Débian…

Je pense qu'il doit avoir une solution à ton problème, mais je ne suis encore assez fort pour savoir le résoudre :/
Tu as tenter de voir sur les forums son/audio de Mandriva : http://forum.mandriva.com/viewforum.php?f=108 ?
Ajouter un commentaire
Réponse
+0
moins plus
je viens d essayer ta solution malheureusement , je n ai pas plus de son sur ma prise casque pour autant, malgré le fait que le fichier " alsa-base.conf " a bien ete créer dans le fichier " modprobe.d "

Puisque apparement tu es un specialiste d Ubuntu, je viendrais peut etre te demander conseil sur celui ci su je viens a ne pas etre satisfait de Fedora 12.

je te remercie bcp de t'etre penché sur mon probleme, tu es d une aide precieuse pour ts les debutants comme moi!!

Je te souhaite bonne continuation

Cordialement

Mat
Ajouter un commentaire
Réponse
+0
moins plus
merci et bonne continuation à toi aussi !
Ajouter un commentaire
Réponse
+0
moins plus
Histoire de compléter un peu ce topic, au cas où le mixage stéréo ne marche pas sur votre ordinateur sous linux : http://stream-recorder.com/...

(ça marche sous Ubuntu Lucid Lynx (10.04))
Ajouter un commentaire
Ce document intitulé «  ubuntu et casque audio  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.