[excel] fonction, nombre négatif, positif [Résolu/Fermé]

Demky 17 Messages postés dimanche 20 août 2006Date d'inscription 26 mars 2012 Dernière intervention - 27 févr. 2008 à 12:17 - Dernière réponse : deepak66 24 Messages postés mercredi 10 juin 2015Date d'inscription 4 novembre 2016 Dernière intervention
- 16 oct. 2015 à 21:51
Bonjour,

J'essayes avec toutes les peines du monde de me faire un tableau sous excel, pour des calculs que je fait souvent, j'explique le "probleme".

J'ai une valeurs de départ ( A ) apres differents calculs, j'obtient un chiffre ( B ) si ce chiffre ( B ) est positif j'utilise la ligne :

=ARRONDI.SUP(nom_de_la_cellule;0)

( d'ailleur si quelqu'un peut m'expliquer ce a quoi correspond le 0, je ne sais pas a quoi il sert mais je sais que sa marche comme sa. )

bref, cette ligne me met un resultat a l'arrondit supérieur, si j'obtient 2.666 excel m'affiche 3 (etc...)

Mais voila je souhaiterai que si ( B ) est inférieur à 0 alors excel me fasse un autre calcul mais je ne sais vraiment pas comment faire avec excel, en d'autre langage cela ferait quelque chose du genre :

If B<0
{
A/6000
}

( doit diviser A par 6000 si b<0, j'utiliserai d'ailleur encore la ligne "=ARRONDI.SUP" pour afficher le resultat arrondit a l'unité supérieur)

En esperant avoir été clair ~~

edit : deuxieme question tres courtes,

Comment faire pour que si D<0 afficher 0 ? (pour une autre cellule :)

Merci.
Afficher la suite 
17Messages postés dimanche 20 août 2006Date d'inscription 26 mars 2012 Dernière intervention

10 réponses

+10
Utile
je veus faire la somme de mes colonnes positive et négative ensemble quel est la formule
pour tableau de caiculexel merci
Cette réponse vous a-t-elle aidé ?  
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 27 févr. 2008 à 12:39
+5
Utile
Bonjour
Tout simplement en cellule B

=SI(Calcul A>0; ARRONDI.SUP(calcul 1);si(Calcul A>0;ARRONDI.SUP(calcul 2);0))

Cette formule vous donnera le résultat du calcul 1 si celui de calcul A est négatif, le calcul 2 s'il est positif, est 0 si le résulat de calcul A est nul.

Attention aux point-virgules et parenthèses qui s'ajoutent bien entendu, aux signes déja inclus dans vos formules de calcul.

BCRDLMNT
Demky 17 Messages postés dimanche 20 août 2006Date d'inscription 26 mars 2012 Dernière intervention - 27 févr. 2008 à 13:40
+2
Utile
merci beaucoup à vous deux ;)
+2
Utile
3
Bonjour,

Depuis un programme X comptable j'exporte une liste de chiffre, devant effectuer un rapprochement comptable entre le débit et le crédit de ce compte, je souhaite, pour me faciliter la vie mettre toute une sélection en négative.

Je ne retrouve plus la fonction adhéquate.

D'avance merci pour la réponse
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 9 mai 2008 à 16:49
Bonjour
Pas facile de vous détecter , vous vous accrochez sur un vieux post!!La prochaine fois, essauez d'ouvrir un nouveau sujet, ça sera plus efficace.
ceci dit, ce que je vous propose:
mettez -1 dans une cellule hors champ
copier là
sélectionner le champ à modifier
Collage spécial: option:multiplication
Attention cette opération passe aussi en positif ce qui est en négatif
Pour faire le tri dans ce cas, il y a d'autres moyens en passant par une colonne sde transfert.
CDLMNT
fefe > Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 9 mai 2008 à 16:56
Bonjour,

Oui désolée j'y suis allée un peu trop vite.....
Merci beaucoup j'ai testé et c'est exactement ça.
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention > fefe - 9 mai 2008 à 17:16
Pas de problème, l'essentiel étant que votre problème à vous soit résolu.
Bonne route
dudu134 2844 Messages postés samedi 18 novembre 2006Date d'inscription 24 janvier 2009 Dernière intervention - 27 févr. 2008 à 12:24
+1
Utile
Bonjour,

=ARRONDI.SUP(nom_de_la_cellule;2) met çà va arrondir au deuxième chiffre après la virgule.

ensuite essaye ceci:
si(b1<0;a1/600;ARRONDI.SUP(nom_de_la_cellule;2))
dudu134 2844 Messages postés samedi 18 novembre 2006Date d'inscription 24 janvier 2009 Dernière intervention - 27 févr. 2008 à 13:42
0
Utile
1
de rien, on est là pour çà
deepak66 24 Messages postés mercredi 10 juin 2015Date d'inscription 4 novembre 2016 Dernière intervention - 16 oct. 2015 à 21:51
bonjour,
peut on incorporer cette fonction dans un calcul ?

=SI(K460="";"";SI(K460-I460<=1;K460*1,65;K460))

de façon à ce que le résultat finisse soit par 0,05 ou 0,10 ou 0,15 ?
Merci beaucoup