Posez votre question Signaler

Nom du dossier avec espace.batch = erreur [Résolu]

testeur98 378Messages postés vendredi 15 février 2008Date d'inscription 27 mars 2015 Dernière intervention - Dernière réponse le 7 juin 2013 à 21:26
Bonjour,
Je fait appel à un fichier batch pour lancer une application qui se trouve dans un dossier don le nom comporte un espace.
l'éxécutable ne se lance pas a cause de cet espace. j'ai pas trouver des paramètres possible.
Ce que j'ai trouver: example pour lancer nero.exe qui est dans le dossier" logiciels ajour" il faut mettre dans mon fichier bat:
start c:\logici~1\nero.exe cet commande fonctionne
ici ça fonctionne car le nom du dossier a plus de 6 lettre avant l'espace, mais comment faire quand il y a moin de 6 lettre avant l'espace.
du genre "logi pasajour"
Pouvez vous m'aider S.V.P. pour xp pro sp2
Mon but, est de lancer mon batch pour qu'il copier un fichier dans ce dossier:
C:\Documents and Settings\intel windows\Menu Démarrer\Programmes\Démarrage1 message(s) posté(s) depuis le vendredi 15 février 2008
Lire la suite 
Réponse
+6
moins plus
Ajouter un commentaire
Réponse
+4
moins plus
Bonjour, si ça peut aider:

dans le bat il faut mettre :

start "nom1" "C:\chemin avec des espace\exe avec des espace"

nom1 = vous mettez ce que vous voulez c est le nom de la fenetre cmd
Ajouter un commentaire
Réponse
+1
moins plus
si j'ai bien compris il faut écrire dans mon fichier bat ceçi, example:
start "c:\logi pasajour\nero.exe"

il faut mettre les guillemets?
j'ai pas encore tester , je vais le faire
Ajouter un commentaire
Réponse
+1
moins plus
C'est ça !
Ajouter un commentaire
Réponse
+1
moins plus
C'est quoi le message d'erreur ?
Ajouter un commentaire
Réponse
+1
moins plus
voila je viens de faire un essaie. dans C j'ai créer un dossier nommé "test 2" qui contient le fichier nommer "1.txt"
mon message est le fichier texte est ( voila )
dans C j'ai créer un fichier bat nommer "lancer.bat"
j'ai écrit dans ce bat:
start "c:\test 2\1.txt"

maintenant je clique sur lancer.bat
le fichier texte ne se lance pas. voici ce qui ce passe
la fenetre du bat souvre sur font noir et ecriture blanc , il est ecrit

Microsoft windows xp [version 5.1.2600]
<C> Copyrigth 1985-2001 Microsoft Corp.
c:\>

l'écran reste comme ça

je vais sortir 45 mn . j'ai xp pro sp2 . teste sur ton pc avec un dossier comme moi "test 2"
Ajouter un commentaire
Réponse
+1
moins plus
je n'ai pas sorti pour 45 mn .
je sais que dans xp pro sp2 microsoft a enlever encore quelque commandes, mais je ne sait pas les quels.
Ajouter un commentaire
Réponse
+0
moins plus
l'éxécutable ne se lance pas a cause de cet espace. j'ai pas trouver des paramètres possible.

Solution simple:
"c:\mon répertoire\mon executable avec des espaces.bat"
Ajouter un commentaire
Réponse
+0
moins plus
ca ne fontionne toujours pas,
Ajouter un commentaire
Réponse
+0
moins plus
c'est resolut
pilop- 13 juil. 2009 à 10:19
ah ben; du bon usage des forums: ne pas oublier qu'il s'agit davantage d'une FAQ qu'un chat. Au sens que chaque réponse peut-être retrouvée par un utilisateur ayant un problème similaire et éviter ainsi que la même question soit posée mille fois. Un patrimoine de savoir en quelque sorte.
Répondre
ZalaZance- 27 déc. 2012 à 10:24
crevard!!
Tu pourrais penser aux autres quand même!
Répondre
Ajouter un commentaire
Ce document intitulé «  nom du dossier avec espace.batch = erreur  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.