Posez votre question Signaler

Autoriser javascript sous "internet explorer& [Résolu]

gbinforme 11119Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 1 juillet 2015 Dernière intervention - Dernière réponse le 12 sept. 2013 à 11:10
Bonjour,
N'utilisant pas personnellement IE, j'ai une petite application locale en HTML, CSS et javascript qui fonctionne sans souci sous Firefox et Opéra mais avec IE, le code javascript est systématiquement bloqué et il faut, à chaque nouvelle fenêtre valider la barre d'avertissement.
Dans le menu 'Outils' / 'Options Internet' onglet 'Sécurité' dans la zone 'Internet' et 'intranet' 'Personnaliser le niveau' les options 'Activer' de la section 'Active scripting' sont bien cochées mais la barre de blocage doit être validée chaque fois.
Je suppose qu'il y a une possibilité mais je ne trouve pas.
Merci d'avance à tous ceux qui ont la solution.
Lire la suite 
Réponse
+10
moins plus
insere ca dans ton code tel quel..ca semble etre du commentaire html mais ca n'en est pas...

<!-- saved from url=(0013)about:internet -->
Ajouter un commentaire
Réponse
+1
moins plus
bonjour

Merci de te pencher sur ce problème et j'ai essayé de mettre ce code dans le head de la page, mais cela ne change rien : Firefox et opera fonctionne toujours mais IE n'en veux pas !

Tu n'auras pas de problème lorsque tu le publieras en ligne..se problème apparaît seulement en local.

C'est une application familiale, et elle va rester en local mais comme je n'ai pas réussi à convaincre tout le monde de passer à mieux...

Ton code m'a tout de même permis de régler le problème car j'ai trouvé le paramètre à modifier :

1. Sur votre ordinateur local, exécutez Internet Explorer et choisissez Outils > Options Internet.
2. Cliquez sur l'onglet Avancé, puis faites défiler la liste jusqu'à la section Sécurité.
3. Activez l'option " Autoriser l'exécution de fichiers avec du contenu actif sur mon ordinateur "
(3ème option)
.
4. Cliquez sur le bouton OK : merci à adobe aussi !

Ce problème vient d'un bug du SP2 que MS à essayé de corriger
avec ce simple commentaire particulier, que Microsoft appelle Mark of the Web.

Merci encore car je me faisais du souci pour les utilisateurs, mais avec une option cochée c'est bon !
Ajouter un commentaire
Réponse
+1
moins plus
Le javascript ne fonctionne plus dans Internet Explorer


C’est le genre de problème qui peu arriver à tous. Les scripts javascript ne fonctionnent plus sur Internet Explorer.

Cela peu avoir plusieurs causes. La première peut être du à un virus ou spy présent sur le PC. Dans ce cas pour en être certain, le mieux est de faire un scan en ligne.

Mais le plus souvent c’est les dll jscript et vbscript qui en sont la cause.

Pour réparer cela, il vous suffit de faire
Démarrer => exécuter => et de taper " regsvr32 jscript.dll " en validant par entrée.
Démarrer => exécuter => et de taper " regsvr32 vbscript.dll " en validant par entrée.
Ouvrez Internet Explorer et vous aurez de nouveau accès au contenu javascript, comme les publicités en flash qui en dépendent, du contenu interactif…

Tu peux vérifier qu'il est activé ici:
Outils -> Options Internet -> Sécurité -> Personnaliser le niveau -> Section script
sadeg 53Messages postés vendredi 6 juin 2008Date d'inscription 22 mars 2013 Dernière intervention - 26 févr. 2011 à 16:02
OK mais vista ne reconnait pas dans démarrer-exécuter, "regsvr32jscript.dll" quand je valide par OK.
Je ne sais plus quoi faire.Merci pour l'aide
Sadeg
Répondre
elmanu59- 10 sept. 2013 à 11:46
Merci a toi, cela a bien fonctionner pour moi
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
en local il faut inserer du code dans le <head> .. </head>....j'ai cherche depuis 10mn je trouve plus le code mais j'avais deja eu le probleme..desole..sinon tu peux chercher dans les options de securités de IE..devrait il y avaoir quelquechose.

Tu n'auras pas de probleme lorsque tu le publieras en ligne..se probleme apparait seulement en local.
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour gbinforme, je viens de faire l'option Internet mais ça ne résoud pas le problème, toujours la même phrase,
Ajouter un commentaire
Réponse
+0
moins plus
bonjour

Désolé pour toi mais je n'ai pas mieux et depuis 4 mois que j'ai déployé mon application pas de souci.
Ajouter un commentaire
Réponse
+0
moins plus
cest bizzare jarrive pas atrouve le java scripting pouver vous me dire eu ilse trouve
Ajouter un commentaire
Réponse
+0
moins plus
sa marche bien avec moi avec se code <!-- saved from url=(0013)about:internet --> entre balise <head>
sadeg 53Messages postés vendredi 6 juin 2008Date d'inscription 22 mars 2013 Dernière intervention - 7 mai 2011 à 20:25
dites-moi ou et comment vous entrez ce code, car je ne vois pas le rapport avec java script
Si vous pouviez commencer par expliquer les étapes de l'opération depuis le début, ce serait plus compréhensible pour tous.
merci Sadeg
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour, j'ai aussi le même problème que vous. Si bien que j'ai abandonné l'idée d'apprendre ce langage. Puis, quelques années plus tard, je me suis dit tiens si je créais moi-même un lecteur de partie d'échecs (fichier *.pgn).

Je suis donc retombé sur le même problème. Hors cette fois-ci, je suis vraiment motivé à l'apprendre ce foutu langage.

J'ai donc chercher et j'ai trouvé.

Apparement, le livre bon marché que j'ai acheté contient des erreurs de syntaxe.
Le javascript est dérivé du langage C. => Il s'agit d'une première piste...

Donc, la syntaxe est proche... puisque dérivée !

J'ai eu alors l'idée de trouvée mon vieux bouquin de "Micro Application"
=> Le poche => Pratique>Complet>Actuel> HTML

C'est effectivement, un livre de poche complet dans lequel il y a une introduction au javascript.

Et là, surprise, la syntaxe ressemble plus à celle du langage C.

Exemple de Micro application (personnalisé => copier/collé) :

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<!-- Date de création: 28/03/2012 -->

<head>
<title>Ma première page en JavaScript...</title>
<script language="javascript">

function bonjour()
{
alert('Coucou');
}

</script>
</head>

<body ONLOAD="bonjour()" bgcolor="#708090">



<h1 align="center"><u>Ma première page en JavaScript...</u></h1>

<br><br>

Cette page, ne fait que dire bonjour.
<br>Pour des raisons inconnues, cette page ne fonctionne pas :(

<!-- bleu color="#004080" -->
<!-- rouge color="#800040" -->


</body>
</html>
johnvsk2 11Messages postés mercredi 20 août 2008Date d'inscription 28 mars 2012 Dernière intervention - 28 mars 2012 à 14:02
Donc, finalement, le code fonctionne !
Ce n'était pas les options dans Internet Explorer qu'il fallait spéciallement regarder....

Dans le bouquin bon marché, <script language="JavaScript"> est écrit avec des majuscule
et
alert("Bonjour") => dans le bouquin bon marché n'est pas terminé par un point-virgule, alors que dans celui de micro application oui !

et enfin, onload est écrit comme ça dans le bouquin bon marché : onLoad => dans Micro Application, il est écrit tout en majuscule => ONLOAD

Moralité, vérifié la syntaxe en premier lieu ! Et dès que vous tombé sur un site Web fiable, ne le perdez pas de vue ;)

Ensemble, on est plus fort !

J'espère rendre service à quelques uns :)
Répondre
johnvsk2 11Messages postés mercredi 20 août 2008Date d'inscription 28 mars 2012 Dernière intervention - 28 mars 2012 à 14:14
Autre chose => alert('Coucou'); => était écrit dans le bouquin de M.... avec des guillemets et non pas dans celui de Micro Application !

Vous voyez ici, que j'ai dû les remplacer par des apostrophes...

Bon amusement !
Répondre
Ajouter un commentaire
Ce document intitulé «  autoriser javascript sous "internet explorer&  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.