Posez votre question Signaler

Données non valides: solution

yann0207 - Dernière réponse le 19 mars 2011 à 14:42
Salut tout le monde
J'ouvre un nouveau sujet concernant un problème que je viens de résoudre après 4 jours d'intenses recherches. J'ai ainsi constaté que les personnes qui avaient le même problème que le mien étaient assez nombreuses et ne bénéficiaient d'aucune réponses pour le résoudre. Voilà qui est fait.

Premièrement, posons bien le problème :
Vous installez une nouvelle carte pci sous windows 2000/2000 pro ou xp. Votre pc détecte bien le nouveau matériel, et lance la procédure d'installation du pilote de cette carte. Et puis grosse galère, apparait le message suivant:
" impossible d'installer ce matériel,une erreur c'est produite lors de l'installation de ce peripherique,données non valides"
Vous changez la carte de slot pci, vous téléchargez les derniers drivers sur le site du fabricant et pour finir vous essayez ou rachetez une autre carte ( en vous disant quel daube ce matos )chez un autre fabricant mais rien n'y fait, toujours la même erreur( j'espère que comme moi vous ne vous retrouvez pas avec deux cartes sur les bras ).

Si windows ne detecte pas votre matériel, c'est un autre problème (irq? ou autres) et la manip qui suit ne résoudra rien.
J'insiste sur le fait que votre carte soit bien détecté par windows et que ce ne soit juste qu'un problème d'installation de drivers car nous allons avoir besoin de l'emplacement exact de la carte par la suite.

Passons aux choses sérieuses :
Cette erreur provient du fait que nous ne sommes pas autorisé à installer cette carte ou du moins ses drivers, même si notre compte est un compte administrateur. Comment est ce possible? pour qui, pourquoi? J'en sais rien mais c'est comme ça.
La procédure suivante consiste à rétablir cette autorisation en modifiant la base de registres de windows.

Procédure pour windows 2000/2000 pro

1- Désintallation de la carte:
Allez dans le gestionnaire de périphérique
Selectionnez votre carte ( celle qui a un point d'exclamation jaune)
Cliquez droit puis choississez désinstaller et ok
Le point d'exclamation doit avoir disparu
Double cliquez sur votre carte afin de noter son emplacement
( Emplacement 1 (Bus PCI 0, périphérique 5, fonction 0) par exemple. Notez que la partie en gras ci dessus

2- Modification de la base de registre:
Cliquez sur démarrer, exécuter
Tapez regedt32.exe puis ok
Dans hkey_local_machine ouvrez system en double cliquant dessus
puis currentcontrolset/enum/pci
Vous accedez à plusieurs dossiers dont le nom commence par VEN
ouvrez le premier d'entre eux, il contient un ou plusieurs sous dossiers
Cliquez sur le premier sous dossier et verifiez deux informations sur la partie droite:
- En face de devicedesc il faut que ce soit le type de carte que vous avez installé (controleur ethernet ou modem ou carte son...)
- En face de locationinformation verifiez qu'apparait l'emplacement noté ci dessus. En effet si vous avez installé votre carte sur plusieurs autres slot pci pour vérifier si le problème ne provenait pas de là, d'autres dossiers VEN ont été crées avec la même dénomination de carte mais un emplacement différent ( j'insiste là dessus parce que je me suis fait avoir)
Si le sous dossier ne correspond pas à votre carte, refaites la manip sur le dossier VEN suivant jusqu'à que celui ci correspondes
Une fois que vous avez trouvé , selectionnez le dossier VEN et non un des sous dossiers,puis dans le menu sécurité choisissez autorisations
Dans la fenêtre qui apparait vous devriez voir administrateurs dans la case nom et seul la case lecture est cochée sous autoriser dans la case autorisations. Cochez aussi la case contrôle total puis ok.Selectionnez avancé puis l'onglet propriétaire et vérifiez que votre compte apparait bien dans la liste des noms
Si vous avez un compte administrateur c'est fini.
Si vous n'avez pas un compte admistrateur vous pouvez ajouter votre compte et lui donner l'autorisation contrôle total mais je n'ai pas fait le test.
Fermez la base de registre

3- Réinstaller le pilote:
Retournez dans le gestionnaire de périphériques
Cliquez droit sur votre carte et sélectionnez rechercher les modifications sur le matériel et la procédure d'installation du pilote doit se faire sans problème

Procédure pour windows xp

Je n'ai pas windows xp mais d'après des témoignages ça fonctionne
C'est la même manip que pour windows 2000 avec les variantes suivantes dans la modification de la base de registre:
regedit au lieu de regedt32.exe
Cliquez droit sur le dossier VEN pour selectionner autorisations et sauvegarder


Voilà, ouf, j'espère que ça vous aidera, n'hésitez pas à répondre si cela ne marchait pas,j'ai peut être la réponse

Pour terminer voici quelques liens qui peuvent s'avérer utile sur des problèmes similaires.

Message d'erreur:Cannot install hardware.
An error occurred during the installation of the device.
The Data is invalid
.
http://support.microsoft.com/default.aspx?scid=kb;[LN];810882
Dans le cas d'un upgrade vers xp

Message d'erreur:Une erreur s'est produite lors de l'installation du périphérique. Le fichier INF ou le jeu d'informations du périphérique ou un de ses éléments ne correspond pas à la classe d'installation spécifiée.
http://support.microsoft.com/default.aspx?scid=kb;fr;306983
Problèmes lors de l'installation de certaines cartes réseau sur windows 2000
Lire la suite 
Réponse
+3
moins plus
Merci beaucoup pour la solution xp (bien que j'ai du loucher sur l'explication pour win 2000 pour comprendre l'xp :p ) qui m'a enfin sorti de ce vilain probleme qui m'empechait d'avoir le net sur mon 2nd PC !
paulo- 19 mars 2011 à 14:42
Merci beacoup! Ce truc a fonctionne tres bien!
Répondre
Ajouter un commentaire
Réponse
+1
moins plus
oups dsl j'avais posté 2 fois pardon
Ajouter un commentaire
Réponse
+0
moins plus
Désolé, mais chez moi cela ne semble pas marcher... il s'agit d'une carte son Muse 5.1 DVD, et un pblm que je rencontre dans ta soluce est que quand je désinstalle la carte, elle n'apparaît plus dans la base de registre. Il me faut alors rechercher les nouveaux périphériques, l'installation du driver foire (putain de "données invalides" !) et je me retrouve alors au m point que si je n'avais pas essayé de désinstaller... Enfin, j'ai beau appliqué tout ce que tu dis "enum/PCI..." autorisations etc, cela ne fonctionne tjrs pas :-(
Ajouter un commentaire
Réponse
+0
moins plus
Salut Blooh
Ce que tu dis là me parait bien étrange, car à moins d'avoir enlevé ta carte son de son slot pci et rebooté la machine, tu dois forcément avoir un ou plusieurs dossiers VEN correspondant à ta carte selon que tu l'as installé sur un ou plusieurs slots pci, donc ouvre les tous et cherche bien la dénomination correspondant à ta carte ainsi que le bon emplacement.
Ensuite il est normal que la manip ne fonctionne après avoir essayé d'installer les pilotes sans succès car il faut impérativement désinstaller la carte d'abord
Bon courage et tiens moi au courant
Ajouter un commentaire
Réponse
+0
moins plus
oui, je suis bien d'accord avec toi que g un dossier Ven correspondant à ma carte son, mais le seul prbm est que, une fois dans le gestionnaire de périphérique, je choisi de desinstaller la carte (afin que la manip marche, comme tu l'as remarqué...), ce fichier Ven disparait ! J'en suis sur, car g 7 fichier Ven carte desinstallé (pas physiquement mais aux yeux de Windows !) et 8 qd elle est reconnue par Windows (mais mal installé !). Le pbm pour ma config avec ta solution est que qd je fais desinstallé dans le gestionnaire, ma carte disparait purement et simplement (et pas seulement le point d'exclamation...) ainsi que dans le registre, et qu'alors, pour faire les manip, je suis obligé de, via le gestionnaire, rechercher les nouveaux périph', et qu'alors Windows n'arrive pas à installer le driver.. d'où pblm ! G m essayé de me donner les droits pré-cités dès le répertoire PCI du registre, et de l'appliquer à ts les enfants, mais cela ne marche pas non plus ! Si tu as une solution, je suis preneur, m si depuis g tt re-installé dans un ordre différent où cela marche (je pense d'ailleurs que le pblm vient d'un des correctifs qui suit le ServicePack 4 de 2000...).
Ajouter un commentaire
Réponse
+0
moins plus
Merci à toi, Yoann0207 pour ta solution... elle marche d'enfer!
c'est magique...
merci encore de nous en avoir fait profiter.
Ajouter un commentaire
Réponse
+0
moins plus
Merci rémy ( et merci kaya qui m'a répondu en premier), ça fait plaisir de voir que je n'ai pas fait ça pour rien.
Concernant le problème de blooh, c'est en effet très étrange. Dans ce cas peut être qu'il ne faut pas désinstaller la carte mais modifier d'abord la base de registre. Ensuite cliquer droit sur l'icone de la carte dans le gestionnaire de périphériques et et sélectionnez rechercher les modifications sur le matériel , mais je ne suis pas sûr que ça va marcher si tu n'as pas désinstallé tes pilotes avant.
Logiquement ta carte ne devrait pas disparaitre du gestionnaire de périphériques si tu désinstalles tes pilotes et en effet sans sa présence ma méthode ne marche plus. Je cherche de mon côté, mais tiens moi au courant si tu trouves la solution
Salut
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
Moi aussi, en essayant d'installé une nouvelle carte son, j'ai eu le piti message me disant : données non valides et bla bla bla.
J'ai bien essayer de faire comme Yann avait dit mais mon pc reste définitivement tétu (j'ai mit "control total et tt mais il me met tj le message).
je suis sous Windows XP pro (je commence à le regretter)
Et ma carte son est une PCI 5.1.
Pouriez-vous m'aidez svp svp svp svp !!!

P.S :
AU SECOURS !!!
Ajouter un commentaire
Réponse
+0
moins plus
Salut niko
Tout comme blooh, je constate que cette méthode ne fonctionne pas dans vos deux cas. Ils ont un point commun à savoir l'installation d'une carte son sous windows XP. Mais je ne pense pas que cela vienne de la carte son. En cherchant bien j'ai trouvé des informations complémentaires qui peuvent avoir leur importance dans la résolution de ce problème sous XP. Après avoir sélectionné contrôle total dans la fenêtre permissions, cliquez sur avancé et cochez les cases comme décrit à cette adresse: http://www.staudio.de/kb/english/datainvalid/
En effet n'ayant pas XP je ne connais pas les phrases exactes que l'on trouve dans la version française.
J'espère que cela résolvera votre problème car autrement je sèche, à moins que votre carte mère ait un chipset son intégré à la base et que vous ayez oublié de le dévalider dans le bios avant d'installer votre carte son.
Bon courage
Ajouter un commentaire
Réponse
+0
moins plus
MERCI OH GRAND YAN !!!!!!!!!!!!
aprés la mort soudaine de ma carte graphique gforce 2 titanium je venais d'acheter une albatron geforce fx5200EP, et j'avais ce problème, aprés avoir cherché longtemps sur internet je suis tombé sur ton post ... et aprés quelques galère de compréhension, j'y suis enfin arrivé !!!
Je suis trop heureux ...!!
tout marche nikel ...
par contre j'aimerais comprendre à koi ce délire est dû ??
moi je pense que mon ancienne carte graphique c t mal désinstallée et que ca foutait le bordel ....
enfin encore merci ....
amicalement serria
Ajouter un commentaire
Réponse
+0
moins plus
Ajouter un commentaire
Réponse
+0
moins plus
EUREKA! Merci mille fois à vous tous pour la soluce : la galère était rude pour moi au point que je devais passer en WIN ME pour utiliser mes ports firewire sur mon ASUS P4S8X !!! Impossible d'installer le pilote pour l'IEEE1394 OHCI ... Enfin c'est possible et maintenant, XP PRO me conviens au poil !
Ajouter un commentaire
Réponse
+0
moins plus
J'ai pas tout lu les postes, mais il faut savoir que c'est le driver nvidia (pour les heureux possesseurs de GeForce) qui bidouille ces permissions de la base de registre et empêche ainsi l'installation de périphériques pci, quel qu'il soit. J'ai aussi séché un bon moment la dessus, formaté mon disque quelques fois avant de comprendre. ;-)
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour
Moi aussi j'ai l'erreur 1":Données non valides mais ce n'est pas pour la meme chose.
En effet l'erreur apparait lors de l'activation d'un service (IAS) sous Win 2000 serveur
Comment faire?
Merci
Ajouter un commentaire
Réponse
+0
moins plus
salut tout le monde
yann, j'ai lu ta super explication pour l'installation de ma carte son muse 5.1 dvd (tiens c'est bizarre je suis pas le seul...)
j'ai réussi a avancer jusqu'au moment au le périphérique fonctionne correctement mais qu'il nécessite un redémarrage...ce que j'effectue bien sur a chaque fois...mais a chaque fois je ne peux redémarrer qu'en mode sans échec ou au moment on ma carte n'était pas installé :(:(
si tu as une petite solution pour m'aider ce serait chouette...j'arrete pas de chercher mais je ne trouve absolument pas
@+
Ajouter un commentaire
Réponse
+0
moins plus
Franchement merci, cela foncionne parfaitement sur XP. Bon ma soirée réseau à foirer mais au - maintenant ma carte realtek fonctionne.
Ajouter un commentaire
Réponse
+0
moins plus
Merci beaucoup car je commencais à maudir la sound blaster 5.1 que je tentais en vain d installer pour mon frère ! Maintenant tout marche et ce sous windows xp pro service pack installé. Quand au fait que ca vienne des drivers pour gforce, ca ne m étonne qu'à moitié...
Ajouter un commentaire
Réponse
+0
moins plus
wahou ! yann tu es mon messie ! La dernière fois que j'ai eu ce probleme g tout réinstallé xp la galère et cette fois miracle ! je suis à la lettre tes dix commandements et tout s'installe comme par enchantement.

merci ô Yann

et beni soit ta volonté divine d'aider ton prochain.
Ajouter un commentaire
Réponse
+0
moins plus
super merci !!!

tu m'a tiré d'une sacrée galère...

t'es un crack, chapeau bas...

Moi je dis mÔssieur
Vinc- 10 déc. 2009 à 20:14
Merci.

J'avais également ce problème de "données non valides" systématique à l'installation des pilotes pour cartes PCI et carte Vidéo AGP sur mon PC en XP familiale -SP3
C’est résolu depuis 10 minutes en moins de 10 clicks.

Total respect

Vinc
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
J'étais très contente de trouver exactement le pb que je rencontre avec l'install d'une carte réseau sans fil dlink , seulement la solution ne fonctionne pas (je suis sous XP pro).
merci de me dire s'il existe d'autres pistes.
kalou
Ajouter un commentaire
Ce document intitulé «  données non valides: solution  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.