Signaler

Monter Volume DD ext. ntfs-3g [Fermé]

Posez votre question Tixou 5Messages postés mercredi 21 novembre 2007Date d'inscription 29 novembre 2007 Dernière intervention - Dernière réponse le 30 nov. 2007 à 10:12 par Manu
Salut à tous,

Je voudrais mettre le DD externe d'un copain sur mon Ubuntu 7.10
quand je le connecte, j'ai le message suivant:

Impossible de monter le volume "Disque dur"
$LogFile indicates unclean shutdown (0,0) Failed to mount '/
dev/sdf1': Opération non supporté Mount is denied
because NTFS is maked to be in use. Choose one action:
Choice 1: If you have windows then disconnect the external devices by clicking on the "Safely Remove Hardware"
icon in the Windows taskbar then shutdown Windows
cleany. Choice 2: If you don't have Windows then you can use
use the "force" option for your own responsibility. For
example type on the command line: mount -t ntfs-3g/dev/sdf1/media/Disque dur -o force
Or add the option to the relevant row in the /etc/fstab file:
/dev/sdf1/media/Disque dur ntfs-3g defaults,force 0 0


J'ai pas de windows installé, je suis débutant sous linux et quand je tape la premiere option dans un terminal
il me répond:

Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .


Et pour la deuxieme option, je ne sais pas comment faire pour modifier "fstad"

Merci
Utile
+0
plus moins
salut,

si tu tape la première ligne de commande "mount -t ntfs-3g/dev/sdf1/media/Disque dur -o force" , il te le montera tout de suite. Mais lorsque tu redémarrera ton poste, tu devra de nouveau le remonter. Si tu entre la commande "/dev/sdf1/media/Disque dur ntfs-3g defaults,force 0 0
" dans le fichier /etc/fstab, ton file system montera automatiquement au démarrage du système.

Je serai toi, je tenterai en premier le montage dynamique sans modifier le fstab.
Utile
+0
plus moins
Bonjour

Le problème à la base c'est que le disque a été débranché sans être démonté. Cela peut entraîner des incohérences et la meilleure solution c'est quand même de faire un chkdsk sous Windows. Si vous n'avez pas Windows, peut-être que le propriétaire du disque a ce qu'il faut.

ntfs-3g ne fait pas encore les reprises d'images avant sauvées dans le journal.

A savoir : il y a maintenant une version de ntfs3g gérant les protections de fichier en beta-test :

http://pagesperso-orange.fr/b.andre/security.html

Manu

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !