Posez votre question Signaler

Vérifiez la variable d'environnement TEMP [Résolu]

erwan38 - Dernière réponse le 18 déc. 2014 à 17:33
Bonjour,
J'ai aussi le problème de ce message à chaque fois que je veux ouvrir Word 2007 version "Office Famille et Etudiant 2007 "
Utilisation de Windows XP SP2 , avec les mises à jour régulières ...
Lorsque je clique sur un fichier .doc pour l'ouvrir :
1- la fenêtre jaune de Office Word 2007 s'ouvre, puis une fenêtre m'annonce : "impossible de créer le fichier de travail . Vérifiez la variable d'environnement TEMP " je clique sur OK
2- Le cadre de Word s'installe à l'écran puis, de nouveau, la même fenêtre , avec le même message concernant le dossier TEMP .
De nouveau je clique sur OK et à ce moment là mon fichier demandé est affiché !
3- Pas de problèmes pour l'enregistrement après modificatios du fichier .
Comment me débarrasser de ses messages inutiles ?
Et d'abord de quel dossier TEMP s'agit-il ? IL en existe à plusieurs étages !!!
C:\ Temp
C:\WINDOWS\Temp
C:\ Documents and settings\<<users>>\Local setting\Temp
et toutes les Applications !
J'ai vidé ces dossiers , j'ai nettoyé avec CCleaner, j'ai supprimé puis re-cré ces dossiers , avec test du résultat pour chaque opération ...
toujours mon message !
Je regrette le bon vieux Word 97 que j'utilisais avant !
Que dit Microsoft sur le sujet ??? Je n'ai pas trouvé .
J'attends de lire vos conseils éclairés ( et détaillés sur la procédure à suivre )
Lire la suite 
Réponse
+19
moins plus
bonsoir,

il faudrait que tu ouvres : clic-droit sur poste de travail/propriétés/avancées/variables d'environnement (en bas de l'ecran)

dans "variables utilisateur pour XXXX"
il faudrait avoir
TEMP : xxx
TMP : xxx

si tu n'as pas TEMP, il faudrait le creer avec la valeur qu'il y a dans TMP

ou si TEMP existe, il doit pointer sur un repertoire qui n'existe pas

cdt
Chos- 30 sept. 2012 à 02:20
Super ça fonctionne niquel !

Win7 x64 & Word 2007
Répondre
hubert- 10 oct. 2012 à 10:25
Fonctionne sur Win7 64 et Office 2010
Répondre
chboub- 2 févr. 2013 à 02:46
Bonjour,
sous seven dans recherche programme et fichier tapez regedit qui ouvrira l'éditeur du registre.Trouvez la clé de registre HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
cache: F:\WD Sync Data\"nom d'utilisateur"\Temp\SB\Temporary Internet Files
et remplcez là par c:\windows\temp
Répondre
lbs- 18 déc. 2014 à 17:29
J'avais le meme probleme que j'ai resolu avec les explication de chboub Merci a lui
Répondre
lbs- 18 déc. 2014 à 17:33
choub Serais tu me dire comment mettre les dossiers que je desire ouvrir en (details) pas petite icone ou grande je souhaiterais "details" par "defaut" Merci par avance
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+12
moins plus
J'ai le même pb, après examen du registre, j'ai trouvé la clé de registre :

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\­Explorer\User Shell Folders
cache:
F:\WD Sync Data\J Louis\Temp\SB\Temporary Internet Files

je l'ai remplacée par c:\windows\temp
et ça marche
Il semble que lors de l'installation du soft avec le disque Western Digital externe en F/ plusieurs clés de registre sont modifiées faisant référence à ce disque amovible. J'ai nettoyé cette clé mais je crains que d'autres entrées ne soient dans le même état et je ne sais comment avancer sans faire des manips risquées.
Si quelqu'un a la même expérience merci de m'aider
Malouann
richard- 14 sept. 2009 à 07:30
Quelle belle invention Internet : on écrit son message d'erreur dans google et hop! on a la solution. Parce qu'il fallait aller la chercher la clef, au bout de la base de registre ! en tout cas, en remplaçant le temp exotique par c:\windows\temp plus aucun pb. Merci à tous !
Répondre
Kid XIII- 24 mars 2010 à 14:04
Ca Marche !!

Merci pour l'info: je n'aurai jamais eu l'idée d'aller voir là !
J'ai aussi modifié ce qui était au-dessus. Pour le reste: bon courrage ...

Kid XIII
Répondre
serge- 10 août 2010 à 21:09
merci pour cete astuce. chez moi c'était effectivement la clé de registre. je connais même le coupable: dmailersync, que j'avais essayé d'installer pour recevoir des emails et les synchroniser avec outlook.
merci!
Répondre
Vigger131- 13 déc. 2010 à 22:34
La valeur d'origine de la sous-clef "cache" trouvée sur une autre bécane est

%USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files

Je l'ai rétablie et ça marche toujours..
Merci encore
Répondre
Mat- 14 nov. 2011 à 22:00
J'ai eu le même pb. En recoupant les commentaires des uns et des autres et ma propre experience, je pense que cela vient des applications Western Digital qui modifient le registre en renvoyant sur le support qui a servit de base de téléchargement au logiciel.
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+5
moins plus
pour résoudre ce problème il suffit sous vista de configurer les programmes office (winword , exel ....) pour les ouvrir en temps qu'administrateur : aller dans C:\programmes\Microsoft office\Office12, cliquer avec le bouton D sur Winword.exe, cliquer sur propriétés puis compatibilité et cocher la case : executer ce programme en tant qu"administrateur puis cliquer sur appliquer.
recommencer pour Excel ,outlook...
cela a tout résolu chez moi
A+
Jean-Paul V.- 28 oct. 2009 à 01:21
Cher ZZO,
J'avais oublie de mentionner ton nom lors de mon message de remerciement afin que les autres suivent tes indications pour corriger ce probleme.

Merci encore une fois

Jean-Paul V
Répondre
cdad65- 3 sept. 2010 à 10:21
les "autres" te remercient aussi!
Le problème est également corrigé pour moi.
Bonne continuation
Répondre
azerty- 8 févr. 2012 à 18:10
Merci pour cette info, ça a marché sous windows 7
Répondre
Lucie- 20 févr. 2012 à 16:12
Je n'ai pas Winword.exe ! A chaque fois que j'ouvre word j'ai le droit au probleme TEMP, et de plus du coup les images ne sont plus détecter, je dois recommencer tout mon travail ! Je ne trouve pas de solution...
Répondre
badu- 13 sept. 2012 à 21:43
bjr a tous je viens de débarquer par ici car jai aussi le même message qui s'affiche lorsque j'essaye d'ouvrir mes documents sous word et je ne peux aussi enregistrer mes documents ! j'ai donc essayé la démarche de zzo qui me parait bien sauf que je rencontre le mm problème que lucie je n'ai pas de dossier ou sous-dossier winword.exe. coment faire ? si qqun pouvait me répondre ça serait vraiment fort sympa car je ne peux plus rien faire alors que je travaille sur pc !!
merci de vos réponses
Répondre
Ajouter un commentaire
Réponse
+4
moins plus
Bonjour à tous

j'ai effectivement créé un nouveau profil... et ça marche...

le problème est résolu, mais si quelqu'un pouvait nous dire "de quoi ça vient", pour éviter de refaire l'opération de bug; si c'est pour créé un profil tous les mois, ..

en tout cas grand MERCI à LILO
Ajouter un commentaire
Réponse
+2
moins plus
Merci de vous interresser à mon problème .


1- j'ai appliqué les indications de jee pee : les 2 adresses de TEMP et TMP sont identiques .
2- la proposition de changer le nom de TEMP est refusée : mon disque dur serait plein ou protégé en écriture ( ni l'un ni l'autre ! )
ou bien le fichierTEMP ( c'est un dossier ! ) serait en cours d'utilisation ( tout est fermé ! ) ---> je conclue : messages bidons et passe-partout

J'ai désinstallé , puis réinstallé Office 2007 : toujours même défaut
J'ai fait un nettoyage complet du disque dur avec Spybot , puis Search and Destroy
J'ai changé mon Anti-virus ( Norton) pour essayer Avast!
Tout cela n'a pas fait disparaitre le défaut .
Ma recherche sur Google m'a fait découvrir que je ne suis pas seul avec ce Pb : d'autres Forum font mention du défaut
Quand à Microsoft , dans son FAQ de Office 2007 : tout est beau et sans PB !!!

Je viens aussi de découvrir que Word 2007 fabrique des fichiers en .docx et que les anciennes versions de Word ( installés sur d'autres PC ) ne lisent pas ces fichiers docx !!! Me voila bien pour correspondre avec autrui ... Mais ceci est un autre PB ... à voir après .
Ajouter un commentaire
Réponse
+1
moins plus
Bonjour
j'ai exactement le même problème qu'Erwan38 qui le décrit très bien , avec la même impossibilité de le résoudre (variables temps, réinstallation ....)
Il semble que sur une ancienne version de office celà proviendrait de la base de registre, mais j'ai essayé de la corriger comme indiqué sur le site microsoft (http://support.microsoft.com/kb/302629/fr) sans succès.
à suivre......
zzo
Ajouter un commentaire
Réponse
+1
moins plus
Salut,

Suis "tombé" dernièrement sur ce message.
J'avais une partition T:\ pour les fichier de type "TEMP".
Lors de l'installe de office 2007 celui-ci a considérer que tout fichier temporaires se trouvaient sur ce disque!
Lorsque j'ai supprimé cette partition pour étendre mon espace mémoire de ma partitin D.\DATA, Office c'est mis à crier !
J'ai résolu le problème d'affichage de l'erreur en éditant la base de registre et en renommant les chemins T:\ concernant office par D:\ (par ex).

Et ça marche.

++
Ajouter un commentaire
Réponse
+1
moins plus
ça fait plaisir de voir qu'on est tous dans la même situation et de trouver des solutions à ce problème!!!

Je tiens à remercier Troubadour du Chaos, qui se met à la porter des nuls en info et qui nous a détaillé la façon de résoudre ce pb (même si j'ai été bloquée quand tu dis "tu dois taper un répertoire existant sur ton disque du", c'est quoi un répertoire? et oui, quand on ne s'y connait vraiment pas en info, c'est compliqué!) et Malouann (grâce à lui je me suis rendue compte que c'est également WD qui pose problème!).

Mais leurs solutions n'ayant pas fonctionné pour moi, j'en suis revenue au message de Lilo (20/05/08) qui préconisait d'ouvrir un nouveau compte. Et ça y est, ça fonctionne enfin!

Merci à tous!
Ajouter un commentaire
Réponse
+1
moins plus
Bonjour à tous,
Apparemment Troubadour aurait trouvé la solution...par contre, je suis vraiment une bille en info et le souci, c'est que je ne trouve pas Démarrer / Exécuter (je suis sous Vista...) Quelqu'un pourrait aider une belette ?! ;-)
Merci d'avance pour vos réponses.
Ajouter un commentaire
Réponse
+0
moins plus
hello
si les variables sont ok, essayer de renommer C:\ Documents and settings\<<users>>\Local setting\Temp en C:\ Documents and settings\<<users>>\Local setting\TempXXX et recréer un dossier Temp
Ajouter un commentaire
Réponse
+0
moins plus
- essayer de renommer et recréer Temp en mode sans échec
- sauver les documents Word2007 en ancien format (enregistrer sous) pour être compatible
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour, j'ai aussi ce problème, dans votre méthode de résolution, "executer ce programme en tant qu"administrateur" est grisé (donc non accessible) que faire???

merci
a+
Ajouter un commentaire
Réponse
+0
moins plus
Salut

j ai eu le meme probleme j ai cherché sur tout les forums il y a chaque fois la mm chose qui revien ( verifier les variables effacer les temp reccrer un nouveau fichier ect) mais rien ne fonctionne.
J ai fini par trouver une solution qui prend 5 minutes:
il suffit de creer un nouveau compte admin transferer vos document personneles effacez l ancien compte et voila ca refonctionne normalement.

ps aucune autre solution car meme l outil dignostic ne fonctionne pas ( celui de office 2007)
marielg- 5 nov. 2008 à 17:25
Je suis aussi dans le même cas que les précédents....suis toujours sous XP familiale....je ne vois comment je peux me créer un autre compte "Administrateur" si j'en possède déjà un....

Ensuite comment faire pour copier les données personnelles vers ce compte.....

Quand je vais dans "panneau de configuration" "Outils d'Administration" "Gestion de l'ordinateur" je n'ai pas "utilisateurs locaux"...j'avais donc créer un compte Administrateur et un" compte d'utilisateur" que j'ai désactivé....Je ne comprends pas ce que je peux faire...Vos lumières sont les bienvenues....
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
pour ma part ca m est arive apres que mon ordi c'est crashé et j etais en train de travailler sur office et puis j ai utiliser un prog pr reparer les erreur de registre donc je pense que c est une cle de registre qui a ete effacé. Donc il faut plus utiliser ces programes donc a mon avis c est du a une erreur dans le registre.
bref apres ca je n arrivait plus a supprimer mon ancien compte je sais pas l ordi se plantait quand je passait par panneau de config puis utilisteur puis effacer l utilisateur. rien a faire meme en mode sans echec donc finalement apres qq heures de recherche j ai trouve comment faire il suffit d aller dans executer et tapper control userpasswords2 puis supprimer ton ancien compte ca fonctionne tres bien et c est fait en 2 s voila je te le signial au cas ou t aurais le meme probleme pr suprimer ton ancien compte.
Ajouter un commentaire
Réponse
+0
moins plus
J'ai vista et j'ai rencontré le même pb hier soir que vous tous.
Après avoir essayé plein d'astuces données par ce site ou d'autres ou notre pb est exposé, j'ai finalement trouvé une solution.
Je n'ai DONC pas besoin de créer un nouveau compte administrateur et récupérer mes données personnelles !
Il s'agit d'un problème de lecture seule !! Allez dans vos dossiers et clic droit sur propriétés ! décochez la case lecture seule, appliquer et le tour est joué !
bonne route ...
marie- 11 nov. 2008 à 22:18
Merci de votre réponse, mais après avoir vérifié, les dossiers, la rubrique "lecture seule" n'est pas cochée et j'ai toujours le problème....en plus j'avais des documents avec des dessins genre "avatars", ils n'apparaissent plus seule un cadre noir...Je ne comprend pas comment faire pour changer mon "Administrateur" et récupérer mes données personnelles...Si vous savez...merci
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

je viens de rencontrer le même problème. Message qui s'affiche au lancement de word puis plantage de l'appli au bout de quelques minutes à cause d'un manque de mémoire.

Si ça peut aider, j'ai simplement vidé une bonne partie du répertoire TEMP (beaucoup de fichiers Word temporaires) et maintenant, tout est rentré dans l'ordre. Je n'ai pas touché aux fichiers verrouillés.

A+
tifil 55Messages postés jeudi 20 août 2009Date d'inscription 31 mars 2013Dernière intervention - 17 juin 2010 à 09:42
Troubadour, j'ai bien suivi ce que vous disiez, je suis allé dans le registre etc...
Mais, vous dite "et dans le champ "valeur de la donnée", tu dois taper un répertoire existant sur ton disque dur".
Or, je ne sais pas qu'est-ce que je dois mettre comme répertoire.

Merci d'avance pour ton aide.
Répondre
Troubadour Du Chaos- 17 juin 2010 à 10:50
Mets "C:\windows\temp" (sans les guillemets), ça marchera.
Répondre
jojo- 14 janv. 2012 à 12:36
Merci beaucoup Troubadour pour ces informations!!!
Ca fait depuis hier que j'essaye toute sorte de chose et maintenant grâce à vos infos ça marche enfin à nouveau!!

Merci =)
Répondre
marie- 18 oct. 2012 à 10:25
Merci à Troubadour du Chaos c parfait !
Répondre
Isaana 1Messages postés samedi 7 septembre 2013Date d'inscription 7 septembre 2013Dernière intervention - 7 sept. 2013 à 07:49
Merci beaucoup Troubadour du Chaos.
Tes explications sont très claires.
Je ne suis pas douée, et aller dans la base de registre est qq chose qui me fait peur, et grâce à toutes les questions que t'as posé Tifil, et tes réponses, j'y suis arrivée parfaitement.
Et enfin mon word fonctionne parfaitement maintenant.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Super, ca marche.... serait-il si compliqué pour microsoft de pondre un patch correctif???

Génial Troubadour !!
Ajouter un commentaire
Réponse
+0
moins plus
Bonsoir,
Merci d'abord pour toutes ces indications, car grace à vous j'ai pu réouvrir mes fichiers word que je ne pouvais plus utiliser.
Lors des vérifications faites, je me suis apercue que ma clé de registre répertoriait en fait mon disque dur externe.
De ce fait, je me rapproche de la situation de malouann, car ce probleme de variable temp a surgit après que je me sois servit de mon WD...
Par conséquent, mes fichiers peuvent maintenant s'ouvrir (ce qui est une grande évolution !!! ), mais, la fenêtre d'erreur continue de s'afficher.
Je me demande donc comment ce problème va enfin pouvoir se résoudre, afin que je ne passe pas mon temps à cliquer sur la fenêtre persistante!
De plus, un autre message d'erreur consécutif me dit que j'ai ouvert une boite de dialogue....
Enfin bref, vous aurez compris que je ne suis pas très aidée en informatique!
Merci donc, à ceux qui passent du temps à essayer de résoudre nos problèmes.....!
Ajouter un commentaire
Réponse
+0
moins plus
merci pour la solution proposée. ça marche!!!!
c'est mon DD WD qui était la source du problème
Ajouter un commentaire
Réponse
+0
moins plus
Ajouter un commentaire
Ce document intitulé «  vérifiez la variable d'environnement TEMP  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.