Menu

Afficher valeur selon l'âge.... [Résolu]

Celuiquiabesoindaide 4 Messages postés mercredi 14 février 2018Date d'inscription 15 février 2018 Dernière intervention - 14 févr. 2018 à 14:01 - Dernière réponse : Celuiquiabesoindaide 4 Messages postés mercredi 14 février 2018Date d'inscription 15 février 2018 Dernière intervention
- 15 févr. 2018 à 07:06
Bonjour à tous,
Je dois créer une formule pour afficher une valeur selon l'âge. J'ai 8 valeurs à choix a afficher. Ces 8 valeurs sont sur la feuille Ptech (cellules A1 à A8). La cellule B37 où la valeur doit s'afficher est sur la feuille Offre nouvel appareil. Exemple, pour un appareil de 1,2 et 3 ans, le facteur est de 0.00, pour 4 ans, le facteur est de 0,15, etc (voir pièce jointe). Le nombre d'année se trouve sur la feuille Ptech (cellule D5).
Merci pour votre Aide...
Afficher la suite 

6 réponses

Répondre au sujet
Vaucluse 21329 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 février 2018 Dernière intervention - 14 févr. 2018 à 14:36
0
Utile
5
Bonjour
1°) comment sont formatées les cellules de colonne B feuille Ptech
si ce sont des valeurs num avec "ans" affichées par le formatage personnalisé de cellule c'est ok. Si par contre ce sont des textes, mieux vaut les transformer en valeur num en éliminant le "ans" et en formatant en "standard"

2°)ensuite pour trouver le correspondant en A de la valeur de D5 en B37 de "Offre nouvel appareil":

=INDEX(Ptech!A:A;EQUIV(Ptech!D5;Ptech!B:B;0))

et si besoin pour éviter un affichage d'erreur quand D5 est vide (à partir de Excel 2007)
=SIERREUR(INDEX(Ptech!A:A;EQUIV(Ptech!D5;Ptech!B:B;0));"")

et avant 2007

=SI(Ptech!D5="";"";INDEX(Ptech!A:A;EQUIV(Ptech!D5;Ptech!B:B;0)))

crdlmnt

Celuiquiabesoindaide 4 Messages postés mercredi 14 février 2018Date d'inscription 15 février 2018 Dernière intervention - 14 févr. 2018 à 15:26
Merci beaucoup, ca fonctionne...... Belle journée à vous
Vaucluse 21329 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 février 2018 Dernière intervention - 14 févr. 2018 à 15:29
Pas de quoi
bonne route
crdlmnt
Celuiquiabesoindaide 4 Messages postés mercredi 14 février 2018Date d'inscription 15 février 2018 Dernière intervention - 14 févr. 2018 à 15:55
Petite question encore, j'ai un problème avec la date. Si la date d'achat est le 20.12.2009, l'appareil est dans la 9ème année le 14.02.2018. Or, la formule me met qu'il est dans la 8ème année, ou est l'erreur?
=SI(D3<>"";DATEDIF(D3;D1;"y");"")
Vaucluse 21329 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 février 2018 Dernière intervention - 14 févr. 2018 à 17:40
Tout à fait normal, DATEDIF avec le code "y" ne compte que les années complètes
en fait vos dates donnent 8 ans, 1 mois et14 jours

il reste à savoir comment vous voulez compter les années et à, partir de quel moment vous devez inclure une année complète
par exemple
si chaque année entamée d'au moins un mois est considérée comme complète, cette formule devrait faire l'affaire:

=SI(D3<>"";DATEDIF(D3;D1;"y")+SI(DATEDIF(D3;D1;"ym")>0;1;0);"")

mais pour ça, il faut que vous sachiez décider de ce qui est une année à prendre en compte

exemple:
pour une année entamée d'un seul jour: remplacer "ym" par "yd"
pour 6 mois; remplacez >0 par >6
etc..

Si besoin, revenez avec l'information et on concoctera la solution.

à vous lire

crdlmnt
Celuiquiabesoindaide 4 Messages postés mercredi 14 février 2018Date d'inscription 15 février 2018 Dernière intervention - 15 févr. 2018 à 07:06
Vous êtes un Grand Seigneur d'Excel.... Merci beaucoup.... Tout fonctionne.
Commenter la réponse de Vaucluse