Menu

Données d'une autre feuille et menu déroulant [Résolu]

Kohmoran 23 Messages postés mardi 28 octobre 2008Date d'inscription 14 février 2018 Dernière intervention - 14 févr. 2018 à 12:08 - Dernière réponse : Vaucluse 21357 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 février 2018 Dernière intervention
- 14 févr. 2018 à 12:41
--- EDIT : SUJET RESOLU !

Bonjour à tous,

J'ai une petite question concernant un classeur Excel que j'essaie de réaliser.

J'explique la situation :
Je suis en train d'essayer de créer un calculateur d'équilibrage de densité pour créer des objets composites (des leurres, en l'occurrence).

J'ai donc créé une première feuille que nous appellerons "Base de Données" avec les noms des matériaux et toute une série de données qui les concernent (densité, dureté, indice de réfraction, point de fusion, etc.), histoire d'avoir ça sous la main.

Dans la seconde feuille que nous appellerons "Calculateur", je voudrais faire des choix de matériaux par menu déroulant (jusque là ça va), et que la densité du matériau choisi apparaisse dans la colonne suivante pour mes calculs.

Pour le moment, j'ai recopié sous forme de matrice les données qui m'intéressaient dans la feuille du Calculateur, mais pas pratique quand je vais rajouter des matériaux ou corriger des valeurs par la suite...

Du coup je voudrais avoir dans le calculateur le menu déroulant, sélectionner par exemple "Balsa", et que la densité du balsa soit récupérée dans la colonne E de ma base de données et affichée dans la colonne B du calculateur.

Comment faire, du coup, pour éviter de devoir recopier des données à la main ?

J'espère avoir été clair. Pas évident de formuler tout ça, et c'est pour ça que je n'ai pas su trouver ça sur Google... Merci d'avance !
Afficher la suite 

2 réponses

Répondre au sujet
Kohmoran 23 Messages postés mardi 28 octobre 2008Date d'inscription 14 février 2018 Dernière intervention - 14 févr. 2018 à 12:41
0
Utile
Il semblerait que j'aie trouvé la solution. J'ignore pourquoi, mais quand je cherchais la fonction RECHERCHEV, elle ne s'affichait pas dans Excel. D'un seul coup, tout devient plus simple ! :)
Commenter la réponse de Kohmoran
Vaucluse 21357 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 février 2018 Dernière intervention - 14 févr. 2018 à 12:41
0
Utile
Bonjour
si le nom cherché est en 1° colonne à gauche de la plage base de données:

=RECHERCHEV(valeur cherchée;plage de base de données;rang de la colonne à ressortir;0)
soit par exemple une base de données en feuil1 avec le matériau en colonne A et des données spécifiques en ligne de colonne B à colonne X

en feuil2, le menu déroulant en A2 pour choisir le matériau
en B2 si vous voulez ressortir la valeur de E correspondante:

=RECHERCHEV(A2;Feuil1!A:X;5;0)

et pour éviter un affichage d'erreur quand A est vide:
=SIERREUR(RECHERCHEV(A2;Feuil1!A:X;5;0);"")
5 désignant la 5° colonne de la plage A:X (soit E)
le 0 est un code Excel qui spécifie le mode de recherche à appliquer
si toutefois la valeur cherchée se trouve à droite de la valeur à ressortir dans la base de données, revenez, il y a d'autres solutions

crdlmnt


Commenter la réponse de Vaucluse