Sous-menus exposés en clair au lieu d'être dans un ascenseur [Résolu]

Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention - 14 janv. 2018 à 15:14 - Dernière réponse : Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention
- 15 janv. 2018 à 14:48
Bonjour,

Ma configuration WP actuelle :

– Version de WordPress : 4.9.1
– Version de PHP/MySQL : 5.6.33 / 10.0.31
– Thème utilisé : vantage-child
– Extensions en place : Akismet Anti-Spam (4.0.2), Erident Custom Login and Dashboard (3.5.5), Forum_wordpress_fr (4.1), Google Analytics for WordPress by MonsterInsights (6.2.6), Gravity Forms (2.2.5), Gravity Forms Toolbar (1.7.0), Lazy Load (0.6.1), MetaSlider (3.6.7), MetaSlider – Pro Add-on Pack (2.7.1), Page Builder by SiteOrigin (2.6.0), PHP Code Widget (2.3), Post Tags and Categories for Pages (1.4.1), Really Simple SSL (2.5.24), SiteOrigin CSS (1.1.5), SiteOrigin Widgets Bundle (1.11.3), TablePress (1.9), TinyMCE Advanced (4.6.7), WooCommerce (3.2.6), WooCommerce Gateways Country Limiter (1.4), WordPress Database Backup (2.3.1), WP-Members (3.1.9.3), WP All Import (3.4.6), Yoast SEO (6.1.1)
– Adresse du site : https://www.resimarmo.pt
– Nom de l’hébergeur : Apache

Problème(s) rencontré(s) :

J’ai un problème dans le menu principal de mon site WordPress en portugais, https://www.monsite.pt. Je ne peux pas déclarer la page « ma page d »accueil » comme page d’accueil de mon site dans « Réglages » –> « Lecture » du tableau de bord de WordPress. Quand je la déclare, cela provoque un conflit avec une page « Inicio » (« accueil » en portugais) que je n’ai pas créée (ou que j’ai peut-être créée il y a plusieurs mois mais je ne m’en souviens plus). Par quoi cela se manifeste-t-il ? Les sous-menu et sous-sous-menus de la page « ma page d’accueil » sont exposés en clair sur une ligne en dessous de la ligne de menu principal (Alors qu’ils ne devraient apparaître que quand je passe par dessus, avec la souris).

Comment remédier à ce problème ?

Quelqu’un aurait peut-être une idée ?

Merci d’avance pour la réponse.

Kidbert6.
Afficher la suite 

7 réponses

Répondre au sujet
elgazar 4405 Messages postés mercredi 30 octobre 2013Date d'inscription 17 janvier 2018 Dernière intervention - 14 janv. 2018 à 17:20
0
Utile
1
Bonjour

ta page d'accueil a l'air de fonctionner normalement, est ce que tu as résolu ton problème ?
Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention - 14 janv. 2018 à 18:16
Bonsoir elgarar, merci de t'occuper de mon problème, content de te retrouver.
Je viens de m'apercevoir qu'elle apparaissait quand je suis sur une autre page (c'est déjà quelque chose). Par contre, il y a une page qui se nomme "Inicio" (Accueil en portugais) que je ne me souviens pas avoir créée. De plus, je ne la trouve nulle part. Elle n'est pas dans les pages, pas dans les articles, pas dans les catégories, pas dans le menu, elle n'est nulle part ! Et, pourtant, elle bien là ! C'est un vrai mystère. Si je déclare ma page RESIMARMO comme page d'accueil statique, les sous-répertoires s'affichent sur une ligne en dessous du menu et non pas dans un menu déroulant comme cela devrait être le cas. Je vais le faire et si tu revisites mon site, tu la verras (https://www.resimarmo.pt). Je viens de m'apercevoir que la page RESIMARMO n'apparaît pas dans cette configuration là. Ce qui est problématique car c'est normalement ma page d'accueil. J'ai treize sites identiques mise à part la langue qui est différente mais sur tous mes autres sites je n'ai pas ce problème. Je viens de m'apercevoir que quand je clique sur "Inicio" je me retrouve sur la page RESIMARMO. Je viens d'essayer en ne déclarant pas RESIMARMO comme page d'accueil cela fonctionne, les sous-pages de RESIMARMO se positionnent bien, mais "Inicio" reste ! Et je ne sais vraiment pas où le chercher pour le supprimer.
Si tu veux des copies d'écran, dis le-moi. Je m'empresserais de t'envoyer ce dont tu as besoin.
Amicalement.
Kidbert6.
Commenter la réponse de elgazar
elgazar 4405 Messages postés mercredi 30 octobre 2013Date d'inscription 17 janvier 2018 Dernière intervention - Modifié par elgazar le 14/01/2018 à 19:05
0
Utile
j'ai un peu de mal a comprendre le problème entre tous ces mots de portugais (on est dimanche soir en plus)

si j'ai bien compris, par défaut tu as la page d'accueil de wordpress qui se nomme inicio, elle doit normalement te montrer la rotation d'article mais quand tu spécifie une autre page d'accueil, tu as toujours le lien inicio qui pointent vers l'ancienne page, c'est ca ?

Avec un ordinateur, on peut faire plus rapidement des choses qu’on n’aurait pas eu besoin de faire sans ordinateur.
Commenter la réponse de elgazar
Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention - 14 janv. 2018 à 19:36
0
Utile
Merci de me répondre si vite et désolé de ne pas être plus explicite, je vais être plus concret.
"Inicio" je ne l'ai pas créée (je ne sais pas si c'est une page, un article ou une catégorie).
Par contre, j'ai créé la page "RESIMARMO" (sur mes 13 sites c'est la page d'accueil et tout se passe bien).
Le problème est le suivant :
1) je ne veux plus voir "Inicio".
2) Je veux déclarer RESIMARMO comme page d'accueil (dans le Tableau de bord de WordPress --> Réglage -> Lecture et dans les Options de lecture au niveau de : La page d’accueil affiche je veux choisir le bouton radio devant Une page statique (choisir ci-dessous) et en dessous je veux sélectionner la page RESIMARMO.
J'ai accès à tous cela, il n'y a pas de problème mais... (et c'est là que j'ai besoin d'un conseil) quand je fais tous ces réglages cela provoque une suppression du nom RESIMARMO de son emplacement normal et le menu déroulant qui, normalement devrait s'afficher au survol de RESIMARMO, est remplacé par une liste en ligne (les uns à côté des autres) en dessous du menu principal. Je vais te faire deux copies d'écran (une normale, ou cela se passe bien sur mes autres sites et une autre de ce que je vois sur ce site là)

Commenter la réponse de Kidbert6
elgazar 4405 Messages postés mercredi 30 octobre 2013Date d'inscription 17 janvier 2018 Dernière intervention - 15 janv. 2018 à 09:58
0
Utile
je vois que tu as réglé le problème et que ton site s'affiche correctement
Commenter la réponse de elgazar
Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention - 15 janv. 2018 à 10:26
0
Utile
1
Mon cher elgazar,
Non, le problème n'est pas encore résolu, mais je sais que cela vient du thème.
J'ai désactivé tous les Plugins mais cela n'a rien changé.
J'ai ensuite changé mon thème par Twenty Thirteen de WordPress et là mon menu s’affiche bien. « Inicio » n’apparais plus et le menu déroulant de « RESIMARMO » fonctionne bien.
C’était donc une question de « Thème« . Je vais envoyer un message à mon interlocuteur privilégié chez SiteOrigin pour qu'il m'aide à le résoudre.
Quand ce sera résolu je reviendrais sur le forum pour donner les explications.
Je te remercie beaucoup de m'avoir pris en charge.
Amicalement.
Kidbert6.
Kidbert6 18 Messages postés lundi 19 juin 2017Date d'inscription 15 janvier 2018 Dernière intervention - 15 janv. 2018 à 14:48
Voilà. C'est réparé !
C'était un problème de déclaration de menu dans :
WP Admin > Apparence > Menus et ouvrir Gérer les emplacements. Ensuite, j'ai défini le menu principal sur Menu 1 et j'ai enregistré.
C'est tout ce qu'il y avait à faire.
Je l'avais déjà fait, mais j'aurais dû le refaire une seconde fois car c'est à la seconde fois que le thème a accepté le réglage.
Merci, elgazar pour ton aide.
Amicalement.
Kidbert6.
Commenter la réponse de Kidbert6