Recherche dates [Résolu]

kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 10:41 - Dernière réponse : Vaucluse 21013 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 janvier 2018 Dernière intervention
- 12 janv. 2018 à 17:45
Bonjour,

Bonjour,

Je viens sur le forum afin d'obtenir une petite aide concernant un petit fichier excel:
- J'ai 3 jalons dont les dates peuvent être differentes selon le mois. Je souhaiterais que chaque mois, les dates des jalons soient recherchées dans la table F1:L4 puis affichées respectivement dans les cellules C4, C6 et C8.

- Néanmoins les dates extraites de la table doivent être celles du mois actuel donc de la colonne avec le mois correspondant. Ainsi, je souhaiterais savoir quelle serait la formule à intégrer dans ces cellules afin qu'à chaque début de mois, les dates affichées dans ces 3 cellules soit automatiquement mises à jour en fonction des dates affichées dans la table.

- Je ne sais pas vraiment s'il est nécessaire d'y apporter la fonction AUJOURDHUI() pour créer un lien mais dans le doute, la cellule A1 contient notamment cette fonction.

Voici le fichier pour plus de facilité : https://www.cjoint.com/c/HAmjNSblppj

Je vous remercie de votre aide et j'en profite pour vous présenter à tous mes meilleurs voeux pour cette nouvelle année.
Afficher la suite 

14 réponses

Répondre au sujet
M-12 115 Messages postés lundi 22 septembre 2008Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 10:54
0
Utile
2
Bonjour

A tester
https://www.cjoint.com/c/HAmj2WYklIX
kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 11:47
Bonjour M-12
cela fonctionne,à voir le mois prochain :)
Merci de votre aide
kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 11:53
Je profite de votre réponse pour vous poser une autre question : si je souhaite ajouter une colonne n-1 pour afficher la colonne du mois précédent quelle modification devrais-je apporter à cette formule ?
Commenter la réponse de M-12
Vaucluse 21013 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 janvier 2018 Dernière intervention - Modifié par Vaucluse le 12/01/2018 à 11:10
0
Utile
8
Bon,jour
est ce ça que vous cherchez?
voyez les notae dans la feuille
https://mon-partage.fr/f/IJgsKseA/
revenez si ça ne convient pas

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Vaucluse 21013 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 15:05
vi... encore une petite erreur dans la position de la parenthèse, c'et ma spécialité!
essayez avec
=SOMMEPROD((MOIS($G$1:$R$1)=MOIS(AUJOURDHUI())-1)*(DECALER($G$1;EQUIV("J1";$F$2:$F$4;0);;;12)))

soit la position des parenthèses derrière le code MOIS(AUJOURDHUI())-1)
kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 16:32
décidement cela ne veut pas ^^. la date 00/01/1900 apparait
Vaucluse 21013 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 17:22
effectivement, la partie MOIS(.....)-1 renvoie 0 sur janvier

essayez celle ci ça a l'air de fonctionner

=SOMMEPROD((MOIS($G$1:$R$1)=MOIS(MOIS.DECALER(AUJOURDHUI();-1)))*(DECALER($G$1;EQUIV("J1";$F$2:$F$4;0);;;12)))

crdlmnt
kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 17:37
Super, cela fonctionne !
Merci beaucoup
Cordialement
Vaucluse 21013 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 17:45
éh bé voila, tout arrive :-)
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse
0
Utile
1
bonjour,
je ne suis pas certain que j'ai bien compris la situation, mais est ce que la fonction Mois( ) peut résoudre votre problème?
kamccm 20 Messages postés dimanche 15 mai 2016Date d'inscription 12 janvier 2018 Dernière intervention - 12 janv. 2018 à 11:49
Bonjour,
même si les deux formules présentées précedemment fonctionnent, je vais tâcher d'y jeter un coup d'oeil.
Merci
Commenter la réponse de ygj