Formule excel somme d'une valeur par semaine et par mois [Résolu]

Franck6767 - 10 janv. 2018 à 10:32 - Dernière réponse :  Franck6767
- 10 janv. 2018 à 13:46
Hello tout le monde !

J'aurais besoin de votre aide car la formule que je souhaite mettre en application ne fonctionne pas.

Voici mon problème :

J'ai une colonne A avec des dates, colonne B avec un montant

Ce que je souhaite faire:

Extraire le chiffre d'affaires par semaine (en incluant la formule NO.SEMAINE) en fonction de la semaine sélectionnée dans une liste déroulante créé à côté
Extraire le chiffre d'affaires par mois en fonction du mois sélectionné dans une liste déroulante créé à côté

Donc si je sélectionne par exemple dans la liste déroulante semaine 5, je voudrais la somme du chiffre d'affaire faite dans la semaine 5
Et pareil pour une ligne en-dessous où si je sélection dans la liste déroulante le mois de février par exemple, je voudrais la somme du chiffre d'affaire faite en février.

Merci beaucoup =D
Afficher la suite 

8 réponses

Répondre au sujet
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - Modifié par Vaucluse le 10/01/2018 à 10:51
0
Utile
7
Bonjour
à adapter:
date en A2:A100, montant en B2:B100

pour la semaine, si par exemple le N° de semaine est Y1, en Z1:
=SOMMEPROD((NO.SEMAINE($A$2:$A$100)=Y1)*($B$2:$B$100))

pour le mois, avec du mois en Z2:
=SOMMEPOD((MOIS($A$2:$A$100)=Y2)*($B$2:$B$100))

pour éviter de trop charger le fichier limitez les champs à la hauteur utile (ici de 2 à 100) mais pas de A:A ouB:B

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Je n'y arrive toujours pas...

https://mon-partage.fr/f/JNteZD5K/

Merci pour votre aide
yclik 1212 Messages postés vendredi 25 juillet 2014Date d'inscription 15 janvier 2018 Dernière intervention - 10 janv. 2018 à 12:08
Bonjour
voir avec cette formule
=SOMMEPROD((NO.SEMAINE($B$2:$B$100;1)=F1)*($C$2:$C$100))
si N° semaine en F1
J'ai toujours le problème avec #VALEUR et je ne comprends pas de quoi ça vient, voir sur mon fichier
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 10 janv. 2018 à 12:31
Re
Ouaip, bon...à priori, c'est une découverte, mais; SOMMEPROD ne reconnait pas le code NO.SEMAINE (?)

une solution
dans la feuil1 , par exemple en E2:E14, tirer cette formule:

=NO.SEMAINE(B2)

et en feuil2 D3 la formule devient:
=SOMMEPROD((Feuil1!E2:E14=C3)*(Feuil1!$C$2:$C$14))

notez aussi que pour avoir un résultat en D4, c'est le N° du mois qu'il faut placer en C4 plutôt que le nom

à moins d'écrire, si vous gardez le menu déroulant:

=SOMMEPROD((MOIS(Feuil1!$B$2:$B$14)=EQUIV(C4;Feuil2!$H$5:$H$16;0))*(Feuil1!$C$2:$C$14))

crdlmnt
Ca a été compliqué mais j'ai fini par réussir, merci beaucoup !!
Commenter la réponse de Vaucluse