Fonction SI avec du texte sur 2 cellules [Résolu]

max33d - 9 janv. 2018 à 14:33 - Dernière réponse :  Max33d
- 11 janv. 2018 à 16:01
Bonjour à tous,

Je vous fais part de mon problème du jour.
En fait j'aimerais créer une fonction SI avec plusieurs conditions. Si ma cellule E3 contient le mot PV alors la valeur renvoyée est 1 (0 si ce n'est pas le cas) mais si dans le même temps ma cellule H3 contient le mot BLANC ou CQ alors la valeur renvoyée est 0 (1 si ce n'est pas le cas)



Merci pour votre aide.



Afficher la suite 

24 réponses

Répondre au sujet
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 9 janv. 2018 à 14:38
0
Utile
11
Bonjour

=SI(ET(E3="PV";H3<>"BLANC";H3<>"CQ");1;0)

crdlmnt
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:36
le blanc est à placer uniquement si bvous risquez d'avoir dans certazins mots des syllabes correodnantes aux texte cherchés. ils seriont alors comptés comme effectifs.
ce blanc permettra d'isoler les textes cherchés
par exemp:
=NB.SI(cel;"*blanc*") détectera aussi le mot blanchette, mais
=NB.SI(cell;"*blanc *") avec un blanc devant le dernier *
ne le détectera pas
et
=NB.SI(cell;"* blanc *") ne détectera que le mot blanc précédé et suivi d'un blanc
crdlmnt
max33d 8 Messages postés mardi 9 janvier 2018Date d'inscription 9 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:41
Très bien, je comprends.

Quand j'applique la formule =SI(ET(NB.SI(E3="*PV*");NB.SI(H3;"*BLANC*")=0;NB.SI(H3;"*CQ*")=0);1;0)
un message d'erreur apparaît me disant que j'ai tapé un nombre insuffisant d'arguments.

Cdt
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:48
exact.. faute de frappe de ma part
derrière le E3 dans le 1° NB.SI, remplacez le signe = par un point virgule
crdlmnt
max33d 8 Messages postés mardi 9 janvier 2018Date d'inscription 9 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:56
Avec le point virgule les 3 fonctions NB.SI ne fonctionnent pas, la fonction ne "différencie" pas la plage et le critère du coup.
Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 11 janv. 2018 à 15:19
J'ai testé la formule de Vaucluse dans ton fichier du message #18 et elle fonctionne parfaitement !
=SI(ET(NB.SI(D3;"*PV*");NB.SI(E3;"*BLANC*")=0;NB.SI(E3;"*CQ*")=0);1;0) en G3.
Commenter la réponse de Vaucluse
Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:28
0
Utile
1
Bonjour max33d.

Ta description du problème n'est pas très claire pour moi.

Tu écris " Si ma cellule E3 contient le mot PV alors la valeur renvoyée est 1 ... mais si dans le même temps ma cellule H3 contient le mot BLANC ou CQ alors la valeur renvoyée est 0 ". Comment comprendre cela ?
Si E3 contient PV et H3 contient CQ, on affiche 1 ou 0 ?

Le mieux est que tu corriges ce tableau, s'il est inexact :
                              
H3 | Blanc ou CQ | ---
E3 | |
PV | 0 | 1
--- | 0 | 0
max33d 8 Messages postés mardi 9 janvier 2018Date d'inscription 9 janvier 2018 Dernière intervention - 9 janv. 2018 à 15:31
Bonjour Raymond,

Le tableau est juste. Pour vous répondre à votre question "Si E3 contient PV et H3 contient CQ, on affiche 1 ou 0 ?" on affiche bien 0 comme indiqué dans le tableau.
Commenter la réponse de Raymond PENTIER
Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 9 janv. 2018 à 16:02
0
Utile



Alors je peux te proposer
Commenter la réponse de Raymond PENTIER
max33d 8 Messages postés mardi 9 janvier 2018Date d'inscription 9 janvier 2018 Dernière intervention - 9 janv. 2018 à 16:22
0
Utile
6
Voici une capture d'écran de ce que j'attends au final (surligné en jaune). Les différents essais de fonctions ne fonctionnent pas.

Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 9 janv. 2018 à 16:49
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Bonjour à tous,

Voici le lien du fichier Excel : https://www.cjoint.com/c/HAliVrGDij7

Merci de votre aide.
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 11 janv. 2018 à 10:59
Bnjour
alors ma dernière proposition devrait faire l'affaire, voyez ici:
https://www.cjoint.com/c/HAlj5SyYVwy
crdlmnt
Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 11 janv. 2018 à 14:55
Mon ami Vaucluse, je crois que t'es trompé de fichier ...

Bonne journée.
Vaucluse 21045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 11 janv. 2018 à 15:14
Exact, voici le bon
https://www.cjoint.com/c/HAlon0WOjSy
merci pour lui
crdlmnt
Commenter la réponse de max33d
Raymond PENTIER 44849 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 janvier 2018 Dernière intervention - 11 janv. 2018 à 15:23
0
Utile
1
Je t'ai répondu plus haut :
J'ai testé la formule de Vaucluse dans ton fichier du message #18 et elle fonctionne parfaitement ! 
=SI(ET(NB.SI(D3;"*PV*");NB.SI(E3;"*BLANC*")=0;NB.SI(E3;"*CQ*")=0);1;0) en G3.

C'est bien, la retraite ! Surtout aux Antilles ... Raymond (INSA, AFPA)
Vous êtes au top les gars !!! Un énorme merci !
Commenter la réponse de Raymond PENTIER