Formule totalisation en fonction de la valeur d'une cellule [Résolu]

marckherv 65 Messages postés mardi 1 août 2017Date d'inscription 16 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:04 - Dernière réponse : marckherv 65 Messages postés mardi 1 août 2017Date d'inscription 16 janvier 2018 Dernière intervention
- 30 déc. 2017 à 18:50
Bonjour,

Je souhaiterai totaliser des montants entre eux en fonction d'une valeur
Je m'explique
colonne A: famille (de 0 à 99)
colonne B: un identifiant
colonne C: la valeur à totaliser pour chaque famille
colonne D: le sous-total par famille (à inscrire pour la ligne du dernier article de la famille)-> cellule en jaune sur mon fichier

colonne E: le nombre d'article dans la famille (à inscrire pour la ligne du dernier article de la famille)-> cellule en jaune sur mon fichier

et cerise sur le gâteau: pouvoir synthétiser le résultat ds colonne D et E dans un tableau


Merci pour votre aide

https://www.cjoint.com/c/GLErcmeFrHj
Afficher la suite 

7 réponses

Répondre au sujet
yclik 1213 Messages postés vendredi 25 juillet 2014Date d'inscription 22 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:15
0
Utile
1
Bonsoir
Voir du côté des tableaux croisés dynamiques
ce qui donnerait ceci
marckherv 65 Messages postés mardi 1 août 2017Date d'inscription 16 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:49
merci, je procède comment?
Commenter la réponse de yclik
via55 8960 Messages postés mercredi 16 janvier 2013Date d'inscription 22 janvier 2018 Dernière intervention - Modifié par via55 le 30/12/2017 à 18:25
0
Utile
1
Bonjour,

En E7 la formule =SI(NB.SI($A$7:A7;A7)=NB.SI(A:A;A7);NB.SI(A:A;A7);"") à étirer vers le bas
E n D7 la formule =SI(E7<>"";SOMME.SI(A:A;A7;C:C);"") à étirer vers le bas

Cdlmnt
Via

"L'imagination est plus importante que le savoir."    A. Einstein
marckherv 65 Messages postés mardi 1 août 2017Date d'inscription 16 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:50
merci
Commenter la réponse de via55
Vaucluse 21062 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:21
0
Utile
2
Bonjour
curieux, Via (salut, bonne fin d'année)
moi j'avais fait ça :-))
https://mon-partage.fr/f/jzXBPL1e/
crdflmnt
via55 8960 Messages postés mercredi 16 janvier 2013Date d'inscription 22 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:25
Hello Vaucluse, bonne fin d'année également ☺
On a des formules similaires, simplement pour toi c'est la colonne D qui détermine si on calcule et moi la E (j'avais écris F par erreur dans ma réponse, j'ai corrigé)
marckherv 65 Messages postés mardi 1 août 2017Date d'inscription 16 janvier 2018 Dernière intervention - 30 déc. 2017 à 18:50
Merci
Commenter la réponse de Vaucluse