Besoin de support pour une formule [Résolu]

Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 19 déc. 2017 à 20:11 - Dernière réponse : Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention
- 29 déc. 2017 à 18:43
Voici mon problème:

J'ai un nombre dans Aet je voudrais soustraire de celui-ci lorsqu'il y a du texte en C et additionner une autre Cellule D lorsqu'il y a une date d'inscrite, le total dans la case B

Donc: A-C(texte)+M ( date)total en B
A: 3
B
C P232323
D: 12-12-2017

Le but est de savoir combien de place il me reste pour inscription.

Donc, A case de départ, C (inscription faite), D (date de fermeture, donc 1 place se libère)

J'espère être claire, pas évident à expliquer.

Merci
Afficher la suite 

17 réponses

Répondre au sujet
Raymond PENTIER 44665 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 29 décembre 2017 Dernière intervention - 21 déc. 2017 à 03:11
+1
Utile
1
Il y a effectivement de multiples formules possibles ... En voici une autre :
=A1-SI(ESTTEXTE(C1);1;0)+SI(ESTNUM(D1);1;0)

Si Tichanoir sait qu'en C il ne peut y avoir que du texte ou rien du tout, et en D qu'une date ou rien du tout, on peut simplifier la formule et écrire :
=A1-SI(C1="";0;1)+SI(D1="";0;1)

Si au contraire il y a des risques que l'utilisateur du fichier saisisse en C autre chose que du texte et en D autre chose qu'une date, alors il faut prendre des précautions et écrire :
=A1-SI(ESTTEXTE(C1);1;0)+SI(CELLULE("format";D1)="D1";1;0)

Amicales salutations à tous.
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 22 déc. 2017 à 18:37
Merci beaucoup , cela a fonctionné. ! Joyeuses Fêtes et bonne retraite.
Commenter la réponse de Raymond PENTIER
Kwak_for_Ever 8 Messages postés samedi 16 décembre 2017Date d'inscription 22 décembre 2017 Dernière intervention - Modifié par Kwak_for_Ever le 19/12/2017 à 20:25
0
Utile
Bonsoir,

Je n'ai pas tout compris, mais voici ma solution :

=si(a="";;si(b="";,a-c+d))

A voir si cela convient.
Commenter la réponse de Kwak_for_Ever
Vaucluse 20898 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 29 décembre 2017 Dernière intervention - 19 déc. 2017 à 20:48
0
Utile
3
Bonsoir

on essaie avec

=SI(C1<>"";A1-1;A1)+SI(D1<>"";1;0)

reste à savoir comment vous "descendez" ça dans une colonne pour faire évoluer sur plusieurs lignes
Par exemple pour cumuler plusieurs lignes de ligne 2 à ligne 50:

valeur de départ en A1:

=A1-NB.SI($C$1:$C$50;"<>")+NB.SI($D$1:$D$50;">0")

crdlmnt

Kwak_for_Ever 8 Messages postés samedi 16 décembre 2017Date d'inscription 22 décembre 2017 Dernière intervention - 19 déc. 2017 à 21:48
Mais il ne faut pas figer les cellules, et laisser libre
Vaucluse 20898 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 29 décembre 2017 Dernière intervention > Kwak_for_Ever 8 Messages postés samedi 16 décembre 2017Date d'inscription 22 décembre 2017 Dernière intervention - 20 déc. 2017 à 07:41
ce n'est pas une formule à tirer, mais à placer hors champ dans une seule cellule pour avoir un résultat constant
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 28 déc. 2017 à 16:17
Merci mais j'ai plusieurs cellules en considérer.
Commenter la réponse de Vaucluse
gbinforme 14486 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 28 décembre 2017 Dernière intervention - 19 déc. 2017 à 22:45
0
Utile
2
Bonjour à tous,

J'ai compris un peu différemment, alors en A2 je mettrais
=SI(ESTNUM(D2);A1+1;SI(C2="";A1;A1-1))

Avec l'initial en A1 et la formule à tirer sur la colonne selon besoin.
Kwak_for_Ever 8 Messages postés samedi 16 décembre 2017Date d'inscription 22 décembre 2017 Dernière intervention - 20 déc. 2017 à 22:57
Bonsoir,

Vous connaissez les matricielles ?
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 28 déc. 2017 à 16:18
Non !
Commenter la réponse de gbinforme
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 21 déc. 2017 à 21:13
0
Utile
6
Merci j'essai et vous reviens !
Raymond PENTIER 44665 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 29 décembre 2017 Dernière intervention - 22 déc. 2017 à 21:06
Cette fois-ci, il te faudra joindre un fichier Excel !
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 28 déc. 2017 à 22:49
voici le document
https://www.cjoint.com/c/GLCvWCK0ohv

J'ai mis les colonnes à considérer orangées
Les lignes à sélectionner sont par CPE ex. F5:F12, etc...
Merci
Raymond PENTIER 44665 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 29 décembre 2017 Dernière intervention - 29 déc. 2017 à 05:26
Alors en C5 la formule sera
=B5-NBVAL(F5:F12)+NBVAL(M5:M12)
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 29 déc. 2017 à 16:44
Oui cela fonctionne, mais cela me donne le nombre de places restantes, Est-ce que vous croyez qu'il est possible de décortiqué les place allouées et les places restantes ? car les intervenantes veulent que le nombre de place restantes soient plus visibles, je ne peux pas faire B-C=D, car cela donne 2 et il me reste 6 places.
Je vous remercie de votre support !
Tichatnoir 9 Messages postés mardi 19 décembre 2017Date d'inscription 29 décembre 2017 Dernière intervention - 29 déc. 2017 à 18:43
Re bonjour M. Pentier, oublié ma demande, cela fonctionne.

Un gros merci pour le temps alloué pour ma demande.

Joyeuses Fêtes.
Commenter la réponse de Tichatnoir