Somme si avec fonction gauche [Résolu]

salsero75014 24 Messages postés mercredi 29 novembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 16:59 - Dernière réponse : Vaucluse 20831 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 8 décembre 2017 Dernière intervention
- 7 déc. 2017 à 16:13

Bonjour,

Je voudrais faire la somme des produit de la colonne h seulement si la colonne b contient l'expression "S/Total R2017"

j'ai tenté ca :

=SOMME.SI(B12:B659;"GAUCHE(S/Total R2017/20652;13)";H12:H659)

Mais ca me donne zéro

merci a vous



Afficher la suite 
24Messages postés mercredi 29 novembre 2017Date d'inscription 8 décembre 2017 Dernière intervention

5 réponses

Répondre au sujet
M-12 81 Messages postés lundi 22 septembre 2008Date d'inscription 7 décembre 2017 Dernière intervention - 6 déc. 2017 à 17:17
+1
Utile
Bonjour,
Plutôt
=SOMME.SI(B12:B659;"S/Total R2017*";H12:H659) 
Commenter la réponse de M-12
DjiDji59430 1765 Messages postés samedi 19 avril 2008Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 17:20
+1
Utile
Bonjour,

Tu ne peux pas faire ça car cette fonction n'admet pas de "sous fonction" (gauche().
Tu dois passer par un sommeprod()

=sommeprod((GAUCHE($B$12:$B$659;13)="S/Total R2017")*($H$12:$H$659))

Cdlmnt
Commenter la réponse de DjiDji59430
salsero75014 24 Messages postés mercredi 29 novembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 18:46
0
Utile
Bonjour,

merci beaucoup, j'ai reussi tout simplement avec la première, bonne soirée à vous messieur :)
Commenter la réponse de salsero75014
salsero75014 24 Messages postés mercredi 29 novembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 7 déc. 2017 à 09:25
0
Utile
Bonjour, si maintenant je veux faire une somme si avec deux element, j'utilise la fonction somme si ensemble, mais ca me donne zéro:
Sachant que j'ai rajouté une colonne g pour avoir les nom partout je voudrais faire la somme seulement si colonne B j'ai "total insertion", et colonne G "invite media" :

=SOMME.SI.ENS(I14:I660;B14:B660;"S/Total insertion";G14:G660;"INVITE MEDIA")

mais ca me met zéro
Commenter la réponse de salsero75014
Vaucluse 20831 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 8 décembre 2017 Dernière intervention - 7 déc. 2017 à 16:13
0
Utile
Bonjour
alors si vous utilisez SOMME.SI.ENS
(ou tou ce qui SOMME.SI / NB.SI etc...
  • soit le code cherché est intégralement et seul écrit dans la colonne, vous pouvez écrire: "texte"
  • soit le code est inscrit n'importe où dans le texte de la colonne, ce qui donne "*texte*"
  • soit vous voulez le texte au début de celui la colonne "texte*"
  • ou à la fin:"*texte"

mais en aucun cas vous ne pouvez chercher un texte plus long que celui inscrit dans la colonne , ce qui semble être les cas e votre exemple
crdlmnt
Commenter la réponse de Vaucluse