Recherche de la première valeur non nulle, sur plusieurs colonne [Résolu]

Brasiligun 113 Messages postés mardi 29 décembre 2009Date d'inscription 7 décembre 2017 Dernière intervention - 6 déc. 2017 à 08:42 - Dernière réponse : ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention
- 7 déc. 2017 à 18:15
Bonjour, à tous

Je viens vous demander votre aide sur un petit, sujet

Je cherche à faire en sorte, que dans mon fichier excel comportant deux feuilles (BDD et Besoin), que pour chaque "article" présent dans la feuilles besoin (à partir de A3), que dans la colonne F, je renvois à partir de la feuille "BDD", la 1ière date (ou valeur non nulle), qui correspond à mon article dans la feuille besoin

Par exemple: (voir mon fichier)

L'article 10106 à pour 1ière valeur non nulle en Janvier 2018 dans la feuille BDD, donc je renvois dans la feuille "Besoin" Janvier 2018 pour l'article 10106

L'article 10114 à pour 1ière valeur non nulle en Février 2018 dans la feuille BDD, donc je renvois dans la feuille "Besoin" Fevrier 2018 pour l'article 10114

Donc vraiment le 1ier mois pour lequel la valeur n'est pas nulle par article

Pour l'instant je l'ai fait avec une RechercheV sur 3 mois seulement, mais je sais que ce n'est pas terrible terrible. Si vous avez des conseils, ou des suggestions, même s'il faut partir sur l'utilisation de VBA je suis partant

"=SI(RECHERCHEV(A3;BDD!A:AC;8;FAUX)>0;"Déc-17";SI(RECHERCHEV(A3;BDD!A:AC;9;FAUX)>0;"Janv-18";SI(RECHERCHEV(A3;BDD!A:AC;10;FAUX)>0;"Fév-18";"")))

Le fichier: http://www.cjoint.com/c/GLghPRKXU5o



Un grand merci de m'avoir lu et merci de votre aide :p


Cordialement
Afficher la suite 
113Messages postés mardi 29 décembre 2009Date d'inscription 7 décembre 2017 Dernière intervention

3 réponses

Répondre au sujet
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - 6 déc. 2017 à 20:42
0
Utile
2
Bonjour

Une solution (à tester) avec macro
http://www.cjoint.com/c/GLgtPpvgUfB

Cdlmnt
Brasiligun 113 Messages postés mardi 29 décembre 2009Date d'inscription 7 décembre 2017 Dernière intervention - 7 déc. 2017 à 07:45
Super c'est exactement ça! Un grand merci

Je l'avais fait avec une grosse formule à base de 22 recherchev, mais ta méthode est beaucoup plus aboutie!

Merci à toi


Cordialement
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - 7 déc. 2017 à 18:15
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en dessous du titre de ton premier message)

Cdlmnt
Commenter la réponse de ccm81