Formule Excel SI Cellule contient mots [Résolu]

FormulaSeeker 7 Messages postés mardi 5 décembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 5 déc. 2017 à 19:33 - Dernière réponse : Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 7 déc. 2017 à 16:05
Bonjour,

Je suis désespérément à la recherche de la bonne formule qui me permettrait de catégoriser plus d'un millier de magasin :

En A1 j'ai par exemple :
Magasin XXX type Super Adresse XXX
Magasin XXX type Hyper Adresse XXX
Magasin XXX Type Express Adresse XXX
Magasin XXX Type Marché Adresse XXX
Magasin XXX Type Utile Adresse XXX

J'ai donc 5 catégories de magasins différents. Je souhaite qu'en B1 s'affiche uniquement la catégorie type Super, Hyper, Express, etc

Sachant que toute case contenant "Utile" contiendra forcément "Express" mais pas l'inverse.

Voici donc la formule que j'essaye :

=SI(NB.SI(D2;"*Hyper U*";"Hyper U";SI(D2;"*Super U*";"Super U";SI(D2;"*Marché*";"Marché U";SI(D2;"*Utile*";"Utile";"U Express")))))

Cela ne fonctionne pas et Excel m'indique que j'ai entré un nombre de caractères trop important... Y a t il une possibilité pour qu'une formule puisse traiter 5 arguments de contenance ?

Je vous remercie beaucoup pour votre aide providentielle !
Afficher la suite 
7Messages postés mardi 5 décembre 2017Date d'inscription 8 décembre 2017 Dernière intervention

8 réponses

Répondre au sujet
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Vaucluse le 5/12/2017 à 19:49
+1
Utile
2
Bonsoir
voyez ici si ça vous convient et revenez si besoin:
https://mon-partage.fr/f/W3B2Nwgd/

note: pas plus d'un seul mot cherché par texte
adaptez la liste de référence et son adresse dans la formule à votre besoin
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
FormulaSeeker 7 Messages postés mardi 5 décembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 10:45
Bonjour !

Vous êtes mon héro du jour !

Merci mille fois :)
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 6 déc. 2017 à 11:20
Pas de quoi, je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse
via55 8788 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention - 5 déc. 2017 à 19:45
0
Utile
2
Bonsoir

Tu peux bien sur imbriquer plus de 5 Si mais ce qui pose problème dans ta formule c'est le NB.SI qui ne sert à rien ce devrait être :
=SI(D2;"*Hyper U*";"Hyper U";SI(D2;"*Super U*";"Super..;etc

Cdlmnt
Via
FormulaSeeker 7 Messages postés mardi 5 décembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 10:46
Bonjour,

Un grand merci d'avoir pris le temps de me répondre !

Excellente journée à vous !
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 7 déc. 2017 à 16:05
Salut Via, comment va?
es tu sur que ta formule fonctionne, avec un code SI qui n'utilise pas d'opérateur. Si, oui, dis moi comment, ça m'interèsse!
crdlmnt
Commenter la réponse de via55
Mike-31 15887 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 5 déc. 2017 à 19:51
0
Utile
1
Bonsoir,

si en colonne A tu as par exemple "Magasin XXX type Super Adresse XXX"
avec simplement Super
dans ta formule ne fais pas référence à Super U SI(D2;"*Super U*";"Super U";

ensuite tu écris que tes valeur sont colonne A et ta formule fait référence à la colonne D

alors si tes valeurs sont bien colonne A à partir de A1 ta première formule sera
=SI(NB.SI(A1;"*Super*")=1;"Super";SI(NB.SI(A1;"*Hyper*")=1;"Hyper";SI(NB.SI(A1;"*Express*")=1;"Express";SI(NB.SI(A1;"*Marché*")=1;"Marché";SI(NB.SI(A1;"*Utile*")=1;"Utile";"")))))
FormulaSeeker 7 Messages postés mardi 5 décembre 2017Date d'inscription 8 décembre 2017 Dernière intervention - 6 déc. 2017 à 10:45
Bonjour,

Un grand merci d'avoir pris le temps de me répondre !

Excellente journée !
Commenter la réponse de Mike-31