Calculer le nombre d'occurences d'une valeur par mois [Résolu]

Benjamin - 30 nov. 2017 à 19:25 - Dernière réponse :  Benjamin
- 1 déc. 2017 à 13:01
Bonjour,

Je rencontre une difficulté sur Excel. J'ai souvent trouvé le reste de mes réponses sur ce forum, c'est pour ça que je le poste ici, je suis sûr que l'un d'entre vous va réussir à trouver la solution :)

Comme dit dans le titre, j'aimerai trouver le nombre d'occurence d'une valeur dans un mois, je m'explique :

En colonne A : des dates au format jour entre le mois d'aout et le mois de décembre
En colonne B : Un prénom

En colonne A, il peut y avoir plusieurs fois la même date. Car ce tableau correspond en fait a des jours de présence.

Par exemple :


A B
02/11 Manu
04/11 Jean
08/11 Jean
11/11 Claire
11/11 Patrick
11/11 Manu
12/11 Patrick
13/11 Claire
14/11 Claire
14/11 Jean
14/11 Manu
15/11 Jean
15/11 Claire
16/11 Manu

Il n'y a ici que le mois de novembre pour l'exemple, mais dans mon vrai tableau c'est comme ça de début août à fin décembre.

J'ai un tableau à côté dans lequel je voudrai récupérer le nombre de fois que chaque valeur de la colonne B, apparaît par mois :

Aout Sept Oct Nov Dec
Jean
Claire
Patrick
Manu

J'ai essayé avec =nb.si.ens(B1:B39;D2;mois(A1:A39);11) ou D2 correspond à un prénom et 11 et la valeur correspondante au mois de novembre.

Ca me retourne une erreur que je n'arrive pas à résoudre.

Est-ce qu'il faut que je fasse un tableau croisé dynamique ? J'aimerai bien m'en passer si possible, c'est un peu compliquer à gérer je trouve.

Merci beaucoup pour votre aide !

Afficher la suite 

4 réponses

Répondre au sujet
mdo100 89 Messages postés jeudi 9 décembre 2010Date d'inscription 8 décembre 2017 Dernière intervention - Modifié par mdo100 le 30/11/2017 à 20:36
+1
Utile
Bonsoir Benjamin,

Une proposition dans le fichier joint:

http://www.cjoint.com/c/GKEtKdXvj1u

Cordialement.
Commenter la réponse de mdo100
via55 8800 Messages postés mercredi 16 janvier 2013Date d'inscription 15 décembre 2017 Dernière intervention - 30 nov. 2017 à 20:28
0
Utile
Bonsoir Benjamin

Tu ne peux pas utiliser MOIS avec NB.SI.ENS mais tu peux encadrer les dates
=NB.SI.ENS(B1:B39;D2;A1:A39;">=" & DATEVAL("01/11/2017");A1:A39;"<" & DATEVAL("01/12/2017"))

Cdlmnt
Via
Commenter la réponse de via55
0
Utile
Bonjour Via,

Il semblerait que ca fonctionne ! Merci beaucoup. Pouvez-vous me donner quelques explications ?

Tout d'abord sur la formule qui répond à ma question : =SOMMEPROD((MOIS(1&D$2)=MOIS($A$2:$A$15))*($C3=$B$2:$B$15))

Puis sur cette formule qui rempli automatiquement les noms :

=SIERREUR(INDEX($B$2:$B$15;EQUIV(0;INDEX(NB.SI(C$2:C5;$B$2:$B$15);0;0);0)); "")

Merci encore en tout cas !
Commenter la réponse de Benjamin
0
Utile
Pardon, je me suis trompé, je voulais parler de la réponse de mdo100 !

Désolé :)
Commenter la réponse de Benjamin