Formule avec datedif [Résolu]

vmail - 30 nov. 2017 à 16:06 - Dernière réponse :  vmail
- 1 déc. 2017 à 12:00
Bonjour,

je recherche une formule avec datedif afin de calculer le repeat de commande de de chaque clients

Colonne b = date d'achat
colone c = nom du client
les commande sont par ordre chronologique et donc les noms de ne suivent pas. (fichier de 46773 lignes.

merci

Afficher la suite 

8 réponses

Répondre au sujet
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:21
0
Utile
Bonjour,

En D2, à tirer vers le bas :
=SIERREUR(DATEDIF(INDEX(C$1:C1;EQUIV(B2;B$1:B1;0));C2;"d");"")

Ou encore :
=SIERREUR(C2-INDEX(C$1:C1;EQUIV(B2;B$1:B1;0));"")
Commenter la réponse de Patrice33740
0
Utile
4
Merci de votre réponse mais aucun résultat ne s'affiche dans la cellule malgré la formule elle reste "vide"
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:33
Désolé, j'avais inversé les colonnes nom et date, ce serait plutot :
=SIERREUR(DATEDIF(INDEX(B$1:B1;EQUIV(C2;C$1:C1;0));B2;"d");"")
ou
=SIERREUR(B2-INDEX(B$1:B1;EQUIV(C2;C$1:C1;0));"")
vmail > Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 17:08
Merci mais le résultat est le même les cellules demeurent vide (aucun résultat ne s'affiche). j'avoue que je n'y comprends pas grand chose.
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention > vmail - 30 nov. 2017 à 17:54
Les dates sont-elles réellement des dates ?
Ne serait-ce pas des textes ?

En alignement standard (ni droite, ni centrer, ni gauche, ni justifié), sont-elles alignées à droite ou à gauche ?
vmail > Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 1 déc. 2017 à 11:06
les dates sont au format date et centré
Commenter la réponse de vmail
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 18:18
0
Utile
Re,

Désolé mais la formule précédente n'est pas sufisnte.

Voici un exemple avec des calculs intermédiaires:
https://mon-partage.fr/f/NIZamAgh/
Commenter la réponse de Patrice33740
0
Utile
super cela fonctionne merci
Commenter la réponse de vmail