Attribuer une valeur par ordre croissant [Résolu]

mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention - 30 nov. 2017 à 15:32 - Dernière réponse : mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention
- 1 déc. 2017 à 08:22
Bonjour,

Je recherche une formule pour un tableau excel, je prends un contexte plus simple pour vous expliquer :
Dans la colonne A, il y a une liste déroulante pour choisir "Bleu" ou "Rouge"
L'idée c'est d'attribuer un numéro pour chaque produit "bleu" ou "rouge" entré.
Je m'explique : si dans la 1er ligne, je choisis "bleu" je souhaiterais dans la colonne B attribuer un numéro "21800001" (oui, je ne souhaite pas commencé à 1 sinon ça serait trop simple).
Ligne suivante : je choisis encore "bleu", alors dans la colonne B je souhaiterais attribuer automatiquement "21800002"
Ligne suivante : je choisis cette fois ci "rouge", je voudrais que dans la colonne B, le compteur recommence à "21800001"
Et au final je voudrais que pour les lignes suivantes, quand je choisis rouge, ça prenne le chiffre suivant le dernier produit rouge et quand je choisis bleu ça prenne le chiffre suivant le dernier produit bleu
Afficher la suite 
6Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention

9 réponses

Répondre au sujet
mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention - 30 nov. 2017 à 15:32
0
Utile
Merci d'avance!!!
Commenter la réponse de mlacoste
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 15:40
0
Utile
7
Bonjour,

Avec la formule :
=NB.SI($A$2:$A2;$A2)+21800000
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention > mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:24
Pas besoin de SI(), as-tu essayé la formule (en C2) ?
mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention > Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:31
Ce que j'ai présenté au dernier message est ce que je souhaite obtenir automatiquement. A la base, seulement la colonne A est remplie avec "rouge" ou "bleu" et je souhaite qu'en B, grâce à une formule, cela attribue un numéro par ordre croissant.
J'ai essayé la fomule =NB.SI(A:A;A1)+21800000 (dans B1)
Cela donne 21800001
Mais dans une ligne suivante, si je choisie encore "rouge", cela change également B1 en 21800002 car cela compte toutes les cases en A où il ya "rouge"
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention > mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:37
La formule est prévue pour commencer en B2, Edit pour B1;
=NB.SI($A$1:$A1;$A1)+21800000
Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention > Patrice33740 6306 Messages postés dimanche 13 juin 2010Date d'inscription 7 décembre 2017 Dernière intervention - 30 nov. 2017 à 16:41
A tirer vers le bas
mlacoste 6 Messages postés jeudi 30 novembre 2017Date d'inscription 1 décembre 2017 Dernière intervention - 1 déc. 2017 à 08:22
Merci beaucoup, j'ai enfin réussi grâce à vous ! Bonne journée !
Commenter la réponse de Patrice33740