Concatener à conditions [Résolu]

Ichou45 7 Messages postés mercredi 28 décembre 2016Date d'inscription 30 novembre 2017 Dernière intervention - 29 nov. 2017 à 19:06 - Dernière réponse :  Ichou45
- 5 déc. 2017 à 15:02
Bonsoir,

J'ai une feuille avec 2 colonnes :

A = les numeros de bon de livraison.
B = les articles livrés par bon de livraison

Pour y voir plus clair ci joint un exemple :

http://www.cjoint.com/c/GKDrY3RyBfw

En C je devais avoir concatener tout les enregistrements de la colonne B selon le numéro du BL.

Merci d'avance.
Afficher la suite 
7Messages postés mercredi 28 décembre 2016Date d'inscription 30 novembre 2017 Dernière intervention

8 réponses

Répondre au sujet
Mike-31 15879 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 6 décembre 2017 Dernière intervention - Modifié par Mike-31 le 29/11/2017 à 19:25
0
Utile
1
Bonsoir,

on peut le faire avec un code VBA si tu as quelques notions de VBA


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Ichou45 7 Messages postés mercredi 28 décembre 2016Date d'inscription 30 novembre 2017 Dernière intervention - 29 nov. 2017 à 19:28
Non merci Mike-31 sans vba si possible.
Commenter la réponse de Mike-31
Mike-31 15879 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 6 décembre 2017 Dernière intervention - Modifié par Mike-31 le 29/11/2017 à 19:48
0
Utile
1
Re,

regarde avec ce genre de formule sur la première ligne exemple en F2

=SI(B2<>"";F1&B2;"")

ensuite on verra de masquer les valeurs inutiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Ichou45 7 Messages postés mercredi 28 décembre 2016Date d'inscription 30 novembre 2017 Dernière intervention - 30 nov. 2017 à 14:27
Bonjour,
J'ai essayé mais ca ne fusionne que 2 cellules a la fois, un bl ca peut contenir min 1 article max 25 articles.

Je teste actuellement =si(et(a1<>"";b1<>"";a2="");b1&" / "&b2;""))
Reste a ajouter une formule a la précédente dans le cas ou a1<>"" et a2="" et b1<>"" et b2<>"" pour fusionner les 3 cellules suivante, la dernière etant vide ca va renvoyer une erreur....

Des idées ?
Commenter la réponse de Mike-31
Mike-31 15879 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 6 décembre 2017 Dernière intervention - 30 nov. 2017 à 14:53
0
Utile
1
Re,

tu as certainement mal saisi la formule
regarde ce fichier tu as deux type d'affichage soit la concaténation en fin de groupe soit en début
ajoute des valeurs jusqu'à la ligne 40
http://www.cjoint.com/c/GKEn1lTtGoj
Ichou45 7 Messages postés mercredi 28 décembre 2016Date d'inscription 30 novembre 2017 Dernière intervention - 30 nov. 2017 à 22:49
Re,

Ça marche tres bien, juste un dernier souci de separateur d'articles soit par " / " ou " ; " je fais comment ?

Merci beaucoup pour ta solution, c'est top.
Commenter la réponse de Mike-31
Mike-31 15879 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 6 décembre 2017 Dernière intervention - 30 nov. 2017 à 23:27
0
Utile
Re,

sur mon fichier en C2 colle cette formule et incrémente la vers le bas
=SI(B2<>"";C1&B2&"/";"")

ou en D10 cette formule et incrémente la vers le haut
=SI(B10<>"";B10&"/"&D11;"")

en retour donne moi la formule retenue on supprimera la fraction de fin
Commenter la réponse de Mike-31
0
Utile
Merci pour ta précieuse aide Mike-31. Probleme resolu en entier. Formule retenue celle de la colonne B.

Merci.
Commenter la réponse de Ichou45